Search
Question: BiocInstaller wants version of R that is not available yet
0
gravatar for matt.s.leslie
12 months ago by
matt.s.leslie0 wrote:

I'm getting an install error I haven't been able to surmount. I'm running R Version 3.3.1 through RStudio Version 0.99.903 on Mac OS 10.10.5.

--------------------------------------------

Here is the code I'm running with the error:

>rm(list = ls())
>install.packages("devtools", dependencies=TRUE)
>library(devtools)
>install_github("NESCent/MINOTAUR", build_vignettes=TRUE)

Downloading GitHub repo NESCent/MINOTAUR@master
from URL https://api.github.com/repos/NESCent/MINOTAUR/zipball/master
Installing MINOTAUR
Downloading GitHub repo Bioconductor-mirror/BiocInstaller@master
from URL https://api.github.com/repos/Bioconductor-mirror/BiocInstaller/zipball/master
Installing BiocInstaller
'/Library/Frameworks/R.framework/Resources/bin/R' --no-site-file --no-environ --no-save --no-restore --quiet \ CMD INSTALL \
'/private/var/folders/tb/x8ht0yyn0fnb9j301ynw377r0000gn/T/RtmpenL3Be/devtools5f1722a9343/Bioconductor-mirror-BiocInstaller-9965cc7' \
--library='/Library/Frameworks/R.framework/Versions/3.3/Resources/library' --install-tests

ERROR: this R is version 3.3.1, package 'BiocInstaller' requires R >= 3.4.0

Error: Command failed (1)

----------------------------------------------

I then tried all iterations of installing Bioconducter from the website (https://www.bioconductor.org/install/) before/after installing 'devtools' to try to ensure BiocInstaller was the correct version:

>source("https://bioconductor.org/biocLite.R")
>biocLite()

But it still seems like the version of BioInstaller is dependent on a version of R that hasn't been released yet - at least for Mac OS.

Any suggestions would be greatly appreciated,

Matt

 

ADD COMMENTlink modified 12 months ago by Martin Morgan ♦♦ 20k • written 12 months ago by matt.s.leslie0
0
gravatar for Martin Morgan
12 months ago by
Martin Morgan ♦♦ 20k
United States
Martin Morgan ♦♦ 20k wrote:

devtools is trying to install the devel version of Bioconductor (from the 'master' branch of github/BIoconductor-mirror/BiocInstaller. The devel version of Biocoductor currently depends on the devel version (aka version 3.4) of R. Work around this by cleaning up your installation remove.packages("BiocInstaller") and then in a new session installing BiocInstaller via source("https://bioconductor.org/biocLite.R"). Then install the github package using upgrade_dependencies=FALSE argument, either

devtools::install_github("NESCent/MINOTAUR", upgrade_dependencies=FALSE)

or

biocLite("NESCent/MINOTAUR", upgrade_dependencies=FALSE)

(biocLite just delegates to devtools). This should be posted as an issue to the devtools github repository.

Actually looking more at this, the DESCRIPTION file of NESCent/MINOTAUR indicates that it will use

Remotes: github::Bioconductor-mirror/BiocInstaller,
        github::Bioconductor-mirror/OmicCircos, github::rstudio/DT

implying that the author intends for the package to be using the devel (implicit @master github remote) branch of R and Bioconductor. Whether this is intentional or not is unclear, but should be taken up as a MINOTAUR issue. (devtools I think does the right thing with Bioconductor dependencies, without specifying a remote).

ADD COMMENTlink modified 12 months ago • written 12 months ago by Martin Morgan ♦♦ 20k

Hi Martin,

I am having the same issue with the "TCGAworkflow" package getting the same error:

ERROR: this R is version 3.3.2, package 'TCGAWorkflow' requires R >=  3.4.0
Error: Command failed (1)
In addition: Warning message:
package ‘TCGAWorkflowData’ is not available (as a binary package for R version 3.3.2) 

I have proceeded as you recommended but I am still getting the same message. Any idea? Thanks

IOM

ADD REPLYlink written 8 months ago by IOM20

I'm not really sure what you've done; the error message says that you should be using R-devel (aka, R version 3.4.0) to use the version of TCGAworkflow that you're trying to use. You haven't really given enough information for a full diagnosis, e.g., how you're trying to install TCGAworkflow and the output of your sessionInfo() (R command).

ADD REPLYlink written 8 months ago by Martin Morgan ♦♦ 20k

Maybe related ... I'm currently reviewing a package called TCGAWorkflow and the accompanying TCGAWorkflowData. They aren't approved yet so they aren't in the Bioconductor repos. Any installation of both packages would have to be (on your own) from the github repos.

ADD REPLYlink written 8 months ago by Valerie Obenchain ♦♦ 6.4k

Hi Valerie,

I tried to install those packages and got this error

> devtools::install_github("BioinformaticsFMRP/TCGAWorkflowData")
Downloading GitHub repo BioinformaticsFMRP/TCGAWorkflowData@master
from URL https://api.github.com/repos/BioinformaticsFMRP/TCGAWorkflowData/zipball/master
Installing TCGAWorkflowData
"C:/R/R-3.3.2/bin/x64/R" --no-site-file --no-environ --no-save --no-restore --quiet CMD INSTALL  \
  "C:/Users/iooo/AppData/Local/Temp/RtmpUhn8Yc/devtools1b14454e9e5/BioinformaticsFMRP-TCGAWorkflowData-3f36003" --library="C:/R/R-3.3.2/library"  \
  --install-tests 

ERROR: this R is version 3.3.2, package 'TCGAWorkflowData' requires R  >= 3.4.0

I did what Martin suggested  (remove.packages("BiocInstaller") and then in a new session installing BiocInstaller via source("https://bioconductor.org/biocLite.R"). Then install the github package using upgrade_dependencies=FALSE argument) but still get the same error.

ADD REPLYlink written 8 months ago by IOM20

Re-installing BiocInstaller will not help. You need to be using R devel (version >=3.4.0) to use these packages. Your R is 3.3.2. If you do upgrade to R 3.4.0, you need to (manually) install the data package before the software package; because these packages are not in the Bioconductor repo the dependencies can't be managed by functions in BiocInstaller.

These packages are not ready for prime time and I would suggest talking with the author before trying to use them. The last time I checked the workflow took over 30 minutes to run and required gigabytes of disk space. Because these packages are not yet approved, any further installation problems you have should be taken up with the author. 

Valerie

ADD REPLYlink written 8 months ago by Valerie Obenchain ♦♦ 6.4k

Hi Valerie,

Thanks for the explanation, I did not know that. Cheers

IOM

ADD REPLYlink written 8 months ago by IOM20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 159 users visited in the last hour