update the version of GenomicRanges
1
0
Entering edit mode
jial2 • 0
@jial2-7016
Last seen 4.9 years ago
United States

Dear Users,

I recently updated R version from 3.2 to 3.3 for the purpose of some package requirements. It needs to update package GenomicRanges to higher version, the current version of GenomicRanges is 1.22.4.
I used

source("https://bioconductor.org/biocLite.R")

biocLite("GenomicRanges")

to reinstall GenomicRanges, it is supposed to install v1.26.2 via the link

http://bioconductor.org/packages/release/bioc/html/GenomicRanges.html

After the installation, the version installed is still v1.22.4.
I tried to use

R CMD INSTALL --library=~/Downloads/GenomicRanges_1.26.1.tar.gz

There is error message "Error: ERROR: no packages specified".

I also tried to use

install.packages("GenomicRanges",lib="~/Downloads/GenomicRanges_1.26.1.tar.gz")

It shows as below: Warning in install.packages("GenomicRanges", lib = "/Users/jial2/Downloads/GenomicRanges_1.26.1.tar.gz") :   'lib = "/Users/jial2/Downloads/GenomicRanges_1.26.1.tar.gz"' is not writable Would you like to use a personal library instead?  (y/n) y Warning message: package ‘GenomicRanges’ is not available (for R version 3.3.2)

Please let me know how to update the version of GenomicRanges.

Thanks so much, it's been highly appreciated.
E

genomicranges • 634 views
ADD COMMENT
1
Entering edit mode

You need to show the output of sessionInfo().

ADD REPLY
1
Entering edit mode
theobroma22 ▴ 10
@theobroma22-11920
Last seen 4.9 years ago

I would first uninstall the library, then try to install it again. 

ADD COMMENT

Login before adding your answer.

Traffic: 372 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6