Finding the correct version of DESeq2 for my version of R (3.6.1)
1
0
Entering edit mode
Mick • 0
@biomickwatson
Last seen 8 weeks ago
United States

Hello

I have R version 3.6.1 on Linux and this is pretty immoveable due to dependencies of other packages. I want to install DESeq2.

I run this using BiocManager::install and it fails to install.

The problem is a dependency, Hmisc, and the reason Hmisc fails is because of a dependency, foreign, and the reason foreign fails is because it equires R>4.0.0

I can't really upgrade my R version, and in any case, moving to R 4.0 has been very difficult for all sorts of reasons.

So how can I find a version of DESeq2 that will work with R 3.6.1 and why does BiocManager::install fail on these dependencies?

Thanks Mick


R version 3.6.1 (2019-07-05)
Platform: x86_64-conda_cos6-linux-gnu (64-bit)
Running under: Scientific Linux 7.5 (Nitrogen)

Matrix products: default
BLAS/LAPACK: /exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/r/lib/libopenblasp-r0.3.12.so

locale:
 [1] LC_CTYPE=en_GB.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_GB.UTF-8        LC_COLLATE=en_GB.UTF-8
 [5] LC_MONETARY=en_GB.UTF-8    LC_MESSAGES=en_GB.UTF-8
 [7] LC_PAPER=en_GB.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_GB.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] tximport_1.14.2 ggplot2_3.3.3

loaded via a namespace (and not attached):
 [1] fansi_0.4.2         withr_2.4.1         crayon_1.4.1
 [4] utf8_1.1.4          grid_3.6.1          R6_2.5.0
 [7] lifecycle_1.0.0     gtable_0.3.0        magrittr_2.0.1
[10] scales_1.1.1        pillar_1.5.1        rlang_0.4.10
[13] vctrs_0.3.6         ellipsis_0.3.1      tools_3.6.1
[16] glue_1.4.2          munsell_0.5.0       compiler_3.6.1
[19] pkgconfig_2.0.3     colorspace_2.0-0    BiocManager_1.30.10
[22] tcltk_3.6.1         tibble_3.1.0
error DESeq2 Install • 121 views
ADD COMMENT
0
Entering edit mode
@james-w-macdonald-5106
Last seen 1 hour ago
United States

The foreign package comes with R (it's a recommended package) and should already be installed. I actually have two versions in my R-3.6.1 install:


> z[row.names(z) %in% c("DESeq2","Hmisc","foreign"),c(1:3,5)]
        Package   LibPath                                 Version 
DESeq2  "DESeq2"  "/share/groups/edge/R/R-3.6.1"          "1.26.0"
foreign "foreign" "/share/groups/edge/R/R-3.6.1"          "0.8-75"
Hmisc   "Hmisc"   "/share/groups/edge/R/R-3.6.1"          "4.4-0" 
foreign "foreign" "/share/apps/R/R-3.6.1/lib64/R/library" "0.8-71"
        Depends                                                                           
DESeq2  "S4Vectors (>= 0.23.18), IRanges, GenomicRanges,\nSummarizedExperiment (>= 1.1.6)"
foreign "R (>= 3.0.0)"                                                                    
Hmisc   "lattice, survival (>= 3.1-6), Formula, ggplot2 (>= 2.2)"                         
foreign "R (>= 3.0.0)"

You can see that there is a version in the site-wide directory, and that's the one you should have, and it should be there for sure. If you need to install foreign then something unusual has happened to your R installation, and it probably happened at a higher level than you (unless you have sudo privileges) can do anything about. You probably need your sysadmin to get a version like say 0.8-71 and install it where it's supposed to go, after which things should be OK.

0
Entering edit mode

Mick - I inadvertently hit Enter early. You'll need to go to the site to see my full answer.

ADD REPLY

Login before adding your answer.

Traffic: 559 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6