ChemmineOB expects libopenbabel.7.dylib but latest OpenBabel 2.4.1 contains libopenbabel.5.dylib
0
0
Entering edit mode
adelenelai • 0
@d70b98e5
Last seen 7 weeks ago
Europe

Hi, I'm having problems loading ChemmineOB and would be grateful for any help.

library(ChemmineOB)

gives

Error: package or namespace load failed for ‘ChemmineOB’:
 .onLoad failed in loadNamespace() for 'ChemmineOB', details:
  call: dyn.load(file, DLLpath = DLLpath, ...)
  error: unable to load shared object '/Library/Frameworks/R.framework/Versions/4.1/Resources/library/ChemmineOB/libs/ChemmineOB.so':
  dlopen(/Library/Frameworks/R.framework/Versions/4.1/Resources/library/ChemmineOB/libs/ChemmineOB.so, 10): Library not loaded: /usr/local/opt/open-babel/lib/libopenbabel.7.dylib
  Referenced from: /Library/Frameworks/R.framework/Versions/4.1/Resources/library/ChemmineOB/libs/ChemmineOB.so
  Reason: image not found

From this error message, it looks like ChemmineOB.so is trying to load libopenbabel.7.dylib.

However, the latest OpenBabel 2.4.1 does not contain this dylib, but only libopenbabel.5.dylib.

(I downloaded Open Babel 2.4.1 per Dan Tenenbaum's instructions and successfully installed as instructed here (including sudo make install). Tested OpenBabel and it works fine.

Does anyone have any ideas?

> sessionInfo()
R version 4.1.0 (2021-05-18)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Mojave 10.14.6

Matrix products: default
BLAS:   /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/4.1/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] ChemmineR_3.44.0 Rcpp_1.0.7      

loaded via a namespace (and not attached):
 [1] pillar_1.6.2        compiler_4.1.0      BiocManager_1.30.16 bitops_1.0-7       
 [5] base64enc_0.1-3     tools_4.1.0         zlibbioc_1.38.0     digest_0.6.27      
 [9] lifecycle_1.0.0     tibble_3.1.3        gtable_0.3.0        pkgconfig_2.0.3    
[13] png_0.1-7           rlang_0.4.11        DBI_1.1.1           gridExtra_2.3      
[17] vctrs_0.3.8         htmlwidgets_1.5.3   grid_4.1.0          DT_0.18            
[21] glue_1.4.2          R6_2.5.0            fansi_0.5.0         ggplot2_3.3.5      
[25] magrittr_2.0.1      scales_1.1.1        ellipsis_0.3.2      htmltools_0.5.1.1  
[29] colorspace_2.0-2    rsvg_2.1.2          utf8_1.2.2          RCurl_1.98-1.3     
[33] munsell_0.5.0       crayon_1.4.1        rjson_0.2.20     
cheminf ChemmineOB Cheminformatics ChemmineR • 81 views
ADD COMMENT
0
Entering edit mode

Just realised that OpenBabel moved from Sourceforge to Github, and the latest version is in fact 3.1.1.

Going to install that now..

ADD REPLY

Login before adding your answer.

Traffic: 443 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6