oligo package blas error
1
0
Entering edit mode
ch_el ▴ 10
@ch_el-22279
Last seen 26 days ago
Spain

Hello, I having the error that has been mentioned before in the rma function of the oligo package. That one

eset <- rma(dat)
Background correcting
Error in basicRMA(pms, pnVec, normalize, background) : 
  ERROR; return code from pthread_create() is 22

sessionInfo()
R version 4.1.1 (2021-08-10)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 20.04.3 LTS

Matrix products: default
BLAS/LAPACK: /opt/OpenBLAS/lib/libopenblas_zenp-r0.3.15.so

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C               LC_TIME=es_ES.UTF-8       
 [4] LC_COLLATE=en_US.UTF-8     LC_MONETARY=es_ES.UTF-8    LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=es_ES.UTF-8       LC_NAME=C                  LC_ADDRESS=C              
[10] LC_TELEPHONE=C             LC_MEASUREMENT=es_ES.UTF-8 LC_IDENTIFICATION=C

I have tried choosing the alternatives to use blas instead of openblas, since I read online that you have to downgrade it or use blas instead, but it doesn't seem to work.

This is what I have selected

sudo update-alternatives --config liblapack.so.3-x86_64-linux-gnu
There are 2 choices for the alternative liblapack.so.3-x86_64-linux-gnu (providing /usr/lib/x86_64-linux-gnu/liblapack.so.3).

  Selection    Path                                                       Priority   Status
------------------------------------------------------------
  0            /usr/lib/x86_64-linux-gnu/openblas-pthread/liblapack.so.3   100       auto mode
* 1            /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3             10        manual mode
  2            /usr/lib/x86_64-linux-gnu/openblas-pthread/liblapack.so.3   100       manual mode

Press <enter> to keep the current choice[*], or type selection number: 1

sudo update-alternatives --config libblas.so.3-x86_64-linux-gnu
There are 2 choices for the alternative libblas.so.3-x86_64-linux-gnu (providing /usr/lib/x86_64-linux-gnu/libblas.so.3).

  Selection    Path                                                     Priority   Status
------------------------------------------------------------
  0            /usr/lib/x86_64-linux-gnu/openblas-pthread/libblas.so.3   100       auto mode
* 1            /usr/lib/x86_64-linux-gnu/blas/libblas.so.3               10        manual mode
  2            /usr/lib/x86_64-linux-gnu/openblas-pthread/libblas.so.3   100       manual mode

Press <enter> to keep the current choice[*], or type selection number: 1

But when I open R after it still seems to be pointing to the openblas path I attached in the first session info.

Any idea on how to fix it?

Many thanks!

rma openblas blas oligo • 103 views
ADD COMMENT
1
Entering edit mode
Guido Hooiveld ★ 3.0k
@guido-hooiveld-2020
Last seen 2 days ago
Wageningen University, Wageningen, the …

This likely has to do with an issue of preprocessCore. Disabling its internal threading while installing preprocessCore has been reported to solve the problem in a similar case. Check here on how to do that (the last post): Minfi issue: return code from pthread_create() is 22

ADD COMMENT
0
Entering edit mode

Resolved! Many thanks!

ADD REPLY

Login before adding your answer.

Traffic: 250 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6