Need help for ProStaR Stand-alone install
0
0
Entering edit mode
@174b85b6
Last seen 7 weeks ago
Canada

Hi,

I'm not sure if I'm doing something wrong, but can't seem to start the GUI with Prostar (as indicated in the manual). Followed the instruction in Prostar manual (i'm using Rstudio in linux) and looks like I have all dependencies. Bioconductor install seems ok since I've validated my BiocManager and get a "TRUE" output.

Can someone let me know if I'm missing something or could it be an issue with using R 4.1.2?

Thanks

please also include the results of running the following in an R session

library(Prostar)

Prostar()

Error in Prostar() : could not find function "Prostar"

sessionInfo( )

R version 4.1.2 (2021-11-01) Platform: x86_64-pc-linux-gnu (64-bit) Running under: Ubuntu 20.04.3 LTS

Matrix products: default BLAS: /usr/lib/x86_64-linux-gnu/blas/libblas.so.3.9.0 LAPACK: /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3.9.0

locale: [1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8
[5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8 LC_PAPER=en_US.UTF-8 LC_NAME=C
[9] LC_ADDRESS=C LC_TELEPHONE=C LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages: [1] stats graphics grDevices utils datasets methods base

other attached packages: [1] Prostar_1.26.1

loaded via a namespace (and not attached): [1] BiocManager_1.30.16 compiler_4.1.2 tools_4.1.2
```

Prostar • 322 views
ADD COMMENT
1
Entering edit mode

This is a little bug with the Prostar() function. It will be fixed in the version 1.26.3 which will be available in a few days on Bioconductor

ADD REPLY
0
Entering edit mode

Thank you for answering.

I've just updated to Prostar v1.26.3 and confirm that the Prostar() command now works in R for me on linux.

Best regards

ADD REPLY
0
Entering edit mode

*** With v1.26.4 the Prostar() command do work and open in browser.

Altough I'm having new issues with data convert since.

see post Problems with Prostar v1.26.4 - issue with convert data prior to filtering

ADD REPLY
0
Entering edit mode

Hi, I have exactly the same problem. I'm using R.4.1.2 for Mac. As Benoit suggested, maybe it's an issue with R.4.1.2 (I didn't found R.4.1.0 for Mac) ? Or maybe we made the same mistake (I'm not very familiar with R) ! Thanks !

library(Prostar) Prostar() Erreur dans Prostar() : impossible de trouver la fonction "Prostar" sessionInfo() R version 4.1.2 (2021-11-01) Platform: x86_64-apple-darwin17.0 (64-bit) Running under: macOS Big Sur 11.2.3

Matrix products: default BLAS: /Library/Frameworks/R.framework/Versions/4.1/Resources/lib/libRblas.0.dylib LAPACK: /Library/Frameworks/R.framework/Versions/4.1/Resources/lib/libRlapack.dylib

locale: [1] fr_FR.UTF-8/fr_FR.UTF-8/fr_FR.UTF-8/C/fr_FR.UTF-8/fr_FR.UTF-8

attached base packages: [1] stats graphics grDevices utils datasets methods base

other attached packages: [1] Prostar_1.26.2

loaded via a namespace (and not attached): [1] BiocManager_1.30.16 compiler_4.1.2 tools_4.1.2

ADD REPLY

Login before adding your answer.

Traffic: 269 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6