Installing Bioconductor
1
4
Entering edit mode
array chip ▴ 410
@array-chip-4136
Last seen 5 weeks ago
United States

Hello, I installed the latest R version 4.1.2, but now I got problem with installing the latest bioconductor version 3.14. Can anyone tell me what is going on? THANKS!

> if (!require("BiocManager", quietly = TRUE))
     install.packages("BiocManager")

> BiocManager::install()
'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories:
    CRAN: https://mirror.las.iastate.edu/CRAN

Bioconductor version 3.14 (BiocManager 1.30.16), R 4.1.2 (2021-11-01)
Installing package(s) 'BiocVersion'
Warning message:
In .inet_warning(msg) :
  package ‘BiocVersion’ is not available for Bioconductor version '3.14'

A version of this package for your version of R might be available elsewhere,
see the ideas at
https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages

> sessionInfo()
R version 4.1.2 (2021-11-01)
Platform: i386-w64-mingw32/i386 (32-bit)
Running under: Windows 10 x64 (build 19042)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] BiocManager_1.30.16 compiler_4.1.2      tools_4.1.2
Bioconductor • 386 views
ADD COMMENT
0
Entering edit mode

same thing, waiting for an answer

ADD REPLY
0
Entering edit mode

Thanks. good to know that it's not just my problem. At this point, I can not use any bioconductor packages.

ADD REPLY
0
Entering edit mode

Just echoing an observation from James (as of 5:40pm EST today):

> dim(available.packages("https://bioconductor.org/packages/3.14/bioc/src/contrib"))
[1]  5 17
> dim(available.packages("https://bioconductor.org/packages/3.13/bioc/src/contrib"))
[1] 1986   17
ADD REPLY
0
Entering edit mode

The core team is aware, and presumably working on it.

ADD REPLY
0
Entering edit mode

I am experiencing the same problem...

ADD REPLY
1
Entering edit mode
@herve-pages-1542
Last seen 10 hours ago
Seattle, WA, United States

Ah, only 2000 packages missing! Sorry for the little glitch. Should be repaired now.

H.

ADD COMMENT
1
Entering edit mode

yeah it works now! thanks for effort

ADD REPLY
0
Entering edit mode

yes, worked now. Thanks!

ADD REPLY

Login before adding your answer.

Traffic: 330 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6