STRINGdb : error with string_db$plot_network()
0
0
Entering edit mode
@wolfgang-raffelsberger-2876
Last seen 3 months ago
France

Dear experts,

suddenly I'm encountering an error when trying to visualize/plot a network with the package STRINGdb.

Here's what I ran (based on the package vignette) :

Any hints ?

library(STRINGdb)

data(diff_exp_example1)
head(diff_exp_example1)     # as in vignette
string_db <- STRINGdb$new( version="11.0b", species=9606, score_threshold=200, input_directory="")
example1_mapped <- string_db$map( diff_exp_example1, "gene", removeUnmappedRows = TRUE )

example1_mapped$STRING_id[1:5]      # mapping was successful
## I get : "9606.ENSP00000362560" "9606.ENSP00000481721" "9606.ENSP00000479355" "9606.ENSP00000369699" "9606.ENSP00000361072"

## try to plot
string_db$plot_network( example1_mapped$STRING_id[1:5] )
## Error in function (type, msg, asError = TRUE)  : 
##  error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac


## For completeness :

sessionInfo( )
## returns 
#R version 4.1.2 (2021-11-01)
#Platform: x86_64-w64-mingw32/x64 (64-bit)
#Running under: Windows 10 x64 (build 19042)
#
#Matrix products: default
#
#locale:
#[1] LC_COLLATE=French_France.1252  LC_CTYPE=French_France.1252   
#[3] LC_MONETARY=French_France.1252 LC_NUMERIC=C                  
#[5] LC_TIME=French_France.1252    
#
#attached base packages:
#[1] stats     graphics  grDevices utils     datasets  methods   base     
#
#other attached packages:
#[1] STRINGdb_2.4.2
#
#loaded via a namespace (and not attached):
# [1] igraph_1.2.8       hash_2.2.6.1       Rcpp_1.0.7         magrittr_2.0.1    
# [5] bit_4.0.4          rlang_0.4.12       fastmap_1.1.0      blob_1.2.2        
# [9] plyr_1.8.6         tools_4.1.2        caTools_1.18.2     png_0.1-7         
#[13] plotrix_3.8-2      KernSmooth_2.23-20 DBI_1.1.2          gtools_3.9.2      
#[17] bit64_4.0.5        RColorBrewer_1.1-2 vctrs_0.3.8        bitops_1.0-7      
#[21] RCurl_1.98-1.5     memoise_2.0.1      cachem_1.0.6       RSQLite_2.2.9     
#[25] gsubfn_0.7         compiler_4.1.2     gplots_3.1.1       chron_2.3-56      
#[29] sqldf_0.4-11       proto_1.0.0        pkgconfig_2.0.3

Thank's in advance, Wolfgang Raffelsberger

STRINGdb • 391 views
ADD COMMENT
0
Entering edit mode

I just realized that there is a more recent version of STRING (it seems the vignette is not up to date), ie 11.5, but I still get a similar "SSL certificate problem" when starting by declaring STRINGdb$new(version="11.5" ...

ADD REPLY
0
Entering edit mode

Dear Wolfgang,

As far as I know we haven't changed anything in our certificate setup. However it is not the first time that some users experience issues with trying to use secure protocol, it's usually curl/OS version dependent and I can't reproduce it. I'll submit a bug fix that adds an ability to connect to STRING server via standard http. This should solve the issue you are experiencing.

I'll write again when the bugfix goes public (should be beginning of next week).

Best, Damian.

ADD REPLY
0
Entering edit mode

Dear Wolfgang,

The bugfix has now been published. If you still can't plot the network in STRINGdb version >= 2.6.1 you can now add parameter protocol="http" when you create the STRINGdb object:

string_db <- STRINGdb$new( version="11.5", species=9606, score_threshold=200, input_directory="", protocol="http")

This should fix the issue with the certificates.

ADD REPLY
0
Entering edit mode

Dear Damian, thanks for the reply. Surprisingly 'BiocManager::install("STRINGdb")' always installes the version 2.4,x, although I'm using R 4.1.2. So I downloaded STRINGdb_2.6.1 and installed it manually (see sessionInfo() at end of message.

So I used string_db <- STRINGdb::STRINGdb$new( version="11.5", species=9606, score_threshold=200, input_directory="", protocol="http") and I got an error-message saying : unused argument (protocol = "http") I found "STRINGdb_2.7.1.t.zip" on https://www.bioconductor.org/packages/devel/bioc/html/STRINGdb.html, but again I get "unused argument (protocol = "http")"

Please not that the git address https://git.bioconductor.org/packages/STRINGdb mentioned on https://www.bioconductor.org/packages/release/bioc/html/STRINGdb.html doesnt work at all.

Thank's in advance; Wolfgang

For completeness: sionInfo() R version 4.1.2 (2021-11-01) Platform: x86_64-w64-mingw32/x64 (64-bit) Running under: Windows 10 x64 (build 19042)

Matrix products: default

locale: [1] LC_COLLATE=French_France.1252 LC_CTYPE=French_France.1252 LC_MONETARY=French_France.1252 LC_NUMERIC=C LC_TIME=French_France.1252

attached base packages: [1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached): [1] Rcpp_1.0.8 plyr_1.8.6 compiler_4.1.2 RColorBrewer_1.1-2 GenomeInfoDb_1.28.4 XVector_0.32.0
[7] bitops_1.0-7 tools_4.1.2 zlibbioc_1.38.0 bit_4.0.4 RSQLite_2.2.9 memoise_2.0.1
[13] pkgconfig_2.0.3 png_0.1-7 rlang_1.0.1 igraph_1.2.11 DBI_1.1.2 cli_3.1.1
[19] parallel_4.1.2 proto_1.0.0 fastmap_1.1.0 GenomeInfoDbData_1.2.6 httr_1.4.2 caTools_1.18.2
[25] Biostrings_2.60.2 S4Vectors_0.30.2 vctrs_0.3.8 gtools_3.9.2 IRanges_2.26.0 stats4_4.1.2
[31] bit64_4.0.5 Biobase_2.52.0 sqldf_0.4-11 R6_2.5.1 plotrix_3.8-2 hash_2.2.6.1
[37] AnnotationDbi_1.54.1 gsubfn_0.7 limma_3.48.3 magrittr_2.0.2 STRINGdb_2.6.1 blob_1.2.2
[43] org.Hs.eg.db_3.13.0 gplots_3.1.1 wrMisc_1.8.1 BiocGenerics_0.38.0 KEGGREST_1.32.0 KernSmooth_2.23-20
[49] RCurl_1.98-1.6 cachem_1.0.6 chron_2.3-56 crayon_1.5.0

ADD REPLY
0
Entering edit mode

Dear Wolfgang,

2.6.1 is the correct version. I just tested it, just to be sure. The argument is working and you can find it in the code, so it has no reason not to. Make sure you are still not using the old version. Something like this should do the job:

remove.packages("STRINGdb")
detach("package:STRINGdb", unload=TRUE)
install.packages("[path to source]", repos = NULL, type="source")
library(STRINGdb)

BiocManager::install("STRINGdb")' always installes the version 2.4,x,

I'm guessing you need to update to the newer bioconductor (3.14) to get the 2.6.x version of the app.

Please not that the git address https://git.bioconductor.org/packages/STRINGdb

This is not a link to click on. It's only used to clone the code from the git repository like this: "git clone https://git.bioconductor.org/packages/STRINGdb". Unless you want to have your own git repo of STRING to make changes, it is the same as downloading the source.

Best regards, Damian.

ADD REPLY
0
Entering edit mode

Dear Damian, great, (after a fresh reboot) all works now without any error-messages.

Wolfgang

ADD REPLY

Login before adding your answer.

Traffic: 526 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6