Cannot install Phyloseq and dada2
1
0
Entering edit mode
ymtan • 0
@517f63cc
Last seen 3 months ago
Australia

Hello all,

I have been having issues installing packages that I really need to use. Basically, I cannot download either Phyloseq or dada2 and I believe it's because I don't have GenomeInfoDbData. But at the same time, I cannot install GenomeInfoDbData because I can't seem to update the dependencies ("fansi" in my case is causing the problems). Which leads me to think I've incorrectly installed Rtools, but I followed the instructions and if i fun devtools::find_rtools(), the output is always TRUE. However, when I follow the installation guide and try to install jslonlite by source, I get an error.

I apologise if this isn't really a BioConductor problem, but I've tried very hard to solve my issue, and still can't figure it out. I really need access to the packages and I'm not sure what else to do. Any help would be very much appreciated.

install.packages("jsonlite", type = "source")
install.packages("jsonlite", type = "source")
Installing package into ‘C:/Users/ymt89/OneDrive/Documents/R/win-library/4.0’
(as ‘lib’ is unspecified)
--- Please select a CRAN mirror for use in this session ---
trying URL 'https://cloud.r-project.org/src/contrib/jsonlite_1.7.2.tar.gz'
Content type 'application/x-gzip' length 421716 bytes (411 KB)
downloaded 411 KB

& was unexpected at this time.

The downloaded source packages are in
        ‘C:\Users\ymt89\AppData\Local\Temp\RtmpWGM5Eg\downloaded_packages’
Warning message:
In install.packages("jsonlite", type = "source") :
  installation of package ‘jsonlite’ had non-zero exit status
>
BiocManager::install("GenomeInfoDbData")
Bioconductor version 3.12 (BiocManager 1.30.16), R 4.0.0 (2020-04-24)
Installing package(s) 'BiocVersion', 'GenomeInfoDbData'
trying URL 'https://bioconductor.org/packages/3.12/bioc/bin/windows/contrib/4.0/BiocVersion_3.12.0.zip'
Content type 'application/zip' length 8889 bytes
downloaded 8889 bytes

package ‘BiocVersion’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
        C:\Users\ymt89\AppData\Local\Temp\RtmpWGM5Eg\downloaded_packages
installing the source package ‘GenomeInfoDbData’

trying URL 'https://bioconductor.org/packages/3.12/data/annotation/src/contrib/GenomeInfoDbData_1.2.4.tar.gz'
Content type 'application/x-gzip' length 10673545 bytes (10.2 MB)
downloaded 10.2 MB

& was unexpected at this time.

The downloaded source packages are in
        ‘C:\Users\ymt89\AppData\Local\Temp\RtmpWGM5Eg\downloaded_packages’
Installation paths not writeable, unable to update packages
  path: C:/Program Files/R/R-4.0.0/library
  packages:
    boot, class, cluster, codetools, foreign, KernSmooth, lattice, MASS, Matrix, mgcv, nlme, nnet, spatial, survival
Old packages: 'fansi'
Update all/some/none? [a/s/n]: a

  There is a binary version available but the source version is later:
      binary source needs_compilation
fansi  0.5.0  1.0.2              TRUE

installing the source package ‘fansi’

trying URL 'https://cloud.r-project.org/src/contrib/fansi_1.0.2.tar.gz'
Content type 'application/x-gzip' length 480902 bytes (469 KB)
downloaded 469 KB

& was unexpected at this time.

The downloaded source packages are in
        ‘C:\Users\ymt89\AppData\Local\Temp\RtmpWGM5Eg\downloaded_packages’
Warning messages:
1: In .inet_warning(msg) :
  installation of package ‘GenomeInfoDbData’ had non-zero exit status
2: In install.packages(update[instlib == l, "Package"], l, repos = repos,  :
  installation of package ‘fansi’ had non-zero exit status

Thank you.

GenomeInfoDbData phyloseq dada2 • 361 views
ADD COMMENT
0
Entering edit mode

Did you notice this message:?

Installation paths not writeable, unable to update packages
  path: C:/Program Files/R/R-4.0.0/library

To me it seems you are running R with insufficient rights... and therefore packages cannot be installed in the C:/Program Files/.. directory.

ADD REPLY
0
Entering edit mode

Hello Guido,

Thanks for replying. I did read about insufficient rights when it comes to installing packages and how that can mess things up. But, for example, even if I specify the installation to my user library, it still doesn't work:

> install.packages("fansi", lib = "C:/Users/ymt89/OneDrive/Documents/R/win-library/4.0")

  There is a binary version available but the source version is later:
      binary source needs_compilation
fansi  0.5.0  1.0.2              TRUE

installing the source package ‘fansi’

trying URL 'https://cran.rstudio.com/src/contrib/fansi_1.0.2.tar.gz'
Content type 'application/x-gzip' length 480902 bytes (469 KB)
downloaded 469 KB

& was unexpected at this time.
Warning in install.packages :
  installation of package ‘fansi’ had non-zero exit status

The downloaded source packages are in
    ‘C:\Users\ymt89\AppData\Local\Temp\RtmpqaR9LR\downloaded_packages’
ADD REPLY
0
Entering edit mode
Mike Smith ★ 5.5k
@mike-smith
Last seen 6 hours ago
EMBL Heidelberg / de.NBI

I'm worried by the repeated line with & was unexpected at this time.

When you're installing a source package you'd expect the line after the "downloaded XX KB" to start with "* installing \*source\* package .."

I've no idea where the message you're seeing is coming from, but it looks wrong to me and is probably the root of your issues.

ADD COMMENT
0
Entering edit mode

Hello Mike,

Thanks for your reply. I tried to troubleshoot this with a colleague yesterday to no avail. I've uninstalled and reinstalled R, RStudio and Rtools, and it solved nothing. I get & was unexpected at this time. for everything I try to install by source. I think the issue is that there is something wrong with my laptop, which I've had several issues with over the couple of years. Sometime last year, it decided it no longer wanted to run .cmd files? I tried to install a programme using a batch file and it just wouldn't work. The command prompt window will appear and reappear immediately. So again, I think this is not allowing Rtools to function correctly? While it's a pain, I hope that is the issue (because I've since been able to install Phyloseq and dada2 without any issues on 2 other laptops) because if it isn't, I still have no idea what is causing the problem on this laptop.

ADD REPLY

Login before adding your answer.

Traffic: 263 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6