airway package not compatible with R version 4.1.2 (2021-11-01)
1
0
Entering edit mode
j.jacob1 • 0
@15fbb3a0
Last seen 3 months ago
United Kingdom

I downloaded package, "airway" as shown:

if (!require("airway"))
BiocManager::install("airway")

This appeared to download to a temporary folder in my Mac, as opposed to the 'Library' folder. Because at this point I quit RStudio and opened a new session, the message detailing the exact location of the airway package is lost. On opening Rstudio/R again, I typed:

library(airway)

No further error message generated until I typed:

colData(airway)

"Error in h(simpleError(msg, call)) : error in evaluating the argument 'x' in selecting a method for function 'colData': object 'airway' not found"

So, I uninstalled airway from the packages pane and tried reinstalling, this time from CRAN using the 'Install' icon in the Packages pane of RStudio. This time I got the message: Warning in install.packages : package ‘airway’ is not available for this version of R A version of this package for your version of R might be available elsewhere, see the ideas at https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages

What should I do to load the airway package

sessionInfo( ) *R version 4.1.2 (2021-11-01) Platform: x86_64-apple-darwin17.0 (64-bit) Running under: macOS Monterey 12.1 Matrix products: default LAPACK: /Library/Frameworks/R.framework/Versions/4.1/Resources/lib/libRlapack.dylib locale: [1] en_GB.UTF-8/en_GB.UTF-8/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8 attached base packages: [1] stats graphics grDevices utils datasets methods base
loaded via a namespace (and not attached): [1] compiler_4.1.2 fastmap_1.1.0 tools_4.1.2 htmltools_0.5.2 knitr_1.37
[6] xfun_0.29 digest_0.6.29 rlang_0.4.12

*

```

airway • 333 views
ADD COMMENT
1
Entering edit mode

I think it would help if you try again to install it via BiocManager::install("airway") and report the exact text output (without quitting in the middle of the process).

ADD REPLY
0
Entering edit mode
ATpoint ★ 1.2k
@atpoint-13662
Last seen 3 days ago
Germany

data(airway) is your friend. The CRAN error comes from the fact that it is not a CRAN package, not that it is a version problem itself.

ADD COMMENT

Login before adding your answer.

Traffic: 139 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6