Error: package or namespace load failed for ‘DESeq2’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]): there is no package called ‘locfit’
1
0
Entering edit mode
cbravo11 • 0
@e0025e70
Last seen 4 weeks ago
United States

I installed DESeq2 using this code:

if (!require("BiocManager", quietly = TRUE)) install.packages("BiocManager")

BiocManager::install("DESeq2")

Then when I run this: library(DESeq2)

I get this error: Error: package or namespace load failed for ‘DESeq2’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]): there is no package called ‘locfit’

I tried to download the "locfit" package but I can't find it anywhere.

What do you think is the problem?

DESeq2 • 394 views
ADD COMMENT
0
Entering edit mode
Basti ▴ 280
@7d45153c
Last seen 12 hours ago
France

Have you tried install.packages("locfit") ?

ADD COMMENT
0
Entering edit mode

or install using BiocManager that will also install CRAN packages BiocManager::install('locfit')

ADD REPLY
0
Entering edit mode

I couldn't intall locfit but somehow, i did so many different things and it worked. :)

ADD REPLY
0
Entering edit mode

I try it and get


BiocManager::install("locift") 'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories: CRAN: https://mirrors.sjtug.sjtu.edu.cn/cran/

Bioconductor version 3.12 (BiocManager 1.30.17), R 4.0.3 (2020-10-10)

Installing package(s) 'locift'

Old packages: 'cli', 'dplyr', 'igraph', 'MASS', 'ps', 'RSQLite', 'testthat', 'tibble'

Update all/some/none? [a/s/n]: n

Warning message:

package ‘locift’ is not available for Bioconductor version '3.12'

A version of this package for your version of R might be available elsewhere,see the ideas at https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages


May be the version has problem How can I do ?

ADD REPLY
0
Entering edit mode

Im trying to use this code: install.packages("locfit")

but this warning appeared: package ‘locfit’ is not available for this version of R ‘locfit’ version 1.5-9.5 is in the repositories but depends on R (>= 4.1.0) im using ubuntu, R ver 4.0.4, bioconductor ver 1.12

ADD REPLY
0
Entering edit mode

The package has place the R version constraint. Your best bet would be to download the package source code and change the R version and install manually if you wanted the most recent version of locfit to install on your computer. The other option is to download and older version of locfit from the package archive and install manually.

ADD REPLY
1
Entering edit mode

Just to add on -- do you require an old version of Bioconductor for your current project?

If not, I recommend using the latest version of R and Bioconductor for bug fixes and improvements.

ADD REPLY

Login before adding your answer.

Traffic: 301 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6