problem withDESeq2
1
0
Entering edit mode
@947f0210
Last seen 3 months ago
Germany

I am trying to load library (DESeq2) and I get the following message


library(DESeq2)
Loading required package: GenomicRanges
Error: package or namespace load failed for ‘GenomicRanges’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
 there is no package called ‘XVector’
Error: package ‘GenomicRanges’ could not be loaded

sessionInfo( )
DESeq2 • 281 views
ADD COMMENT
0
Entering edit mode
shepherl 3.3k
@lshep
Last seen 49 minutes ago
United States

install XVector with BiocManager::install("XVector") and try again. If you continue to have trouble, please also include your sessionInfo()

ADD COMMENT
0
Entering edit mode

So, XVector didn't get install with this command also. Code:

if (!require("BiocManager", quietly = TRUE))
 BiocManager::install("XVextor")

Error: 'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories:
    CRAN: https://cran.rstudio.com/

Bioconductor version 3.14 (BiocManager 1.30.18), R 4.1.2 (2021-11-01)
Installing package(s) 'XVextor'
Warning message:
package ‘XVextor’ is not available for Bioconductor version '3.14'

A version of this package for your version of R might be available elsewhere,
see the ideas at
https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages 

SessionInfo() R version 4.1.2 (2021-11-01)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19042)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252    LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                           LC_TIME=English_United States.1252    

attached base packages:
[1] stats4    stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] GenomeInfoDb_1.30.1 IRanges_2.28.0      S4Vectors_0.32.4    BiocGenerics_0.40.0 BiocManager_1.30.18

loaded via a namespace (and not attached):
[1] compiler_4.1.2         tools_4.1.2            GenomeInfoDbData_1.2.7 RCurl_1.98-1.7         bitops_1.0-7
ADD REPLY
0
Entering edit mode

You mis-spelled XVector in the above. BiocManager::install("XVextor") should be BiocManager::install("XVector")

ADD REPLY
0
Entering edit mode

Ok, Thanks. I tried again but I still get error:

Code: if (!require("BiocManager", quietly = TRUE))
 BiocManager::install("XVector")
----------------------------------------------------------------------------
Error::   'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories:
    CRAN: https://cran.rstudio.com/

Bioconductor version 3.14 (BiocManager 1.30.18), R 4.1.2 (2021-11-01)
Installing package(s) 'XVector'
also installing the dependency ‘zlibbioc’

trying URL 'https://bioconductor.org/packages/3.14/bioc/bin/windows/contrib/4.1/zlibbioc_1.40.0.zip'
Error in download.file(url, destfile, method, mode = "wb", ...) : 
  cannot open URL 'https://bioconductor.org/packages/3.14/bioc/bin/windows/contrib/4.1/zlibbioc_1.40.0.zip'
In addition: Warning message:
In download.file(url, destfile, method, mode = "wb", ...) :
  cannot open URL 'https://bioconductor.org/packages/3.14/bioc/bin/windows/contrib/4.1/zlibbioc_1.40.0.zip': HTTP status was '403 Forbidden'
Warning in download.packages(pkgs, destdir = tmpd, available = available,  :
  download of package ‘zlibbioc’ failed
trying URL 'https://bioconductor.org/packages/3.14/bioc/bin/windows/contrib/4.1/XVector_0.34.0.zip'
Error in download.file(url, destfile, method, mode = "wb", ...) : 
  cannot open URL 'https://bioconductor.org/packages/3.14/bioc/bin/windows/contrib/4.1/XVector_0.34.0.zip'
In addition: Warning message:
In download.file(url, destfile, method, mode = "wb", ...) :
  cannot open URL 'https://bioconductor.org/packages/3.14/bioc/bin/windows/contrib/4.1/XVector_0.34.0.zip': HTTP status was '403 Forbidden'
Warning in download.packages(pkgs, destdir = tmpd, available = available,  :
  download of package ‘XVector’ failed
-----------------------------------------------------------------------
> sessionInfo()
R version 4.1.2 (2021-11-01)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19042)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252    LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                           LC_TIME=English_United States.1252    

attached base packages:
[1] stats4    stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] GenomeInfoDb_1.30.1 IRanges_2.28.0      S4Vectors_0.32.4    BiocGenerics_0.40.0 BiocManager_1.30.18

loaded via a namespace (and not attached):
[1] compiler_4.1.2         tools_4.1.2            GenomeInfoDbData_1.2.7 RCurl_1.98-1.7         bitops_1.0-7
ADD REPLY
0
Entering edit mode

I was able to install XVector on a windows 10 VM with Bioc 3.14. The errors suggest that you're having problems downloading. Could you first try visiting https://bioconductor.org/packages/3.14/bioc/bin/windows/contrib/4.1/zlibbioc_1.40.0.zip in a browser? If that works, in R try to download it with download.file. If you're not able to download the file via download.file, try setting a proxy. See Setting Proxies in ?download.file.

ADD REPLY

Login before adding your answer.

Traffic: 673 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6