Can't Install ensembldb and EnsDb.Hsapiens.v86
2
0
Entering edit mode
elmfinds • 0
@993bfcc9
Last seen 4 weeks ago
United States

Hello. I can't load ensembldb and EnsDb.Hsapiens.v86. Please see the requested information below. Thank you in advance for any and all advice.

BiocManager::install("ensembldb")
'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories:
    CRAN: https://ftp.osuosl.org/pub/cran
    BioCsoft: https://bioconductor.org/packages/3.15/bioc
    BioCann: https://bioconductor.org/packages/3.15/data/annotation
    BioCexp: https://bioconductor.org/packages/3.15/data/experiment

Bioconductor version 3.15 (BiocManager 1.30.18), R 4.2.1 (2022-06-23)
Old packages: 'colorspace', 'Matrix'
Update all/some/none? [a/s/n]: 
a
Warning: unable to access index for repository https://www.stats.ox.ac.uk/pub/RWin/bin/macosx/contrib/4.2:
  cannot open URL 'https://www.stats.ox.ac.uk/pub/RWin/bin/macosx/contrib/4.2/PACKAGES'
Warning: unable to access index for repository https://R-Forge.R-project.org/bin/macosx/contrib/4.2:
  cannot open URL 'https://R-Forge.R-project.org/bin/macosx/contrib/4.2/PACKAGES'
Warning: unable to access index for repository https://www.rforge.net/bin/macosx/contrib/4.2:
  cannot open URL 'https://www.rforge.net/bin/macosx/contrib/4.2/PACKAGES'

  There are binary versions available but the source versions are later:
           binary source needs_compilation
colorspace  2.0-3  2.1-0              TRUE
Matrix      1.4-1  1.4-2              TRUE

Do you want to install from sources the packages which need compilation? (Yes/no/cancel) y
installing the source packages ‘colorspace’, ‘Matrix’

trying URL 'https://R-Forge.R-project.org/src/contrib/colorspace_2.1-0.tar.gz'
Content type 'application/x-gzip' length 2464234 bytes (2.4 MB)
==================================================
downloaded 2.4 MB

trying URL 'https://R-Forge.R-project.org/src/contrib/Matrix_1.4-2.tar.gz'
Content type 'application/x-gzip' length 3673197 bytes (3.5 MB)
==================================================
downloaded 3.5 MB
* installing *source* package ‘colorspace’ ...
** using staged installation
** libs
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
ERROR: compilation failed for package ‘colorspace’
* removing ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/colorspace’
* restoring previous ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/colorspace’
* installing *source* package ‘Matrix’ ...
** using staged installation
** libs
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
ERROR: compilation failed for package ‘Matrix’
* removing ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/Matrix’
* restoring previous ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/Matrix’

The downloaded source packages are in
    ‘/private/var/folders/fn/9ftb5p2156389n_frl68stz40000gn/T/Rtmpxf3yAQ/downloaded_packages’
Warning messages:
1: package(s) not installed when version(s) same as current; use `force = TRUE` to re-install: 'ensembldb' 
2: In install.packages(update[instlib == l, "Package"], l, repos = repos,  :
  installation of package ‘colorspace’ had non-zero exit status
3: In install.packages(update[instlib == l, "Package"], l, repos = repos,  :
  installation of package ‘Matrix’ had non-zero exit status
> 


BiocManager::install("EnsDb.Hsapiens.v86")
'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories:
    CRAN: https://ftp.osuosl.org/pub/cran
    BioCsoft: https://bioconductor.org/packages/3.15/bioc
    BioCann: https://bioconductor.org/packages/3.15/data/annotation
    BioCexp: https://bioconductor.org/packages/3.15/data/experiment

Bioconductor version 3.15 (BiocManager 1.30.18), R 4.2.1 (2022-06-23)
Installing package(s) 'EnsDb.Hsapiens.v86'
Warning: unable to access index for repository https://www.stats.ox.ac.uk/pub/RWin/bin/macosx/contrib/4.2:
  cannot open URL 'https://www.stats.ox.ac.uk/pub/RWin/bin/macosx/contrib/4.2/PACKAGES'
Warning: unable to access index for repository https://R-Forge.R-project.org/bin/macosx/contrib/4.2:
  cannot open URL 'https://R-Forge.R-project.org/bin/macosx/contrib/4.2/PACKAGES'
Warning: unable to access index for repository https://www.rforge.net/bin/macosx/contrib/4.2:
  cannot open URL 'https://www.rforge.net/bin/macosx/contrib/4.2/PACKAGES'
installing the source package ‘EnsDb.Hsapiens.v86’
trying URL 'https://bioconductor.org/packages/3.15/data/annotation/src/contrib/EnsDb.Hsapiens.v86_2.99.0.tar.gz'
Content type 'application/x-gzip' length 78178992 bytes (74.6 MB)
==================================================
downloaded 74.6 MB

* installing *source* package ‘EnsDb.Hsapiens.v86’ ...
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Error: package or namespace load failed for ‘AnnotationDbi’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 there is no package called ‘png’
Execution halted
ERROR: lazy loading failed for package ‘EnsDb.Hsapiens.v86’
* removing ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/EnsDb.Hsapiens.v86’

The downloaded source packages are in
    ‘/private/var/folders/fn/9ftb5p2156389n_frl68stz40000gn/T/Rtmpxf3yAQ/downloaded_packages’
Old packages: 'colorspace', 'Matrix'
Update all/some/none? [a/s/n]: 
a
Warning: unable to access index for repository https://www.stats.ox.ac.uk/pub/RWin/bin/macosx/contrib/4.2:
  cannot open URL 'https://www.stats.ox.ac.uk/pub/RWin/bin/macosx/contrib/4.2/PACKAGES'
Warning: unable to access index for repository https://R-Forge.R-project.org/bin/macosx/contrib/4.2:
  cannot open URL 'https://R-Forge.R-project.org/bin/macosx/contrib/4.2/PACKAGES'
Warning: unable to access index for repository https://www.rforge.net/bin/macosx/contrib/4.2:
  cannot open URL 'https://www.rforge.net/bin/macosx/contrib/4.2/PACKAGES'

  There are binary versions available but the source versions are later:
           binary source needs_compilation
colorspace  2.0-3  2.1-0              TRUE
Matrix      1.4-1  1.4-2              TRUE
Warning message:
In install.packages(...) :
  installation of package ‘EnsDb.Hsapiens.v86’ had non-zero exit status


RESULTS of sessionInfo( )
R version 4.2.1 (2022-06-23)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Monterey 12.4

Matrix products: default
LAPACK: /Library/Frameworks/R.framework/Versions/4.2/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats4    stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] BiocManager_1.30.18  Biobase_2.56.0       GenomicRanges_1.48.0 GenomeInfoDb_1.32.2  IRanges_2.30.0      
 [6] S4Vectors_0.34.0     BiocGenerics_0.42.0  tximport_1.24.0      forcats_0.5.1        stringr_1.4.0       
[11] dplyr_1.0.9          purrr_0.3.4          readr_2.1.2          tidyr_1.2.0          tibble_3.1.7        
[16] ggplot2_3.3.6        tidyverse_1.3.1     

loaded via a namespace (and not attached):
 [1] httr_1.4.3             bit64_4.0.5            jsonlite_1.8.0         modelr_0.1.8          
 [5] assertthat_0.2.1       blob_1.2.3             GenomeInfoDbData_1.2.8 cellranger_1.1.0      
 [9] pillar_1.7.0           RSQLite_2.2.14         backports_1.4.1        glue_1.6.2            
[13] XVector_0.36.0         rvest_1.0.2            colorspace_2.0-3       pkgconfig_2.0.3       
[17] broom_1.0.0            haven_2.5.0            zlibbioc_1.42.0        scales_1.2.0          
[21] tzdb_0.3.0             generics_0.1.2         ellipsis_0.3.2         cachem_1.0.6          
[25] withr_2.5.0            cli_3.3.0              magrittr_2.0.3         crayon_1.5.1          
[29] readxl_1.4.0           memoise_2.0.1          fs_1.5.2               fansi_1.0.3           
[33] xml2_1.3.3             tools_4.2.1            hms_1.1.1              lifecycle_1.0.1       
[37] munsell_0.5.0          reprex_2.0.1           compiler_4.2.1         rlang_1.0.3           
[41] grid_4.2.1             RCurl_1.98-1.7         rstudioapi_0.13        bitops_1.0-7          
[45] gtable_0.3.0           DBI_1.1.3              R6_2.5.1               lubridate_1.8.0       
[49] fastmap_1.1.0          bit_4.0.4              utf8_1.2.2             stringi_1.7.6         
[53] Rcpp_1.0.8.3           vctrs_0.4.1            dbplyr_2.2.1           tidyselect_1.1.2
installation EnsDb.Hsapiens.v86 Bioconductor package ensembldb • 196 views
ADD COMMENT
0
Entering edit mode
mbk0asis • 0
@mbk0asis-7155
Last seen 4 weeks ago
Korea, Republic Of
Error: package or namespace load failed for ‘AnnotationDbi’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 there is no package called ‘png’

You may need to install a package 'png' first??

ADD COMMENT
0
Entering edit mode

I agree with mbk0asis above - you should first install the png package and maybe also avoid installing packages from source as your system seems to lack required compilers:

BiocManager::install("png")

And select to install binary packages instead of installing them from source.

ADD REPLY
0
Entering edit mode
elmfinds • 0
@993bfcc9
Last seen 4 weeks ago
United States

Thank you mbk0asis and Johannes! Installing png solved my issue. I appreciate your help!

ADD COMMENT

Login before adding your answer.

Traffic: 356 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6