error running UniProt.ws
2
1
Entering edit mode
@julienwollbrett-19764
Last seen 11 weeks ago
Switzerland

Hello,

I have an error running UniProt.ws R package. It looks like the Uniprot Web Service has been updated but the R package has not been updated accordingly. Is there any plan on updating this package ?


uniprot_object <- UniProt.ws(taxId = 9606)
Error in file(con, "r") : 
  cannot open the connection to 'https://www.uniprot.org/uniprot/?query=organism:9606&format=tab&columns=id'
In addition: Warning message:
In file(con, "r") :
  cannot open URL 'https://rest.uniprot.org/uniprotkb/query=organism:9606&format=tab&columns=id': HTTP status was '400 Bad Request'

sessionInfo( )

R version 4.2.1 (2022-06-23)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 20.04.4 LTS

Matrix products: default
BLAS:   /usr/lib/x86_64-linux-gnu/libf77blas.so.3.10.3
LAPACK: /usr/lib/x86_64-linux-gnu/openblas-pthread/liblapack.so.3

locale:
 [1] LC_CTYPE=en_GB.UTF-8       LC_NUMERIC=C               LC_TIME=fr_FR.UTF-8       
 [4] LC_COLLATE=en_GB.UTF-8     LC_MONETARY=fr_FR.UTF-8    LC_MESSAGES=en_GB.UTF-8   
 [7] LC_PAPER=fr_FR.UTF-8       LC_NAME=C                  LC_ADDRESS=C              
[10] LC_TELEPHONE=C             LC_MEASUREMENT=fr_FR.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] doParallel_1.0.17   iterators_1.0.14    foreach_1.5.2       RMySQL_0.10.23     
[5] DBI_1.1.3           UniProt.ws_2.36.0   BiocGenerics_0.42.0 RSQLite_2.2.14     

loaded via a namespace (and not attached):
 [1] Rcpp_1.0.9             lattice_0.20-45        tidyr_1.2.0            GO.db_3.15.0          
 [5] png_0.1-7              Biostrings_2.64.0      assertthat_0.2.1       digest_0.6.29         
 [9] utf8_1.2.2             BiocFileCache_2.4.0    R6_2.5.1               GenomeInfoDb_1.32.2   
[13] stats4_4.2.1           httr_1.4.3             pillar_1.7.0           zlibbioc_1.42.0       
[17] rlang_1.0.3            curl_4.3.2             data.table_1.14.2      SparseM_1.81          
[21] blob_1.2.3             S4Vectors_0.34.0       R.utils_2.12.0         R.oo_1.25.0           
[25] BgeeDB_2.22.3          topGO_2.48.0           RCurl_1.98-1.7         bit_4.0.4             
[29] compiler_4.2.1         pkgconfig_2.0.3        tidyselect_1.1.2       KEGGREST_1.36.2       
[33] tibble_3.1.7           GenomeInfoDbData_1.2.8 codetools_0.2-18       IRanges_2.30.0        
[37] matrixStats_0.62.0     fansi_1.0.3            crayon_1.5.1           dplyr_1.0.9           
[41] dbplyr_2.2.1           bitops_1.0-7           R.methodsS3_1.8.2      rappdirs_0.3.3        
[45] grid_4.2.1             lifecycle_1.0.1        magrittr_2.0.3         graph_1.74.0          
[49] cli_3.3.0              cachem_1.0.6           XVector_0.36.0         ellipsis_0.3.2        
[53] filelock_1.0.2         generics_0.1.3         vctrs_0.4.1            tools_4.2.1           
[57] bit64_4.0.5            Biobase_2.56.0         glue_1.6.2             purrr_0.3.4           
[61] fastmap_1.1.0          AnnotationDbi_1.58.0   BiocManager_1.30.18    memoise_2.0.1
UniProt.ws • 465 views
ADD COMMENT
1
Entering edit mode
@james-w-macdonald-5106
Last seen 2 days ago
United States

It looks like they completely refactored their rest server to use POST/GET. That's going to require a complete refactor for UniProt.ws as well, which is a bummer. I doubt it will be a quick fix.

0
Entering edit mode
@marcel-ramos-7325
Last seen 7 days ago
United States

I've updated the package to handle these requests on both Bioc devel and release 3.15. Let me know if you have any issues.

Best,

Marcel

ADD COMMENT
0
Entering edit mode

Or maybe it is a quick fix! Nicely done Marcel!

ADD REPLY
0
Entering edit mode

I still get the same result as above, should running BiocManager::install() do the trick?

ADD REPLY
0
Entering edit mode

Marcel Ramos You have introduced a dependency on BiocBaseUtils, but that package is only available in devel.

ADD REPLY
0
Entering edit mode

Hi Jim,

I've updated the release version of UniProt.ws and the error should go away for the next build. The release builds run Mon, Wed, Fri so it will take some time to see those changes. You can also install it via

BiocManager::install("Bioconductor/UniProt.ws", ref = "RELEASE_3_15")

Best regards,

Marcel

ADD REPLY

Login before adding your answer.

Traffic: 233 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6