Unable to access index for Bioconductor repository
1
0
Entering edit mode
mvictor • 0
@a5337a9d
Last seen 7 weeks ago
United States

Hi, I am a very new R user, attempting to install bioconductor packages on my mac (R version 4.2.1, macOS 12.4 Monterey).

With attempted installation of bioconductor packages using either v3.15 or 3.16, I run into the following:

```> library(BiocManager) Bioconductor version 3.15 (BiocManager 1.30.18), R 4.2.1 (2022-06-23)

library(BiocVersion) library(BiocParallel) BiocManager::install("DEXSeq")

'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories: CRAN: http://cran.rstudio.com/

Bioconductor version 3.15 (BiocManager 1.30.18), R 4.2.1 (2022-06-23) Installing package(s) 'DEXSeq' also installing the dependencies ‘Rhtslib’, ‘DESeq2’, ‘Rsamtools’, ‘genefilter’

Warning: unable to access index for repository https://bioconductor.org/packages/3.15/bioc/bin/macosx/big-sur-arm64/contrib/4.2: cannot open URL 'https://bioconductor.org/packages/3.15/bioc/bin/macosx/big-sur-arm64/contrib/4.2/PACKAGES'

Monterey macOS Bioconductor • 267 views
ADD COMMENT
0
Entering edit mode
@c635ce62
Last seen 9 weeks ago
United States

M1 binaries are not yet available for Bioconductor packages. I am currently working on getting M1 binaries available for Bioconductor 3.16, but it will still be awhile before they're available. Until then, you can install rosetta2 on your Mac to use the Intel versions.

ADD COMMENT

Login before adding your answer.

Traffic: 278 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6