I can't upgrade to version 3.15 in R
1
0
Entering edit mode
dsrlij • 0
@130ef850
Last seen 8 weeks ago
United States

What should I do to deal with the following sentence?

Upgrade 4 packages to Bioconductor version '3.15'? [y/n]:


> if (!require("BiocManager", quietly = TRUE))
+   install.packages("BiocManager")
trying URL 'https://cran.rstudio.com/bin/windows/contrib/4.2/BiocManager_1.30.18.zip'
Content type 'application/zip' length 360733 bytes (352 KB)
downloaded 352 KB

package ‘BiocManager’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
    C:\Users\L\AppData\Local\Temp\RtmpA7OiKC\downloaded_packages
> BiocManager::install(version = "3.15")
'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for details

replacement repositories:
    CRAN: https://cran.rstudio.com/

Upgrade 4 packages to Bioconductor version '3.15'? [y/n]:
Install • 237 views
ADD COMMENT
1
Entering edit mode
@gordon-smyth
Last seen 3 hours ago
WEHI, Melbourne, Australia

The dialog is asking you to type "y" followed by return if you want to upgrade the four packages or "n" followed by return if you don't. Presumably you want to type "y".

ADD COMMENT
0
Entering edit mode

thankyou, I typed “yes” earlier, haha

ADD REPLY
0
Entering edit mode

I will assume that it has worked for you now. The dialog is asking for "y" rather than "yes", i.e., you need to type one letter, not three.

ADD REPLY

Login before adding your answer.

Traffic: 602 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6