Cannot download flowUtils package from Bioconductor 3.16
1
0
Entering edit mode
Zoya • 0
@063c5fbd
Last seen 8 weeks ago
India

Hello,

I am new to using R and RStudio. I am trying to download the flowUtils package from Bioconductor 3.16 (BiocManager 1.30.19) using RStudio on my Windows 11 laptop but for some reason I am unable to. I know the package has been released for this version of Bioconductor (https://bioconductor.org/packages/release/bioc/), so I am very confused as to why I cannot download flowUtils.

Any help is greatly welcome.

Code should be placed in three backticks as shown below


#problematic code
if (!require("BiocManager", quietly = TRUE))
    install.packages("BiocManager")

BiocManager::install("flowUtils", type = "binary")


#output of the code below
> if (!require("BiocManager", quietly = TRUE))
+     install.packages("BiocManager")
Bioconductor version 3.16 (BiocManager 1.30.19), R 4.2.2 (2022-10-31 ucrt)
> 
> BiocManager::install("flowUtils")
Bioconductor version 3.16 (BiocManager 1.30.19), R 4.2.2 (2022-10-31 ucrt)
Installing package(s) 'flowUtils'
Installation paths not writeable, unable to update packages
  path: C:/Program Files/R/R-4.2.2/library
  packages:
    boot, Matrix
Old packages: 'xfun'
Update all/some/none? [a/s/n]: a
trying URL 'https://cloud.r-project.org/bin/windows/contrib/4.2/xfun_0.35.zip'
Content type 'application/zip' length 406240 bytes (396 KB)
downloaded 396 KB

package ‘xfun’ successfully unpacked and MD5 sums checked
Warning: cannot remove prior installation of package ‘xfun’
Warning: restored ‘xfun’

The downloaded binary packages are in
        C:\Users\zaqai\AppData\Local\Temp\Rtmp6NbbuT\downloaded_packages
Warning messages:
1: package ‘flowUtils’ is not available for Bioconductor version '3.16'

A version of this package for your version of R might be available elsewhere,
see the ideas at
https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages 
2: In file.copy(savedcopy, lib, recursive = TRUE) :
  problem copying C:\Users\zaqai\AppData\Local\R\win-library\4.2\00LOCK\xfun\libs\x64\xfun.dll to C:\Users\zaqai\AppData\Local\R\win-library\4.2\xfun\libs\x64\xfun.dll: Permission denied


#session information
sessionInfo( )

R version 4.2.2 (2022-10-31 ucrt)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 22621)

Matrix products: default

locale:
[1] LC_COLLATE=English_India.utf8  LC_CTYPE=English_India.utf8    LC_MONETARY=English_India.utf8 LC_NUMERIC=C                   LC_TIME=English_India.utf8    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] BiocManager_1.30.19

loaded via a namespace (and not attached):
[1] compiler_4.2.2 tools_4.2.2
Bioconductor flowUtils • 343 views
ADD COMMENT
0
Entering edit mode
Mike Smith ★ 5.9k
@mike-smith
Last seen 1 hour ago
EMBL Heidelberg

Unfortunately the flowUtils package is deprecated in Bioconductor 3.16. You can see this at the top of the landing page at https://www.bioconductor.org/packages/release/bioc/html/flowUtils.html There's a paragraph that says:

This package is deprecated. It will probably be removed from Bioconductor. Please refer to the package end-of-life guidelines for more information.

This is because the package is consistently failing one or more of the checks Bioconductor requires packages to pass. This means the package can't be built and really is "not available for 3.16".

It actually looks like the author of flowUtils requested the deprecation (List of Deprecated Packages for Bioc3.16) so, if the package is very important to you, I'd recommend reaching out to them to ask if there is an alternative package they suggest or if they might reconsider the deprecation.

ADD COMMENT
0
Entering edit mode

Many thanks for clarifying, Mike. Does this mean I won't be able to download flowUtils using devtools either?

ADD REPLY
0
Entering edit mode

You could download the last available tarball of source package from https://www.bioconductor.org/packages/3.15/bioc/html/flowUtils.html and try to install that manually.

Alternatively, you can try to use devtools to install from GitHub at https://github.com/jspidlen/flowUtils but that version looks like it's even older.

ADD REPLY

Login before adding your answer.

Traffic: 709 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6