Trouble Installing DADA2 (warning: R new user)
0
0
Entering edit mode
schott01 • 0
@6cc9b06f
Last seen 10 days ago
United States

I am trying to install DADA2 from bioconductor

I have this as my input: ```if (!require("BiocManager", quietly = TRUE)) install.packages("BiocManager")

BiocManager::install("dada2")```

But I keep gettin this as my output: if (!require("BiocManager", quietly = TRUE)) Update all/some/none? [a/s/n]: install.packages("BiocManager") Update all/some/none? [a/s/n]: Update all/some/none? [a/s/n]: BiocManager::install("dada2") Update all/some/none? [a/s/n]:

AND this:

Installation paths not writeable, unable to update packages path: C:/Program Files/R/R-4.4.1/library packages: foreign, MASS, nlme, survival Old packages: 'ps'

I have an up-to-date R and Bioconductor/BioManager. So, I am not sure what the trouble might be. However, other packges I was able to install so far were Phyloseq and Tidyverse.

dada2 • 232 views
ADD COMMENT
0
Entering edit mode

If there were no ERROR's than dada2 is likely installed. Did you try loading the library after with library(dada2)? Is R installed by an administrative account? likely you are not able to update because your user does not have permission to update the default packages installed with whatever user installed R.

ADD REPLY
0
Entering edit mode

I have gotten errors like:

Error: Bioconductor version '3.10' requires R version '3.6'; use version = '3.19' with R version 4.4; see https://bioconductor.org/install

However, both R and Bioconductor are up to date from my end.

ADD REPLY
0
Entering edit mode

Okay, I closed out R studio and was finally able to see that dada2 was indeed installed.

ADD REPLY
0
Entering edit mode

As far as this ERROR for Bioc requires R version, Bioconductor is closely tied to an R release. Depending if you tried to use a premade script or commands, that had a version specified, you might have seen this error. But to use the latest version of Bioconductor you need the latest version of R, else you will be limited to the version of Bioconductor for the version of R you have installed

ADD REPLY

Login before adding your answer.

Traffic: 813 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6