Search
Question: Rsubread crash on Mac during alignment
0
gravatar for raf4
6 months ago by
raf420
raf420 wrote:

Dear Bioconductor Forum,

Rsubread crashed on my 32Gb Mac on a particular pair of fastq files. It worked fine on the previous file in the dataset and also other times I had used it. The CPU was at 100% and the memory was at 24.3% all the way through the run. The script was

library(Rsubread)
align(index="GRCh38",readfile1="a2-Solub-W2_S1_L001_R1_001.fastq.gz",readfile2="a2-Solub-W2_S1_L001_R2_001.fastq.gz",output_file="a2-Solub.bam")

The command line and error message was:

c2b2afmd2:GrCh38 friedman$ R CMD BATCH align2SC.R
/Library/Frameworks/R.framework/Resources/bin/BATCH: line 60:  4665 Abort trap: 6           ${R_HOME}/bin/R -f ${in} ${opts} ${R_BATCH_OPTIONS} > ${out} 2>&1

Here is the last line of the *.Rout file

||   70% completed,  90 mins elapsed, rate=3.7k fragments per second          ||

(I am not reproducing the whole file for space).

It stopped at this point, in each of 3 runs.

The sessionInfo() (obtained from the GUI) is:

 

> sessionInfo()
R version 3.3.2 (2016-10-31)
Platform: x86_64-apple-darwin13.4.0 (64-bit)
Running under: OS X Yosemite 10.10.4

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] Rsubread_1.24.1

loaded via a namespace (and not attached):
[1] tools_3.3.2

Please advise.

Thanks and best wishes,

Rich

Richard A. Friedman, PhD
Associate Research Scientist,
Biomedical Informatics Shared Resource
Herbert Irving Comprehensive Cancer Center (HICCC)

 

ADD COMMENTlink modified 12 weeks ago • written 6 months ago by raf420

Dear Rich, could you please send us the fastq files under question so we can take a close look? Thanks, Wei

ADD REPLYlink written 6 months ago by Wei Shi2.6k
0
gravatar for xu
6 months ago by
xu0
xu0 wrote:

Hi, I have similar R crash issues. After around 10 minutes, the program crashed.

The fastq files (ChIP-seq, from mouse) are from Ion Torrent machine.

At first I used MAC, then I used our Linux rstudio server, where the CPU and memory are much better.

I also tried the Subread running in Linux, crash all the same.

Then I tried my old data from Arabidopsis with Ensembl tair10 genome, crash all the same.

When I used Rsubread v1.18, there is not problem, so before solving this problem, can I use the data from v1.18

Thank you!

Xu

ADD COMMENTlink written 6 months ago by xu0
0
gravatar for Wei Shi
5 months ago by
Wei Shi2.6k
Australia
Wei Shi2.6k wrote:

Dear Richard, thanks for sending us your data. This should be fixed it in the latest version (1.24.2) - it runs well on our Macbook.

Wei

ADD COMMENTlink written 5 months ago by Wei Shi2.6k
0
gravatar for raf4
12 weeks ago by
raf420
raf420 wrote:

Dear Wei and Yang,

I am sorry that I didn't get back to you. The person whom I was helping when I found the bug went elsewhere.

I am curently using the new version and it works fine.

Thanks and best wishes,

Rich

ADD COMMENTlink written 12 weeks ago by raf420

Thanks for letting us know Rich!

ADD REPLYlink written 12 weeks ago by Wei Shi2.6k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 138 users visited in the last hour