treeio installation problem
1
1
Entering edit mode
anabento ▴ 10
@anabento-12306
Last seen 5.5 years ago

Hi I have R version 3.3.2. I tried to install treeio and it gives me an error:

 BioC_mirror: https://bioconductor.org
Using Bioconductor 3.4 (BiocInstaller 1.24.0), R 3.3.2 (2016-10-31).
Installing package(s) ‘treeio’
Warning message:
package ‘treeio’ is not available (for R version 3.3.2)

I need to install it as Im trying to use ggtree fro BEAST trees

 

Thanks

Ana 

 

 

 

 

software error • 1.1k views
ADD COMMENT
0
Entering edit mode

I have exactly the same problem!!

ADD REPLY
0
Entering edit mode

If your problem i exactly the same, including using Bioconductor version 3.4, then the solution is as James mentions below -- update to a current version of R and Bioconductor. If you are using a current version of R and Bioconductor, please post the full transcript of your attempt to install the package.

ADD REPLY
1
Entering edit mode
@james-w-macdonald-5106
Last seen 1 day ago
United States

You need the devel version of Bioconductor to use packages that are still only in devel.

ADD COMMENT
0
Entering edit mode

Get the released version from Bioconductor:

try http:// if https:// URLs are not supported

if (!requireNamespace("BiocManager", quietly=TRUE)) install.packages("BiocManager")

BiocManager::install("BiocUpgrade") ## you may need this

BiocManager::install("treeio") Or the development version from github:

install.packages("devtools")

devtools::install_github("GuangchuangYu/treeio")

ADD REPLY

Login before adding your answer.

Traffic: 217 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6