about an error in cn.MOPS : could not find symbol "recursive" in environment of the generic function
0
0
Entering edit mode
Bogdan ▴ 620
@bogdan-2367
Last seen 14 days ago
Palo Alto, CA, USA

Dear all, 

I am using the package cn.MOPS on a PBS/Torque cluster node (that runs RedHat), and I am following the examples in the manual. However, I am getting the following error : "could not find symbol "recursive" in environment of the generic function" Please, any suggestions on how to fix it ? Thank you !  

BAMFiles <- list.files(system.file("extdata", package="cn.mops"),pattern=".bam$", full.names=TRUE)

bamDataRanges <- getReadCountsFromBAM(BAMFiles, sampleNames=paste("Sample",1:3), mode="unpaired",  WL=10000, refSeqName="20")

Identified the following reference sequences:  20
Using 20 as reference.
Using indexed BAM files.
Reading file: /home/tanasab/R/x86_64-pc-linux-gnu-library/3.3/cn.mops/extdata/test1.bam
  20

Reading file: /home/tanasab/R/x86_64-pc-linux-gnu-library/3.3/cn.mops/extdata/test2.bam

20

Reading file: /home/tanasab/R/x86_64-pc-linux-gnu-library/3.3/cn.mops/extdata/test3.bam
  20

Error in c(ir, IRanges::IRanges(start = brkpts[1:(nSegm - 1)], end = brkpts[2:(nSegm)] -  : 
  could not find symbol "recursive" in environment of the generic function

 

> sessionInfo()
R version 3.3.2 Patched (2017-02-12 r72168)
Platform: x86_64-pc-linux-gnu (64-bit)

locale:
[1] C

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets 
[8] methods   base     

other attached packages:
[1] Biobase_2.34.0       snow_0.4-2           cn.mops_1.20.0      
[4] GenomicRanges_1.26.2 GenomeInfoDb_1.10.2  IRanges_2.8.1       
[7] S4Vectors_0.12.1     BiocGenerics_0.20.0 

loaded via a namespace (and not attached):
[1] zlibbioc_1.20.0    tools_3.3.2        XVector_0.14.0    
[4] Biostrings_2.42.1  BiocParallel_1.8.1 Rsamtools_1.26.1  
[7] bitops_1.0-6 

cn.MOPS • 1.0k views
ADD COMMENT
0
Entering edit mode

Could you run "traceback()" right after the error occurred and tell me the result of it? It seems like an error that does not come from cn.mops. Btw. "getReadCountsFromBAM" is just a "convenience function".. you can also use other methods to obtain the read count matrix.

Regards,

Günter

ADD REPLY
0
Entering edit mode

Dear Gunter, thank you for your note, and kind help. I shall say that everything seems to be working now on the PBS/TORQUE cluster that we have :

i've added a few more packages (below), and resourced the bash, although it may have been indeed a cluster-related issue. Could I re-verify the code with you please ? I am going to open a new track ;) thank you !

 

#!/usr/bin/env Rscript

 

library(cn.mops)

library(parallel)

library(snow)

library(RUnit)

library(BiocParallel)

 

# registered()

# register(MulticoreParam(workers = 1))

 

#### initially, we would need to enter the TUMOR FILE, the GERMLINE file, and the CHROMOSOME to run the analysis ON.

 

args <- commandArgs(TRUE)

 

TUMOR <- args[1]         

GERMLINE <- args[2]

CHR <- args[3] 

ADD REPLY

Login before adding your answer.

Traffic: 284 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6