Which version of R to use for "HiCDCPlus" "HiC-DC+"
1
1
Entering edit mode
Tay ▴ 10
@tay-24158
Last seen 3.7 years ago

Hello! I'm using R version 4.0.3 (2020-10-10). I was trying to download HiCDCPlus on BiocManager, however I faced this error:

> BiocManager::install("HiCDCPlus")
Bioconductor version 3.12 (BiocManager 1.30.10), R 4.0.3 (2020-10-10)
Installing package(s) 'HiCDCPlus'
Installation path not writeable, unable to update packages: codetools,
  KernSmooth, nlme
Warning message:
package ‘HiCDCPlus’ is not available for this version of R

A version of this package for your version of R might be available elsewhere,
see the ideas at
https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages

Which version of R would be compatible with your package? Thank you!

HiC-DC+ HiCDCPlus BiocParallel • 2.3k views
ADD COMMENT
0
Entering edit mode

HiCDCPlus now available on Bioconductor! You should be able to install it using BiocManager::install("HiCDCPlus")

ADD REPLY
0
Entering edit mode

Hi,

I am trying to install the HiCDCPlus package now but still facing the same problem.

BiocManager::install("HiCDCPlus")

Bioconductor version 3.12 (BiocManager 1.30.10), R 4.0.3 (2020-10-10)

Installing package(s) 'HiCDCPlus'

Warning message: package ‘HiCDCPlus’ is not available for this version of R

A version of this package for your version of R might be available elsewhere, see the ideas at https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages

Can you please suggest which version of R/Bioconductor would be compatible? Thank you!

ADD REPLY
1
Entering edit mode

packages are added to the 'devel' branch so this package requires R-devel / Bioc 3.13; it will be included in the next release, in approximately two months. Here's the package 'landing page' https://bioconductor.org/packages/devel/bioc/html/HiCDCPlus.html and note the installation instructions.

ADD REPLY
0
Entering edit mode

Thank you

ADD REPLY
1
Entering edit mode
@martin-morgan-1513
Last seen 3 days ago
United States

This package IS NOT YET AVAILABLE IN BIOCONDUCTOR.

It is UNDER REVIEW https://github.com/Bioconductor/Contributions/issues/1720.

This question has been asked before.

ADD COMMENT
0
Entering edit mode

could you please provide alternative installation instructions in the meanwhile?

ADD REPLY
0
Entering edit mode

HiCDCPlus is now available on Bioconductor! You should be able to install it using BiocManager::install("HiCDCPlus")

ADD REPLY

Login before adding your answer.

Traffic: 420 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6