Errors when trying to install 'gwscat' on ubuntu with R 4.0.3
0
Entering edit mode
wmov98 • 10
@7df4b43e
Last seen 12 weeks ago

Hi All, I am trying to install the 'gwscat' package on R 4.0.3 however I am getting errors when trying to load it in (using ubuntu 18.04). I am using Bioconductor 3.12, I type in the following command and it proceeds to install, however midway during the installation errors appear and the package is then removed.

Code should be placed in three backticks as shown below

if (!requireNamespace("BiocManager", quietly = TRUE))
    install.packages("BiocManager")

BiocManager::install("gwascat")

#Console output
Installation path not writeable, unable to update packages: foreign, spatial
Warning messages:
1: In install.packages(...) :
  installation of package ‘XML’ had non-zero exit status
2: In install.packages(...) :
  installation of package ‘xml2’ had non-zero exit status
3: In install.packages(...) :
  installation of package ‘biomaRt’ had non-zero exit status
4: In install.packages(...) :
  installation of package ‘rtracklayer’ had non-zero exit status
5: In install.packages(...) :
  installation of package ‘BSgenome’ had non-zero exit status
6: In install.packages(...) :
  installation of package ‘GenomicFeatures’ had non-zero exit status
7: In install.packages(...) :
  installation of package ‘VariantAnnotation’ had non-zero exit status
8: In install.packages(...) :
  installation of package ‘gwascat’ had non-zero exit status

#sessionInfo( ) there is no output to the console
GWASTools gwascat • 153 views
ADD COMMENTlink
0
Entering edit mode

Please can you update you post to include the error message and the output of running sessionInfo()

ADD REPLYlink
1
Entering edit mode

Sorry about that, this is my first post.

ADD REPLYlink
0
Entering edit mode

Hi -- if you cannot get sessionInfo() to respond, the question about it should go to an r-help mailing list. Clearly there are installation difficulties for your system. They can relate to system capabilities, permissions, or a full disk. Apropos gwascat, here is my current result for a slightly out-of-date linux system. You should report the results of the install call and the sessionInfo call and then perhaps we can provide more assistance.

 BiocManager::install('gwascat')
Bioconductor version 3.12 (BiocManager 1.30.10), R 4.0.2 Patched (2020-07-19
  r78892)
Installing package(s) 'gwascat'
trying URL 'https://bioconductor.org/packages/3.12/bioc/src/contrib/gwascat_2.22.0.tar.gz'
Content type 'application/x-gzip' length 35361783 bytes (33.7 MB)
==================================================
downloaded 33.7 MB

* installing *source* package ‘gwascat’ ...
** using staged installation
** R
** data
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
** testing if installed package can be loaded from temporary location
** testing if installed package can be loaded from final location
** testing if installed package keeps a record of temporary installation path
* DONE (gwascat)

The downloaded source packages are in
    ‘/tmp/RtmpPXM6yU/downloaded_packages’
Updating HTML index of packages in '.Library'
Making 'packages.html' ... done
Old packages: 'beachmat', 'BiocStyle', 'DelayedMatrixStats', 'KEGGREST',
  'rlang', 'RNAseq123', 'scuttle', 'sparklyr', 'tximeta'
Update all/some/none? [a/s/n]: n
> sessionInfo()
R version 4.0.2 Patched (2020-07-19 r78892)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 20.04 LTS (fossa-melisa X20)

Matrix products: default
BLAS:   /home/stvjc/R-4-0-dist/lib/R/lib/libRblas.so
LAPACK: /home/stvjc/R-4-0-dist/lib/R/lib/libRlapack.so

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] BiocManager_1.30.10 compiler_4.0.2      tools_4.0.2
ADD REPLYlink
0
Entering edit mode
Mike Smith ♦ 4.8k
@mike-smith
Last seen 11 hours ago
EMBL Heidelberg / de.NBI

As @Vincent-J.-Carey says, if sessionInfo() really doesn't do anything then there's probably something really quite wrong with your system. However, it looks like you managed to get BiocManager installed, so something is working. My suspicion is that you're missing some Ubuntu system libraries that are necessary for installing at least some of those packages. Without seeing the actual error messages it' hard to know what's required, but I'd suggest running this in a bash terminal:

sudo apt-get install libxml2-dev libcurl4-openssl-dev

Then restart R and try the installation again.

ADD COMMENTlink

Login before adding your answer.

Similar Posts
Loading Similar Posts
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.4