User: balwierz

gravatar for balwierz
balwierz40
Reputation:
40
Status:
New User
Location:
United Kingdom
Last seen:
4 months, 2 weeks ago
Joined:
4 years, 4 months ago
Email:
b*******@gmail.com

Posts by balwierz

<prev • 12 results • page 1 of 2 • next >
0
votes
3
answers
3.7k
views
3
answers
Answer: A: How to remove out of bound rows from granges
... It is super easy a <- a[trim(a) == a] If your GRanges `a` does not have seqinfo, assign it first (and do it always whenever you create any GRanges): seqlevels(a) <- seqlevels(Mmusculus) seqlengths(a) <- seqlengths(Mmusculus) ...
written 4 months ago by balwierz40
1
vote
1
answer
790
views
1
answer
IRanges (GRanges): Inconsistent behaviour when overlapping ranges of width 0
... I will describe the problem using GRanges, but it is solely within IRanges. Ranges of width are apparently allowed. You can obtain them for instance calling `promoters(TxDb, upstream=0, downstream=0)`     Specifically, these ranges cannot be found by `distanceToNearest` _if_ they are within the su ...
iranges granges written 2.3 years ago by balwierz40 • updated 2.3 years ago by Hervé Pagès ♦♦ 14k
0
votes
2
answers
1.1k
views
2
answers
Comment: C: Does package S4Vectors break ifelse?
... Merci                   ...
written 2.3 years ago by balwierz40
2
votes
2
answers
1.1k
views
2
answers
Answer: A: Does package S4Vectors break ifelse?
... After 2 years it is still broken. This time IRanges introduce faulty code. a <- "foo" ifelse(is.numeric(a), yes=a+5, no=a) [1] "foo" library(IRanges) ifelse(is.numeric(a), yes=a+5, no=a) Error in a + 5 : non-numeric argument to binary operator   ...
written 2.4 years ago by balwierz40
1
vote
2
answers
1.1k
views
2
answers
Comment: C: Does package S4Vectors break ifelse?
... Hello Herve, I just bumped into this thread after an hour of debugging my code, which wasn't broken. ifelse is broken. Not any more in S4vectors, but the code turning base function ifelse to a S4 function dispatched by all 3 arguments still exists in IRanges. Moreover, when I load IRanges there is ...
written 2.4 years ago by balwierz40
0
votes
0
answers
416
views
0
answers
[bug] BayesPeak cannot deal with RangedData input
...   class(inputR) [1] "GRanges" attr(,"package") [1] "GenomicRanges" class(chipR) [1] "GRanges" attr(,"package") [1] "GenomicRanges" raw.output = bayespeak(as(chipR, "RangedData") , as(inputR, "RangedData")) Error in as.vector(x, mode) : invalid 'mode' argument Enter a frame number, or 0 to exit ...
bayespeak bug written 3.3 years ago by balwierz40
0
votes
0
answers
483
views
0
answers
[bug report] som documentation contains incorrect formula
... ?som includes a description of class 'som'. component code a metrix with nrow = xdim*ydim, each row corresponding to a code vector of a cell in the map. The mapping from cell coordinate (x, y) to the row index in the code matrix is: rownumber = x + y * xdim should say rownumber = x + y * xdi ...
bug som written 3.8 years ago by balwierz40
0
votes
1
answer
651
views
1
answer
[ChIPseeker; feature request] More flexibility in specifying the TSS region
... It would be useful to have more flexibility in selecting the TSS region. It is currently hardcoded in getGenomicAnnotation that the region is subdivided into 1000 bp regions. For some marks and compact genomes it is too large. I would like to have a way to specify bins myself, e.g. by specifying a ...
chipseeker featurerequest tss written 3.8 years ago by balwierz40 • updated 3.8 years ago by Guangchuang Yu1.1k
1
vote
0
answers
518
views
0
answers
Length of a region incorrectly calculated
... Length of a region is calculated as end - start, instead of end - start + 1. This causes problems when length of a region equals no_windows. I also suggest either checking this condition before CPU intensive operations on a bam file, using warnings instead of stop, or solving the problem properly ...
bug coverageview written 3.9 years ago by balwierz40
1
vote
0
answers
478
views
0
answers
Cannot log in to support.bioconductor.org (this site) using StackExchange ID
... Steps to reproduce: "log in" -> "with StackExchange ID" -> (log in to your account) -> (approve permission) After that there is an error message giving no details of the problem.   With google ID works without problems ...
website written 3.9 years ago by balwierz40

Latest awards to balwierz

No awards yet. Soon to come :-)

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 364 users visited in the last hour