errors in Purecn callLOH
1
0
Entering edit mode
@xiaoqiaoliu-14074
Last seen 3.6 years ago

I am using PureCN, v1.6.3. it seems everything including predict somatic, get copy number and etc, go well except callLOH function. below is the standard error and session info, could you please help? thanks

below is the error information in stderr

In .bcfHeaderAsSimpleList(header) :
  duplicate keys in header will be forced to unique rownames
Error in `$<-.data.frame`(`*tmp*`, "arm", value = "p") :
  replacement has 1 row, data has 0
Calls: callLOH -> .getArmLocations -> $<- -> $<-.data.frame
Execution halted

below is the session infor

> sessionInfo()
R version 3.3.1 Patched (2016-08-12 r71089)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Red Hat Enterprise Linux Server release 6.3 (Santiago)

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets
[8] methods   base

other attached packages:
 [1] PureCN_1.6.3               VariantAnnotation_1.20.3
 [3] Rsamtools_1.24.0           Biostrings_2.40.2
 [5] XVector_0.12.1             SummarizedExperiment_1.2.3
 [7] Biobase_2.32.0             GenomicRanges_1.26.4
 [9] GenomeInfoDb_1.10.3        IRanges_2.8.2
[11] S4Vectors_0.12.2           BiocGenerics_0.20.0
[13] DNAcopy_1.48.0

loaded via a namespace (and not attached):
 [1] Rcpp_0.12.12            RColorBrewer_1.1-2      futile.logger_1.4.3
 [4] plyr_1.8.4              GenomicFeatures_1.24.5  bitops_1.0-6
 [7] futile.options_1.0.0    tools_3.3.1             zlibbioc_1.18.0
[10] biomaRt_2.28.0          RSQLite_1.0.0           gtable_0.2.0
[13] BSgenome_1.40.1         DBI_0.7                 rtracklayer_1.32.2
[16] grid_3.3.1              data.table_1.10.4       AnnotationDbi_1.34.4
[19] XML_3.98-1.4            BiocParallel_1.6.6      VGAM_1.0-3
[22] ggplot2_2.1.0           lambda.r_1.1.9          scales_0.4.1
[25] GenomicAlignments_1.8.4 splines_3.3.1           colorspace_1.2-6
[28] RCurl_1.95-4.8          munsell_0.4.3

 

 

 

PureCN • 441 views
ADD COMMENT
0
Entering edit mode
@markusriester-9875
Last seen 28 days ago

I fixed this bug last week in the developer version (https://github.com/lima1/PureCN/issues/10). I recommend updating to that version (requires rebuilding the normal database though). It's fairly well tested and will become new stable in 4 weeks.

As workaround, you can provide the centromere positions with correct chromosome names in runAbsoluteCN.

 

 

 

 

ADD COMMENT

Login before adding your answer.

Traffic: 468 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6