Search
Question: error message from oligo package
0
gravatar for chchen
8 months ago by
chchen0
chchen0 wrote:

Hello,

I'm currently analyzing a gene expression data and I use oligo to read CEL file. when I finished the read.celfiles, this seems pretty well. However, I got an error message from backgroundCorrect(raw,method="mas"). "Error in rsqlite_send_query(conn@ptr,statement): no such table: mmfeature".

any suggestion?

Thanks for your help

Chung-Hsing

> file.list<-list.celfiles("D:/My Documents/C_language/Core&Serves/CA_ChenLT/GEO",full.names=TRUE)
> raw<-read.celfiles(file.list)
Loading required package: pd.hugene.1.0.st.v1
Loading required package: RSQLite
Loading required package: DBI
Platform design info loaded.
Reading in : D:/My Documents/C_language/Core&Serves/CA_ChenLT/GEO/GSM949164_Control1.CEL
Reading in : D:/My Documents/C_language/Core&Serves/CA_ChenLT/GEO/GSM949166_Control2.CEL
Reading in : D:/My Documents/C_language/Core&Serves/CA_ChenLT/GEO/GSM949168_Control3.CEL
Reading in : D:/My Documents/C_language/Core&Serves/CA_ChenLT/GEO/GSM949174_OSA1.CEL
Reading in : D:/My Documents/C_language/Core&Serves/CA_ChenLT/GEO/GSM949175_OSA2.CEL
Reading in : D:/My Documents/C_language/Core&Serves/CA_ChenLT/GEO/GSM949176_OSA3.CEL
> head(getNetAffx(raw, "probeset"))
Error in (function (classes, fdef, mtable)  : 
  unable to find an inherited method for function ‘getNetAffx’ for signature ‘"GeneFeatureSet"’
> mas.raw<-backgroundCorrect(raw,method="mas")
Error in rsqlite_send_query(conn@ptr, statement) : 
  no such table: mmfeature
> head(pm(raw))
     GSM949164_Control1.CEL GSM949166_Control2.CEL GSM949168_Control3.CEL GSM949174_OSA1.CEL GSM949175_OSA2.CEL GSM949176_OSA3.CEL
1056                    377                    453                    576                390                272                477
1060                    371                    172                    280                168                133                274
1060                    371                    172                    280                168                133                274
1061                   1469                    347                    353                184                190                278
1063                    234                    184                    124                110                112                203
1064                   4885                   6538                   6502               5003               2902               5805
> head(mm(raw))
Error in rsqlite_send_query(conn@ptr, statement) : 
  no such table: mmfeature

 

 

here is my sessionInfo().

> sessionInfo()
R version 3.4.3 (2017-11-30)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 16299)

Matrix products: default

locale:
[1] LC_COLLATE=Chinese (Traditional)_Taiwan.950  LC_CTYPE=Chinese (Traditional)_Taiwan.950   
[3] LC_MONETARY=Chinese (Traditional)_Taiwan.950 LC_NUMERIC=C                                
[5] LC_TIME=Chinese (Traditional)_Taiwan.950    

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] pd.hugene.1.0.st.v1_3.14.1 DBI_0.7                    RSQLite_2.0                oligo_1.42.0              
 [5] Biostrings_2.46.0          XVector_0.18.0             IRanges_2.12.0             S4Vectors_0.16.0          
 [9] Biobase_2.38.0             oligoClasses_1.40.0        BiocGenerics_0.24.0       

loaded via a namespace (and not attached):
 [1] Rcpp_0.12.14               compiler_3.4.3             BiocInstaller_1.28.0       pillar_1.0.1              
 [5] GenomeInfoDb_1.14.0        bitops_1.0-6               iterators_1.0.9            tools_3.4.3               
 [9] zlibbioc_1.24.0            digest_0.6.13              bit_1.1-12                 memoise_1.1.0             
[13] preprocessCore_1.40.0      tibble_1.4.1               lattice_0.20-35            ff_2.2-13                 
[17] pkgconfig_2.0.1            rlang_0.1.6                Matrix_1.2-12              foreach_1.4.4             
[21] DelayedArray_0.4.1         GenomeInfoDbData_1.0.0     affxparser_1.50.0          bit64_0.9-7               
[25] grid_3.4.3                 blob_1.1.0                 codetools_0.2-15           matrixStats_0.52.2        
[29] GenomicRanges_1.30.0       splines_3.4.3              SummarizedExperiment_1.8.1 RCurl_1.95-4.10           
[33] affyio_1.48.0 

 

 

 

 

ADD COMMENTlink modified 8 months ago • written 8 months ago by chchen0
0
gravatar for chchen
8 months ago by
chchen0
chchen0 wrote:

ok, i found this post:

gcrma problem while processing HuGene-1_0-st-v1 genechip from Affymetrix

and the main reason is

HuGene-1_0-st-v1 dont contain mm probes, so mas5 cannot be used on this chip.

ADD COMMENTlink written 8 months ago by chchen0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 154 users visited in the last hour