Search
Question: R session terminates when trying to load affycoretools package
0
gravatar for biostR
4 months ago by
biostR0
biostR0 wrote:

Hi,

I recently installed affycoretools package  (version 1.46.5) via biocInstaller. After that, I tried to attach the package typing  library(affycoretools) within  Rstudio console and at each trial I encountered with the warning "R encountered fatal error. The session was terminated" .

I also tried loading the library in a vanilla session. R also stopped working. 

I would be very happy if I could overcome the problem because I am aiming to use some affycoretools functions. 

Below, the session info is provided. Thank you very much in advance. 

R version 3.3.1 (2016-06-21)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] oligoClasses_1.36.0 limma_3.28.21       Biostrings_2.42.1   XVector_0.14.1      IRanges_2.8.2      
[6] S4Vectors_0.12.2    Biobase_2.32.0      BiocGenerics_0.20.0

loaded via a namespace (and not attached):
 [1] Rcpp_0.12.15               GenomicRanges_1.26.4       zlibbioc_1.20.0            bit_1.1-12                
 [5] lattice_0.20-34            rlang_0.2.0                foreach_1.4.4              blob_1.1.0                
 [9] GenomeInfoDb_1.10.3        tools_3.3.1                SummarizedExperiment_1.4.0 grid_3.3.1                
[13] ff_2.2-13                  DBI_0.7                    iterators_1.0.9            digest_0.6.14             
[17] bit64_0.9-7                tibble_1.4.2               affyio_1.44.0              Matrix_1.2-8              
[21] bitops_1.0-6               codetools_0.2-15           RCurl_1.95-4.10            memoise_1.1.0             
[25] RSQLite_2.0   

 

ADD COMMENTlink modified 4 months ago by James W. MacDonald46k • written 4 months ago by biostR0
2
gravatar for James W. MacDonald
4 months ago by
United States
James W. MacDonald46k wrote:

You are using software that is almost 2 years out of date. Please update to a current version of R/Bioconductor, and let us know if you still have problems.

ADD COMMENTlink written 4 months ago by James W. MacDonald46k

Thank you very much for a fast answer. 

Now I installed the latest version of R, and I can load affycoretools without problems but actually I have some problems with latest version of R. 

I am not sure if I should post this problem as a separate question but  about a week ago I upgraded Rstudio and R packages (at that time I was using R version 3.4.1) and I started to run into "R code execution error" pop-up messages and also  I could not see the packages anymore in the packages pane. Trying to refresh the packages pane resulted in "readRDS(pfile) : unknown input format".  I reverted to a previous R software and that fixed up things for a while. Now there is the same problem with R version 3.4.3 I cannot use Rstudio efficiently. Thank you for your time. 

R version 3.4.3 (2017-11-30)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] limma_3.34.8        Biostrings_2.46.0   XVector_0.18.0      IRanges_2.12.0      S4Vectors_0.16.0   
[6] Biobase_2.38.0      BiocGenerics_0.24.0

loaded via a namespace (and not attached):
[1] zlibbioc_1.24.0 compiler_3.4.3  tools_3.4.3     affyio_1.48.0  
ADD REPLYlink written 4 months ago by biostR0

Any questions about RStudio should be asked on whatever help forum they might have. This support site is only intended to help people with questions about Bioconductor packages.

ADD REPLYlink written 4 months ago by James W. MacDonald46k

Sorry for the inconvenience. Unfortunately I could not visit the forum for a very long time and I forgot about posting rules.  Next time I will be careful about software/ content etc. 

Best.  

ADD REPLYlink written 4 months ago by biostR0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 264 users visited in the last hour