Error: could not find function "msaConvert"
1
0
Entering edit mode
singh24s • 0
@singh24s-16375
Last seen 4.1 years ago

Hey,

 

 prokAligned3 <- msaConvert(prokAligned, type="phangorn::phyDat")

 

Keep trying this code. keep getting the error could not find "msaconvert"

have upgraded everything,running latest version of R

msa • 666 views
ADD COMMENT
0
Entering edit mode

I have seen such error messages in the past, and the reason was always that the users read the manual of a newer version than they actually used. So, if you have the latest version, this is a new issue that I will be glad to go into. Please provide a minimal example that produces that error along with the result of sessionInfo(), otherwise I do not have sufficient information to analyze the issue.

ADD REPLY
0
Entering edit mode

This was the command:- prokAligned2 <- msaConvert(prokAligned, type="seqinr::alignment")
Error: could not find function "msaConvert"

 

sessionInfo()
R version 3.2.4 (2016-03-10)
Platform: x86_64-apple-darwin13.4.0 (64-bit)
Running under: OS X 10.10.5 (Yosemite)

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats4    parallel  stats     graphics 
[5] grDevices utils     datasets  methods  
[9] base     

other attached packages:
[1] seqinr_3.4-5        msa_1.2.1          
[3] Biostrings_2.38.4   XVector_0.10.0     
[5] IRanges_2.4.8       S4Vectors_0.8.11   
[7] BiocGenerics_0.16.1

loaded via a namespace (and not attached):
[1] MASS_7.3-50     zlibbioc_1.16.0
[3] tools_3.2.4     yaml_2.1.19    
[5] Rcpp_0.12.17    ade4_1.7-10    

ADD REPLY
0
Entering edit mode

i use this to install msa

source("https://bioconductor.org/biocLite.R")
biocLite("msa")

 

and always get version 1.2.1

ADD REPLY
0
Entering edit mode
UBodenhofer ▴ 290
@ubodenhofer-5425
Last seen 23 days ago
University of Applied Sciences Upper Au…

Well, as obvious from your sessionInfo() results, you are using R 3.2.4 which is more than two years old. Since Bioconductor binds releases to the latest R version, you only have Bioconductor 3.3, which includes 'msa' version 1.2.1. The msaConvert() function has been introduced in 'msa' version 1.3.3. In order to use msaConvert(), you need to install a newer version of R (ideally R 3.5.0 or 3.5.1), otherwise you will not have access to the latest features.

ADD COMMENT

Login before adding your answer.

Traffic: 439 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6