error with getBM function of biomaRt package
1
0
Entering edit mode
T Joshi ▴ 90
@t-joshi-3142
Last seen 8.1 years ago
Hi, I was running the example in getBM and got the following error: getBM(attributes=c("affy_hg_u95av2","hgnc_symbol","chromosome_name","b and"),filters="affy_hg_u95av2",values=c("1939_at","1503_at","1454_at") , mart=mart) Error in getBM(attributes = c("affy_hg_u95av2", "hgnc_symbol", "chromosome_name", : could not find function "postForm" Here is the sessionInfo: > sessionInfo() R version 2.7.1 (2008-06-23) ia64-unknown-linux-gnu attached base packages: [1] splines tools stats graphics grDevices utils datasets [8] methods base other attached packages: [1] GOstats_2.6.0 Category_2.6.0 genefilter_1.20.1 [4] survival_2.34-1 RBGL_1.18.0 annotate_1.18.0 [7] xtable_1.5-4 GO.db_2.2.0 AnnotationDbi_1.2.2 [10] RSQLite_0.6-9 DBI_0.2-4 Biobase_2.0.1 [13] graph_1.18.1 biomaRt_1.14.1 RCurl_0.0.666 loaded via a namespace (and not attached): [1] cluster_1.11.11 tcltk_2.7.1 XML_1.96-0 I also tried with some other data, but it doesn't seem to work anyway. I have attached the output of debug to this mail. Please let me know what's happening here. regards, Josh
GO GO • 1.6k views
ADD COMMENT
0
Entering edit mode
@james-w-macdonald-5106
Last seen 4 hours ago
United States
Hi Josh, The version of RCurl that you have seems to be really old to me. The version used by BioC 2.3 is 0.92-0. You might try biocLite("RCurl"), or better yet, upgrade to R-2.8.0 and BioC 2.3. Best, Jim T Joshi wrote: > Hi, > I was running the example in getBM and got the following error: > > getBM(attributes=c("affy_hg_u95av2","hgnc_symbol","chromosome_name", "band"),filters="affy_hg_u95av2",values=c("1939_at","1503_at","1454_at "), > mart=mart) > Error in getBM(attributes = c("affy_hg_u95av2", "hgnc_symbol", > "chromosome_name", : > could not find function "postForm" > > Here is the sessionInfo: >> sessionInfo() > R version 2.7.1 (2008-06-23) > ia64-unknown-linux-gnu > attached base packages: > [1] splines tools stats graphics grDevices utils datasets > [8] methods base > > other attached packages: > [1] GOstats_2.6.0 Category_2.6.0 genefilter_1.20.1 > [4] survival_2.34-1 RBGL_1.18.0 annotate_1.18.0 > [7] xtable_1.5-4 GO.db_2.2.0 AnnotationDbi_1.2.2 > [10] RSQLite_0.6-9 DBI_0.2-4 Biobase_2.0.1 > [13] graph_1.18.1 biomaRt_1.14.1 RCurl_0.0.666 > > loaded via a namespace (and not attached): > [1] cluster_1.11.11 tcltk_2.7.1 XML_1.96-0 > > I also tried with some other data, but it doesn't seem to work anyway. > I have attached the output of debug to this mail. Please let me know > what's happening here. > > regards, > Josh > > > -------------------------------------------------------------------- ---- > > _______________________________________________ > Bioconductor mailing list > Bioconductor at stat.math.ethz.ch > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor -- James W. MacDonald, M.S. Biostatistician Hildebrandt Lab 8220D MSRB III 1150 W. Medical Center Drive Ann Arbor MI 48109-0646 734-936-8662
ADD COMMENT
0
Entering edit mode
Hi, Thank you James, Installing RCurl package again solved the problem. Josh On Wed, Dec 3, 2008 at 2:25 PM, James W. MacDonald <jmacdon at="" med.umich.edu=""> wrote: > Hi Josh, > > The version of RCurl that you have seems to be really old to me. The version > used by BioC 2.3 is 0.92-0. You might try biocLite("RCurl"), or better yet, > upgrade to R-2.8.0 and BioC 2.3. > > Best, > > Jim > > > > T Joshi wrote: >> >> Hi, >> I was running the example in getBM and got the following error: >> >> >> getBM(attributes=c("affy_hg_u95av2","hgnc_symbol","chromosome_name" ,"band"),filters="affy_hg_u95av2",values=c("1939_at","1503_at","1454_a t"), >> mart=mart) >> Error in getBM(attributes = c("affy_hg_u95av2", "hgnc_symbol", >> "chromosome_name", : >> could not find function "postForm" >> >> Here is the sessionInfo: >>> >>> sessionInfo() >> >> R version 2.7.1 (2008-06-23) >> ia64-unknown-linux-gnu >> attached base packages: >> [1] splines tools stats graphics grDevices utils datasets >> [8] methods base >> >> other attached packages: >> [1] GOstats_2.6.0 Category_2.6.0 genefilter_1.20.1 >> [4] survival_2.34-1 RBGL_1.18.0 annotate_1.18.0 >> [7] xtable_1.5-4 GO.db_2.2.0 AnnotationDbi_1.2.2 >> [10] RSQLite_0.6-9 DBI_0.2-4 Biobase_2.0.1 >> [13] graph_1.18.1 biomaRt_1.14.1 RCurl_0.0.666 >> >> loaded via a namespace (and not attached): >> [1] cluster_1.11.11 tcltk_2.7.1 XML_1.96-0 >> >> I also tried with some other data, but it doesn't seem to work anyway. >> I have attached the output of debug to this mail. Please let me know >> what's happening here. >> >> regards, >> Josh >> >> >> ------------------------------------------------------------------- ----- >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at stat.math.ethz.ch >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: >> http://news.gmane.org/gmane.science.biology.informatics.conductor > > -- > James W. MacDonald, M.S. > Biostatistician > Hildebrandt Lab > 8220D MSRB III > 1150 W. Medical Center Drive > Ann Arbor MI 48109-0646 > 734-936-8662 >
ADD REPLY

Login before adding your answer.

Traffic: 213 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6