Question: error while loading the genefilter package [R 2.8.1. on Mac OSX 10.5.6]
0
gravatar for Massimo Pinto
10.6 years ago by
Massimo Pinto390
Massimo Pinto390 wrote:
Greetings BioC list readers, on a Mac OSX 10.5.6 with R 2.8.1 I have successfully installed a series of packages by typing the following code on the R Console. > source("http://bioconductor.org/biocLite.R") > biocLite() [...] however, this is what I am getting when I try to load genefilter, which is required by the package Agi4x44PreProcess > library(genefilter) Loading required package: Biobase Loading required package: tools Welcome to Bioconductor Vignettes contain introductory material. To view, type 'openVignette()'. To cite Bioconductor, see 'citation("Biobase")' and for packages 'citation(pkgname)'. Loading required package: survival Loading required package: splines Error in dyn.load(file, DLLpath = DLLpath, ...) : unable to load shared library '/Library/Frameworks/R.framework/Resources/library/genefilter/libs/i38 6/genefilter.so': dlopen(/Library/Frameworks/R.framework/Resources/library/genefilter/ libs/i386/genefilter.so, 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib Referenced from: /Library/Frameworks/R.framework/Resources/library/genefilter/libs/i386 /genefilter.so Reason: image not found Error: package/namespace load failed for 'genefilter' There is no /Library/Frameworks/ directory on my disk. Looks like I have got a messy installation. Does this look familiar to any of you? Yours, Massimo -- Massimo Pinto Post Doctoral Research Fellow Enrico Fermi Centre and Italian Public Health Research Institute (ISS), Rome http://claimid.com/massimopinto [[alternative HTML version deleted]]
genefilter • 1.1k views
ADD COMMENTlink modified 10.6 years ago by Patrick Aboyoun1.6k • written 10.6 years ago by Massimo Pinto390
Answer: error while loading the genefilter package [R 2.8.1. on Mac OSX 10.5.6]
0
gravatar for Patrick Aboyoun
10.6 years ago by
Patrick Aboyoun1.6k
United States
Patrick Aboyoun1.6k wrote:
Massimo, The problem is in the version of the genefilter Mac OS X 10.5 (Leopard) binary package you are using. I just downloaded genefilter version 1.22 for BioC 2.3 from bioconductor.org and don't see the dynamic linking to libgfortran that is suggested by your error message: sandbox$ otool -L genefilter/libs/i386/genefilter.so genefilter/libs/i386/genefilter.so: genefilter.so (compatibility version 0.0.0, current version 0.0.0) /Library/Frameworks/R.framework/Versions/2.8/Resources/lib/libR.dylib (compatibility version 2.8.0, current version 2.8.0) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFou ndation (compatibility version 150.0.0, current version 476.15.0) /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0) /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.1) Try to reinstall genefilter using biocLite("genefilter") and let me know if the problem persists. Perhaps it is with a different library. Include your sessionInfo() in your response so I can help troubleshoot any problems that arise. Patrick Massimo Pinto wrote: > Greetings BioC list readers, > > on a Mac OSX 10.5.6 with R 2.8.1 I have successfully installed a series of > packages by typing the following code on the R Console. > > >> source("http://bioconductor.org/biocLite.R") >> biocLite() >> > > [...] > > however, this is what I am getting when I try to load genefilter, which is > required by the package Agi4x44PreProcess > > >> library(genefilter) >> > Loading required package: Biobase > Loading required package: tools > > Welcome to Bioconductor > > Vignettes contain introductory material. To view, type > 'openVignette()'. To cite Bioconductor, see > 'citation("Biobase")' and for packages 'citation(pkgname)'. > > Loading required package: survival > Loading required package: splines > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared library > '/Library/Frameworks/R.framework/Resources/library/genefilter/libs/i 386/genefilter.so': > dlopen(/Library/Frameworks/R.framework/Resources/library/genefilte r/libs/i386/genefilter.so, > 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib > Referenced from: > /Library/Frameworks/R.framework/Resources/library/genefilter/libs/i3 86/genefilter.so > Reason: image not found > Error: package/namespace load failed for 'genefilter' > > There is no /Library/Frameworks/ directory on my disk. Looks like I have got > a messy installation. Does this look familiar to any of you? > Yours, > Massimo > >
ADD COMMENTlink written 10.6 years ago by Patrick Aboyoun1.6k
Hi Patrick, thank you for your assistance. Here is my SessionInfo() > sessionInfo() R version 2.8.1 (2008-12-22) i386-apple-darwin8.11.1 locale: C attached base packages: [1] splines tools stats graphics grDevices utils [7] datasets methods base other attached packages: [1] survival_2.34-1 Biobase_2.2.2 loaded via a namespace (and not attached): [1] AnnotationDbi_1.4.3 DBI_0.2-4 RSQLite_0.7-1 [4] annotate_1.20.1 ==== If I install genefilter from BioC, right from the R console, I am getting the same results as I indicated in my earlier message. Perhaps you mean that I should download the sources and re-compile? Mmm I used to do these things in Linux, I need to take some dust off my neurons if I need to get this done on a Mac. Massimo On Wed, Apr 15, 2009 at 6:27 PM, Patrick Aboyoun <paboyoun@fhcrc.org> wrote: > Massimo, > The problem is in the version of the genefilter Mac OS X 10.5 (Leopard) > binary package you are using. I just downloaded genefilter version 1.22 for > BioC 2.3 from bioconductor.org and don't see the dynamic linking to > libgfortran that is suggested by your error message: > > sandbox$ otool -L genefilter/libs/i386/genefilter.so > genefilter/libs/i386/genefilter.so: > genefilter.so (compatibility version 0.0.0, current version 0.0.0) > /Library/Frameworks/R.framework/Versions/2.8/Resources/lib/libR.dylib > (compatibility version 2.8.0, current version 2.8.0) > > /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreF oundation > (compatibility version 150.0.0, current version 476.15.0) > /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version > 7.4.0) > /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version > 1.0.0) > /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version > 111.1.1) > > Try to reinstall genefilter using biocLite("genefilter") and let me know if > the problem persists. Perhaps it is with a different library. Include your > sessionInfo() in your response so I can help troubleshoot any problems that > arise. > > > Patrick > > > > Massimo Pinto wrote: > >> Greetings BioC list readers, >> >> on a Mac OSX 10.5.6 with R 2.8.1 I have successfully installed a series of >> packages by typing the following code on the R Console. >> >> >> >>> source("http://bioconductor.org/biocLite.R") >>> biocLite() >>> >>> >> >> [...] >> >> however, this is what I am getting when I try to load genefilter, which is >> required by the package Agi4x44PreProcess >> >> >> >>> library(genefilter) >>> >>> >> Loading required package: Biobase >> Loading required package: tools >> >> Welcome to Bioconductor >> >> Vignettes contain introductory material. To view, type >> 'openVignette()'. To cite Bioconductor, see >> 'citation("Biobase")' and for packages 'citation(pkgname)'. >> >> Loading required package: survival >> Loading required package: splines >> Error in dyn.load(file, DLLpath = DLLpath, ...) : >> unable to load shared library >> >> '/Library/Frameworks/R.framework/Resources/library/genefilter/libs/ i386/genefilter.so': >> >> dlopen(/Library/Frameworks/R.framework/Resources/library/genefilte r/libs/i386/genefilter.so, >> 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib >> Referenced from: >> >> /Library/Frameworks/R.framework/Resources/library/genefilter/libs/i 386/genefilter.so >> Reason: image not found >> Error: package/namespace load failed for 'genefilter' >> >> There is no /Library/Frameworks/ directory on my disk. Looks like I have >> got >> a messy installation. Does this look familiar to any of you? >> Yours, >> Massimo >> >> >> > > -- Massimo Pinto Post Doctoral Research Fellow Enrico Fermi Centre and Italian Public Health Research Institute (ISS), Rome http://claimid.com/massimopinto [[alternative HTML version deleted]]
ADD REPLYlink written 10.6 years ago by Massimo Pinto390
Patrick I think I've got a similar problem with a collaborator who is also on OS X 10.5.6 and R 2.8.1, but here the problem is with the affy package. For some reason, it appears that biocLite is installing the OS X 10.4 version of the binary (from http://bioconductor.org/packages/2.3/bioc/bin/macosx/universal) rather then the 10.5 version (from http://bioconductor.org/packages/2.3/bioc/bin/macosx/leopard). Could this be a bug in biocLite? Here is the output from trying to install and load "affy", and the sessionInfo() > source("http://bioconductor.org/biocLite.R") > biocLite("affy") Running biocinstall version 2.3.10 with R version 2.8.1 Your version of R requires version 2.3 of Bioconductor. trying URL 'http://bioconductor.org/packages/2.3/bioc/bin/macosx/universal/contri b/2.8/affy_1.20.2.tgz' Content type 'application/x-gzip' length 1439037 bytes (1.4 Mb) opened URL ================================================== downloaded 1.4 Mb The downloaded packages are in /var/folders/B7/B77yjISEE1iKVBJQ80Q+lk+++TI/-Tmp-//Rtmp0yyhTV/download ed_packages > library("affy") Loading required package: Biobase Loading required package: tools Welcome to Bioconductor Vignettes contain introductory material. To view, type 'openVignette()'. To cite Bioconductor, see 'citation("Biobase")' and for packages 'citation(pkgname)'. Error in dyn.load(file, DLLpath = DLLpath, ...) : unable to load shared library '/Library/Frameworks/R.framework/Resources/library/preprocessCore/libs /i386/preprocessCore.so': dlopen(/Library/Frameworks/R.framework/Resources/library/preprocessCor e/libs/i386/preprocessCore.so, 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib Referenced from: /Library/Frameworks/R.framework/Resources/library/preprocessCore/libs/ i386/preprocessCore.so Reason: image not found Error: package/namespace load failed for 'affy' >sessionInfo() R version 2.8.1 (2008-12-22) i386-apple-darwin8.11.1 locale: en_GB.UTF-8/en_GB.UTF-8/C/C/en_GB.UTF-8/en_GB.UTF-8 attached base packages: [1] tools stats graphics grDevices utils datasets methods base other attached packages: [1] Biobase_2.2.2 loaded via a namespace (and not attached): [1] affyio_1.10.1 Cheers Richard Massimo Pinto wrote: > Hi Patrick, thank you for your assistance. > Here is my SessionInfo() > >> sessionInfo() > R version 2.8.1 (2008-12-22) > i386-apple-darwin8.11.1 > > locale: > C > > attached base packages: > [1] splines tools stats graphics grDevices utils > [7] datasets methods base > > other attached packages: > [1] survival_2.34-1 Biobase_2.2.2 > > loaded via a namespace (and not attached): > [1] AnnotationDbi_1.4.3 DBI_0.2-4 RSQLite_0.7-1 > [4] annotate_1.20.1 > > ==== > > If I install genefilter from BioC, right from the R console, I am getting > the same results as I indicated in my earlier message. Perhaps you mean that > I should download the sources and re-compile? Mmm I used to do these things > in Linux, I need to take some dust off my neurons if I need to get this done > on a Mac. > > Massimo > > > > On Wed, Apr 15, 2009 at 6:27 PM, Patrick Aboyoun <paboyoun at="" fhcrc.org=""> wrote: > >> Massimo, >> The problem is in the version of the genefilter Mac OS X 10.5 (Leopard) >> binary package you are using. I just downloaded genefilter version 1.22 for >> BioC 2.3 from bioconductor.org and don't see the dynamic linking to >> libgfortran that is suggested by your error message: >> >> sandbox$ otool -L genefilter/libs/i386/genefilter.so >> genefilter/libs/i386/genefilter.so: >> genefilter.so (compatibility version 0.0.0, current version 0.0.0) >> /Library/Frameworks/R.framework/Versions/2.8/Resources/lib/libR.dylib >> (compatibility version 2.8.0, current version 2.8.0) >> >> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/Core Foundation >> (compatibility version 150.0.0, current version 476.15.0) >> /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version >> 7.4.0) >> /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version >> 1.0.0) >> /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version >> 111.1.1) >> >> Try to reinstall genefilter using biocLite("genefilter") and let me know if >> the problem persists. Perhaps it is with a different library. Include your >> sessionInfo() in your response so I can help troubleshoot any problems that >> arise. >> >> >> Patrick >> >> >> >> Massimo Pinto wrote: >> >>> Greetings BioC list readers, >>> >>> on a Mac OSX 10.5.6 with R 2.8.1 I have successfully installed a series of >>> packages by typing the following code on the R Console. >>> >>> >>> >>>> source("http://bioconductor.org/biocLite.R") >>>> biocLite() >>>> >>>> >>> [...] >>> >>> however, this is what I am getting when I try to load genefilter, which is >>> required by the package Agi4x44PreProcess >>> >>> >>> >>>> library(genefilter) >>>> >>>> >>> Loading required package: Biobase >>> Loading required package: tools >>> >>> Welcome to Bioconductor >>> >>> Vignettes contain introductory material. To view, type >>> 'openVignette()'. To cite Bioconductor, see >>> 'citation("Biobase")' and for packages 'citation(pkgname)'. >>> >>> Loading required package: survival >>> Loading required package: splines >>> Error in dyn.load(file, DLLpath = DLLpath, ...) : >>> unable to load shared library >>> >>> '/Library/Frameworks/R.framework/Resources/library/genefilter/libs /i386/genefilter.so': >>> >>> dlopen(/Library/Frameworks/R.framework/Resources/library/genefilt er/libs/i386/genefilter.so, >>> 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib >>> Referenced from: >>> >>> /Library/Frameworks/R.framework/Resources/library/genefilter/libs/ i386/genefilter.so >>> Reason: image not found >>> Error: package/namespace load failed for 'genefilter' >>> >>> There is no /Library/Frameworks/ directory on my disk. Looks like I have >>> got >>> a messy installation. Does this look familiar to any of you? >>> Yours, >>> Massimo >>> >>> >>> >> > > -- Richard D Pearson richard.pearson at well.ox.ac.uk Wellcome Trust Centre for Human Genetics http://www.well.ox.ac.uk/~rpearson University of Oxford Tel: +44 (0)1865 287575 Roosevelt Drive Mob: +44 (0)7971 221181 Oxford OX3 7BN, UK Fax: +44 (0)1865 287664
ADD REPLYlink written 10.6 years ago by Richard Pearson160
Richard, According to your sessionInfo, you are running i386-apple- darwin8.11.1, which is Mac OS X 10.4 (Tiger). These two issues are related, however, and I just pushed a fix to bioconductor.org, that is available through biocLite. There were some older builds of Mac OS X binary packages for BioC 2.3 at bioconductor.org that didn't have its dynamic links revised to work with libraries supplied in the pre-built versions of R for Macs OS X. Due to web caching it may take up to 24 hours for the new packages to be available using biocLite, so you can try now and if it doesn't work wait some hours and try again. Hopefully the cache will clear sooner rather than later. Patrick Richard Pearson wrote: > Patrick > > I think I've got a similar problem with a collaborator who is also on > OS X 10.5.6 and R 2.8.1, but here the problem is with the affy > package. For some reason, it appears that biocLite is installing the > OS X 10.4 version of the binary (from > http://bioconductor.org/packages/2.3/bioc/bin/macosx/universal) rather > then the 10.5 version (from > http://bioconductor.org/packages/2.3/bioc/bin/macosx/leopard). Could > this be a bug in biocLite? > > Here is the output from trying to install and load "affy", and the > sessionInfo() > > > source("http://bioconductor.org/biocLite.R") > > biocLite("affy") > Running biocinstall version 2.3.10 with R version 2.8.1 > Your version of R requires version 2.3 of Bioconductor. > trying URL > 'http://bioconductor.org/packages/2.3/bioc/bin/macosx/universal/cont rib/2.8/affy_1.20.2.tgz' > > Content type 'application/x-gzip' length 1439037 bytes (1.4 Mb) > opened URL > ================================================== > downloaded 1.4 Mb > > > The downloaded packages are in > > /var/folders/B7/B77yjISEE1iKVBJQ80Q+lk+++TI/-Tmp-//Rtmp0yyhTV/downlo aded_packages > > > library("affy") > Loading required package: Biobase > Loading required package: tools > > Welcome to Bioconductor > > Vignettes contain introductory material. To view, type > 'openVignette()'. To cite Bioconductor, see > 'citation("Biobase")' and for packages 'citation(pkgname)'. > > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared library > '/Library/Frameworks/R.framework/Resources/library/preprocessCore/li bs/i386/preprocessCore.so': > > > dlopen(/Library/Frameworks/R.framework/Resources/library/preprocessC ore/libs/i386/preprocessCore.so, > 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib > Referenced from: > /Library/Frameworks/R.framework/Resources/library/preprocessCore/lib s/i386/preprocessCore.so > > Reason: image not found > Error: package/namespace load failed for 'affy' > > > > >sessionInfo() > > R version 2.8.1 (2008-12-22) > i386-apple-darwin8.11.1 > > locale: > en_GB.UTF-8/en_GB.UTF-8/C/C/en_GB.UTF-8/en_GB.UTF-8 > > attached base packages: > [1] tools stats graphics grDevices utils datasets > methods base > other attached packages: > [1] Biobase_2.2.2 > > loaded via a namespace (and not attached): > [1] affyio_1.10.1 > > Cheers > > Richard > > > Massimo Pinto wrote: >> Hi Patrick, thank you for your assistance. >> Here is my SessionInfo() >> >>> sessionInfo() >> R version 2.8.1 (2008-12-22) >> i386-apple-darwin8.11.1 >> >> locale: >> C >> >> attached base packages: >> [1] splines tools stats graphics grDevices utils >> [7] datasets methods base >> >> other attached packages: >> [1] survival_2.34-1 Biobase_2.2.2 >> >> loaded via a namespace (and not attached): >> [1] AnnotationDbi_1.4.3 DBI_0.2-4 RSQLite_0.7-1 >> [4] annotate_1.20.1 >> >> ==== >> >> If I install genefilter from BioC, right from the R console, I am >> getting >> the same results as I indicated in my earlier message. Perhaps you >> mean that >> I should download the sources and re-compile? Mmm I used to do these >> things >> in Linux, I need to take some dust off my neurons if I need to get >> this done >> on a Mac. >> >> Massimo >> >> >> >> On Wed, Apr 15, 2009 at 6:27 PM, Patrick Aboyoun <paboyoun at="" fhcrc.org=""> >> wrote: >> >>> Massimo, >>> The problem is in the version of the genefilter Mac OS X 10.5 (Leopard) >>> binary package you are using. I just downloaded genefilter version >>> 1.22 for >>> BioC 2.3 from bioconductor.org and don't see the dynamic linking to >>> libgfortran that is suggested by your error message: >>> >>> sandbox$ otool -L genefilter/libs/i386/genefilter.so >>> genefilter/libs/i386/genefilter.so: >>> genefilter.so (compatibility version 0.0.0, current version 0.0.0) >>> /Library/Frameworks/R.framework/Versions/2.8/Resources/lib/libR.dylib >>> (compatibility version 2.8.0, current version 2.8.0) >>> >>> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/Cor eFoundation >>> >>> (compatibility version 150.0.0, current version 476.15.0) >>> /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current >>> version >>> 7.4.0) >>> /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current >>> version >>> 1.0.0) >>> /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current >>> version >>> 111.1.1) >>> >>> Try to reinstall genefilter using biocLite("genefilter") and let me >>> know if >>> the problem persists. Perhaps it is with a different library. >>> Include your >>> sessionInfo() in your response so I can help troubleshoot any >>> problems that >>> arise. >>> >>> >>> Patrick >>> >>> >>> >>> Massimo Pinto wrote: >>> >>>> Greetings BioC list readers, >>>> >>>> on a Mac OSX 10.5.6 with R 2.8.1 I have successfully installed a >>>> series of >>>> packages by typing the following code on the R Console. >>>> >>>> >>>> >>>>> source("http://bioconductor.org/biocLite.R") >>>>> biocLite() >>>>> >>>>> >>>> [...] >>>> >>>> however, this is what I am getting when I try to load genefilter, >>>> which is >>>> required by the package Agi4x44PreProcess >>>> >>>> >>>> >>>>> library(genefilter) >>>>> >>>>> >>>> Loading required package: Biobase >>>> Loading required package: tools >>>> >>>> Welcome to Bioconductor >>>> >>>> Vignettes contain introductory material. To view, type >>>> 'openVignette()'. To cite Bioconductor, see >>>> 'citation("Biobase")' and for packages 'citation(pkgname)'. >>>> >>>> Loading required package: survival >>>> Loading required package: splines >>>> Error in dyn.load(file, DLLpath = DLLpath, ...) : >>>> unable to load shared library >>>> >>>> '/Library/Frameworks/R.framework/Resources/library/genefilter/lib s/i386/genefilter.so': >>>> >>>> >>>> dlopen(/Library/Frameworks/R.framework/Resources/library/genefil ter/libs/i386/genefilter.so, >>>> >>>> 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib >>>> Referenced from: >>>> >>>> /Library/Frameworks/R.framework/Resources/library/genefilter/libs /i386/genefilter.so >>>> >>>> Reason: image not found >>>> Error: package/namespace load failed for 'genefilter' >>>> >>>> There is no /Library/Frameworks/ directory on my disk. Looks like I >>>> have >>>> got >>>> a messy installation. Does this look familiar to any of you? >>>> Yours, >>>> Massimo >>>> >>>> >>>> >>> >> >> >
ADD REPLYlink written 10.6 years ago by Patrick Aboyoun1.6k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 476 users visited in the last hour