Entering edit mode
one more point about accessors. when autogenerated in the
OOP package, last time I looked, the accessor functions
had a prefix
for slot foo, you would get an accessor function "getFoo"
you might also get an assignment helper "setFoo"
we MAY want to start distinguishing our accessors in this manner.
this can be done in a backwards compatible way, by simply
adding compliantly named slots. we then deprecate the
old style accessors and after a certain time, eliminate them
from the class definition.