Question: difficulty loading rsbml
0
gravatar for Paul Shannon
8.8 years ago by
Paul Shannon1.1k
Paul Shannon1.1k wrote:
The specific error is see (text below) suggests that libsbml is not being found. ASTNode appears to be a symbol in libsbml biocLite ('rbsml') installing /usr/local/lib/libsbml.4.2.0.dylib export DYLD_LIBRARY_PATH=/usr/local/lib R > library (rsbml) I get this error message: Error : .onLoad failed in loadNamespace() for 'rsbml', details: call: dyn.load(file, DLLpath = DLLpath, ...) error: unable to load shared object '/Library/Frameworks/R.framework /Versions/2.12/Resources/library/rsbml/libs/x86_64/rsbml.so': dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/libra ry/rsbml/libs/x86_64/rsbml.so, 6): Symbol not found: _ASTNode_addChild Referenced from: /Library/Frameworks/R.framework/Versions/2.12/Resou rces/library/rsbml/libs/x86_64/rsbml.so Expected in: dynamic lookup Error: package/namespace load failed for 'rsbml' rsbml.so is where it is supposed to be: /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsbm l/libs/x86_64: -rwxr-xr-x 1 pshannon admin 95328 Oct 19 22:08 rsbml.so Any suggestions? Thanks. - Paul > sessionInfo () R version 2.12.1 (2010-12-16) Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) locale: [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 attached base packages: [1] stats graphics grDevices utils datasets methods base loaded via a namespace (and not attached): [1] graph_1.29.2 tools_2.12.1
rsbml • 1.3k views
ADD COMMENTlink modified 3.7 years ago by den.kazakiewicz0 • written 8.8 years ago by Paul Shannon1.1k
Answer: difficulty loading rsbml
0
gravatar for Dan Tenenbaum
8.8 years ago by
Dan Tenenbaum8.2k
United States
Dan Tenenbaum8.2k wrote:
On Sat, Feb 5, 2011 at 8:23 PM, Paul Shannon <pshannon@systemsbiology.org>wrote: > The specific error is see (text below) suggests that libsbml is not being > found. ASTNode appears to be a symbol in libsbml > > biocLite ('rbsml') > installing /usr/local/lib/libsbml.4.2.0.dylib > export DYLD_LIBRARY_PATH=/usr/local/lib > R > > library (rsbml) > > I get this error message: > > Error : .onLoad failed in loadNamespace() for 'rsbml', details: > call: dyn.load(file, DLLpath = DLLpath, ...) > error: unable to load shared object > '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64/rsbml.so': > dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/libr ary/rsbml/libs/x86_64/rsbml.so, > 6): Symbol not found: _ASTNode_addChild > Referenced from: > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsbm l/libs/x86_64/rsbml.so > Expected in: dynamic lookup > > Error: package/namespace load failed for 'rsbml' > > rsbml.so is where it is supposed to be: > > > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64: > -rwxr-xr-x 1 pshannon admin 95328 Oct 19 22:08 rsbml.so > > Any suggestions? Thanks. > > - Paul > > Hi Paul, rsbml requires that you install libsbml. rsbml does not do this for you. You can get libsbml from http://www.sbml.org. Dan > > > sessionInfo () > R version 2.12.1 (2010-12-16) > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > locale: > [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > loaded via a namespace (and not attached): > [1] graph_1.29.2 tools_2.12.1 > _______________________________________________ > Bioconductor mailing list > Bioconductor@r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > [[alternative HTML version deleted]]
ADD COMMENTlink written 8.8 years ago by Dan Tenenbaum8.2k
Thanks for your replies, Dan and Martin. My original post mostly concealed that I do have libsbml installed. A quick test from python shows that it works: python can read the latest, full yeastNet sbml file. So the problem appears to be that something I have done, or not done, leads to rsbml not being able to find libsbml. I thought that perhaps the macos version of LD_LIBRARY_PATH (which is 'DYLD_LIBRARY_PATH') might not be properly set. Here's what I tried. Maybe wiser heads than my own can see what I am doing wrong. bash> export DYLD_LIBRARY_PATH=/usr/local/lib bash> R > env = Sys.getenv () > env [grep ('DYLD', names (env))] # find out the value of this path to the running R process DYLD_LIBRARY_PATH "/Library/Frameworks/R.framework/Resources/lib/x86_64:/usr/local/lib" > grep ('libsbml', list.files ('/usr/local/lib'), value=TRUE) # is libsbml findable down that path? [1] "libsbml.4.2.0.dylib" "libsbml.4.dylib" "libsbml.a" "libsbml.dylib" "libsbml.la" "libsbmlj.jnilib" > library (rsbml) # try to load. as rsbml.so loads, it looks for, but cannot find, libsbml (apparently) Error : .onLoad failed in loadNamespace() for 'rsbml', details: call: dyn.load(file, DLLpath = DLLpath, ...) error: unable to load shared object '/Library/Frameworks/R.framewo rk/Versions/2.12/Resources/library/rsbml/libs/x86_64/rsbml.so': dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/lib rary/rsbml/libs/x86_64/rsbml.so, 6): Symbol not found: _ASTNode_addChild Referenced from: /Library/Frameworks/R.framework/Versions/2.12/Res ources/library/rsbml/libs/x86_64/rsbml.so Expected in: dynamic lookup Error: package/namespace load failed for 'rsbml' Any suggestions? Thanks! - Paul sessionInfo () R version 2.12.1 (2010-12-16) Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) locale: [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 attached base packages: [1] stats graphics grDevices utils datasets methods base loaded via a namespace (and not attached): [1] graph_1.29.2 tools_2.12.1 On Feb 6, 2011, at 12:12 AM, Dan Tenenbaum wrote: > > > On Sat, Feb 5, 2011 at 8:23 PM, Paul Shannon <pshannon at="" systemsbiology.org=""> wrote: > The specific error is see (text below) suggests that libsbml is not being found. ASTNode appears to be a symbol in libsbml > > biocLite ('rbsml') > installing /usr/local/lib/libsbml.4.2.0.dylib > export DYLD_LIBRARY_PATH=/usr/local/lib > R > > library (rsbml) > > I get this error message: > > Error : .onLoad failed in loadNamespace() for 'rsbml', details: > call: dyn.load(file, DLLpath = DLLpath, ...) > error: unable to load shared object '/Library/Frameworks/R.framewor k/Versions/2.12/Resources/library/rsbml/libs/x86_64/rsbml.so': > dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/libr ary/rsbml/libs/x86_64/rsbml.so, 6): Symbol not found: _ASTNode_addChild > Referenced from: /Library/Frameworks/R.framework/Versions/2.12/Reso urces/library/rsbml/libs/x86_64/rsbml.so > Expected in: dynamic lookup > > Error: package/namespace load failed for 'rsbml' > > rsbml.so is where it is supposed to be: > > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64: > -rwxr-xr-x 1 pshannon admin 95328 Oct 19 22:08 rsbml.so > > Any suggestions? Thanks. > > - Paul > > > > Hi Paul, > > rsbml requires that you install libsbml. rsbml does not do this for you. > > You can get libsbml from http://www.sbml.org. > > Dan > > > > sessionInfo () > R version 2.12.1 (2010-12-16) > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > locale: > [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > loaded via a namespace (and not attached): > [1] graph_1.29.2 tools_2.12.1 > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor >
ADD REPLYlink written 8.8 years ago by Paul Shannon1.1k
On Sun, Feb 6, 2011 at 8:19 AM, Paul Shannon <pshannon@systemsbiology.org>wrote: > Thanks for your replies, Dan and Martin. > > My original post mostly concealed that I do have libsbml installed. A > quick test from python shows that it works: python can read the latest, full > yeastNet sbml file. So the problem appears to be that something I have > done, or not done, leads to rsbml not being able to find libsbml. > > I thought that perhaps the macos version of LD_LIBRARY_PATH (which is > 'DYLD_LIBRARY_PATH') might not be properly set. > Here's what I tried. Maybe wiser heads than my own can see what I am doing > wrong. > > bash> export DYLD_LIBRARY_PATH=/usr/local/lib > bash> R > > env = Sys.getenv () > > env [grep ('DYLD', names (env))] # find out the value of this path to > the running R process > DYLD_LIBRARY_PATH > "/Library/Frameworks/R.framework/Resources/lib/x86_64:/usr/local/lib" > > > grep ('libsbml', list.files ('/usr/local/lib'), value=TRUE) # is > libsbml findable down that path? > [1] "libsbml.4.2.0.dylib" "libsbml.4.dylib" "libsbml.a" > "libsbml.dylib" "libsbml.la" "libsbmlj.jnilib" > > > library (rsbml) # try to load. as rsbml.so loads, it looks for, but > cannot find, libsbml (apparently) > Error : .onLoad failed in loadNamespace() for 'rsbml', details: > call: dyn.load(file, DLLpath = DLLpath, ...) > error: unable to load shared object > '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64/rsbml.so': > > dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/libr ary/rsbml/libs/x86_64/rsbml.so, > 6): Symbol not found: _ASTNode_addChild > Referenced from: > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsbm l/libs/x86_64/rsbml.so > Expected in: dynamic lookup > > Error: package/namespace load failed for 'rsbml' > > Any suggestions? > You might try building rsbml from source--it will prompt you to configure some variables (such as the location of libsbml) if they are needed. source("http://bioconductor.org/biocLite.R") biocLite("rsbml", type="source") Dan > Thanks! > > - Paul > > sessionInfo () > R version 2.12.1 (2010-12-16) > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > locale: > [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > loaded via a namespace (and not attached): > [1] graph_1.29.2 tools_2.12.1 > > > > > > > On Feb 6, 2011, at 12:12 AM, Dan Tenenbaum wrote: > > > > > > > On Sat, Feb 5, 2011 at 8:23 PM, Paul Shannon < > pshannon@systemsbiology.org> wrote: > > The specific error is see (text below) suggests that libsbml is not being > found. ASTNode appears to be a symbol in libsbml > > > > biocLite ('rbsml') > > installing /usr/local/lib/libsbml.4.2.0.dylib > > export DYLD_LIBRARY_PATH=/usr/local/lib > > R > > > library (rsbml) > > > > I get this error message: > > > > Error : .onLoad failed in loadNamespace() for 'rsbml', details: > > call: dyn.load(file, DLLpath = DLLpath, ...) > > error: unable to load shared object > '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64/rsbml.so': > > > dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/libr ary/rsbml/libs/x86_64/rsbml.so, > 6): Symbol not found: _ASTNode_addChild > > Referenced from: > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsbm l/libs/x86_64/rsbml.so > > Expected in: dynamic lookup > > > > Error: package/namespace load failed for 'rsbml' > > > > rsbml.so is where it is supposed to be: > > > > > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64: > > -rwxr-xr-x 1 pshannon admin 95328 Oct 19 22:08 rsbml.so > > > > Any suggestions? Thanks. > > > > - Paul > > > > > > > > Hi Paul, > > > > rsbml requires that you install libsbml. rsbml does not do this for you. > > > > You can get libsbml from http://www.sbml.org. > > > > Dan > > > > > > > sessionInfo () > > R version 2.12.1 (2010-12-16) > > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > > > locale: > > [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 > > > > attached base packages: > > [1] stats graphics grDevices utils datasets methods base > > > > loaded via a namespace (and not attached): > > [1] graph_1.29.2 tools_2.12.1 > > _______________________________________________ > > Bioconductor mailing list > > Bioconductor@r-project.org > > https://stat.ethz.ch/mailman/listinfo/bioconductor > > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > > > > [[alternative HTML version deleted]]
ADD REPLYlink written 8.8 years ago by Dan Tenenbaum8.2k
Probably because your libsbml version is too new. rsbml only supports libsbml 3.x. If anyone wants to volunteer to fix that, please let me know. SBML falls too far outside the scope of my current work. Thanks, Michael On Sun, Feb 6, 2011 at 8:19 AM, Paul Shannon <pshannon@systemsbiology.org>wrote: > Thanks for your replies, Dan and Martin. > > My original post mostly concealed that I do have libsbml installed. A > quick test from python shows that it works: python can read the latest, full > yeastNet sbml file. So the problem appears to be that something I have > done, or not done, leads to rsbml not being able to find libsbml. > > I thought that perhaps the macos version of LD_LIBRARY_PATH (which is > 'DYLD_LIBRARY_PATH') might not be properly set. > Here's what I tried. Maybe wiser heads than my own can see what I am doing > wrong. > > bash> export DYLD_LIBRARY_PATH=/usr/local/lib > bash> R > > env = Sys.getenv () > > env [grep ('DYLD', names (env))] # find out the value of this path to > the running R process > DYLD_LIBRARY_PATH > "/Library/Frameworks/R.framework/Resources/lib/x86_64:/usr/local/lib" > > > grep ('libsbml', list.files ('/usr/local/lib'), value=TRUE) # is > libsbml findable down that path? > [1] "libsbml.4.2.0.dylib" "libsbml.4.dylib" "libsbml.a" > "libsbml.dylib" "libsbml.la" "libsbmlj.jnilib" > > > library (rsbml) # try to load. as rsbml.so loads, it looks for, but > cannot find, libsbml (apparently) > Error : .onLoad failed in loadNamespace() for 'rsbml', details: > call: dyn.load(file, DLLpath = DLLpath, ...) > error: unable to load shared object > '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64/rsbml.so': > > dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/libr ary/rsbml/libs/x86_64/rsbml.so, > 6): Symbol not found: _ASTNode_addChild > Referenced from: > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsbm l/libs/x86_64/rsbml.so > Expected in: dynamic lookup > > Error: package/namespace load failed for 'rsbml' > > Any suggestions? > > Thanks! > > - Paul > > sessionInfo () > R version 2.12.1 (2010-12-16) > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > locale: > [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > loaded via a namespace (and not attached): > [1] graph_1.29.2 tools_2.12.1 > > > > > > > On Feb 6, 2011, at 12:12 AM, Dan Tenenbaum wrote: > > > > > > > On Sat, Feb 5, 2011 at 8:23 PM, Paul Shannon < > pshannon@systemsbiology.org> wrote: > > The specific error is see (text below) suggests that libsbml is not being > found. ASTNode appears to be a symbol in libsbml > > > > biocLite ('rbsml') > > installing /usr/local/lib/libsbml.4.2.0.dylib > > export DYLD_LIBRARY_PATH=/usr/local/lib > > R > > > library (rsbml) > > > > I get this error message: > > > > Error : .onLoad failed in loadNamespace() for 'rsbml', details: > > call: dyn.load(file, DLLpath = DLLpath, ...) > > error: unable to load shared object > '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64/rsbml.so': > > > dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/libr ary/rsbml/libs/x86_64/rsbml.so, > 6): Symbol not found: _ASTNode_addChild > > Referenced from: > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsbm l/libs/x86_64/rsbml.so > > Expected in: dynamic lookup > > > > Error: package/namespace load failed for 'rsbml' > > > > rsbml.so is where it is supposed to be: > > > > > /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64: > > -rwxr-xr-x 1 pshannon admin 95328 Oct 19 22:08 rsbml.so > > > > Any suggestions? Thanks. > > > > - Paul > > > > > > > > Hi Paul, > > > > rsbml requires that you install libsbml. rsbml does not do this for you. > > > > You can get libsbml from http://www.sbml.org. > > > > Dan > > > > > > > sessionInfo () > > R version 2.12.1 (2010-12-16) > > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > > > locale: > > [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 > > > > attached base packages: > > [1] stats graphics grDevices utils datasets methods base > > > > loaded via a namespace (and not attached): > > [1] graph_1.29.2 tools_2.12.1 > > _______________________________________________ > > Bioconductor mailing list > > Bioconductor@r-project.org > > https://stat.ethz.ch/mailman/listinfo/bioconductor > > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > > > > _______________________________________________ > Bioconductor mailing list > Bioconductor@r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > [[alternative HTML version deleted]]
ADD REPLYlink written 8.8 years ago by Michael Lawrence11k
I just built, from source, libsbml 5.0.0-b1 and then did biocLite to get rsbml installed from source. i needed to set PKG_CONFIG_PATH to know where the libsbml.pc was and all was well > dom <- rsbml_dom(doc) > sapply(species(model(dom)), id) Glucose Glucose_6_phosphate "Glucose" "Glucose_6_phosphate" Fructose_6_phosphate Fructose_1_6_bisphosphate "Fructose_6_phosphate" "Fructose_1_6_bisphosphate" Dihydroxyacetonephosphate Glyceraldehyd_3_phosphate "Dihydroxyacetonephosphate" "Glyceraldehyd_3_phosphate" _1_3_Bisphosphoglycerate _3_Phosphoglycerate "_1_3_Bisphosphoglycerate" "_3_Phosphoglycerate" _2_Phosphoglycerate Phosphoenolpyruvate "_2_Phosphoglycerate" "Phosphoenolpyruvate" Pyruvate ATP "Pyruvate" "ATP" ADP H_ "ADP" "H_" NAD_ NADH "NAD_" "NADH" H2O Pi "H2O" "Pi" > sessionInfo() R version 2.13.0 Under development (unstable) (2010-12-18 r53869) Platform: x86_64-apple-darwin10.4.0/x86_64 (64-bit) locale: [1] C attached base packages: [1] stats graphics grDevices datasets tools utils methods [8] base other attached packages: [1] Biobase_2.11.6 rsbml_2.9.1 weaver_1.17.0 codetools_0.2-6 [5] digest_0.4.2 loaded via a namespace (and not attached): [1] graph_1.29.0 Perhaps Paul and I can take this off line if a similar configuration is not working for him... and then get back to the list. On Sun, Feb 6, 2011 at 7:20 PM, Michael Lawrence <lawrence.michael at="" gene.com=""> wrote: > Probably because your libsbml version is too new. rsbml only supports > libsbml 3.x. If anyone wants to volunteer to fix that, please let me know. > SBML falls too far outside the scope of my current work. > > Thanks, > Michael > > On Sun, Feb 6, 2011 at 8:19 AM, Paul Shannon <pshannon at="" systemsbiology.org="">wrote: > >> Thanks for your replies, Dan and Martin. >> >> My original post mostly concealed that I do have libsbml installed. ?A >> quick test from python shows that it works: python can read the latest, full >> yeastNet sbml file. ?So the problem appears to be that something I have >> done, or not done, leads to rsbml not being able to find libsbml. >> >> I thought that perhaps the macos version of LD_LIBRARY_PATH (which is >> 'DYLD_LIBRARY_PATH') might not be properly set. >> Here's what I tried. ?Maybe wiser heads than my own can see what I am doing >> wrong. >> >> ?bash> export DYLD_LIBRARY_PATH=/usr/local/lib >> ?bash> R >> ?> env = Sys.getenv () >> ?> env [grep ('DYLD', names (env))] ?# find out the value of this path to >> the running R process >> ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? DYLD_LIBRARY_PATH >> ? ?"/Library/Frameworks/R.framework/Resources/lib/x86_64:/usr/local/lib" >> >> ?> grep ('libsbml', list.files ('/usr/local/lib'), value=TRUE) ? # is >> libsbml findable down that path? >> ? ? [1] "libsbml.4.2.0.dylib" "libsbml.4.dylib" ? ? "libsbml.a" >> "libsbml.dylib" ? ? ? "libsbml.la" ? ? ? ? ?"libsbmlj.jnilib" >> >> ?> library (rsbml) ? # try to load. ?as rsbml.so loads, it looks for, but >> cannot find, libsbml (apparently) >> ? ? Error : .onLoad failed in loadNamespace() for 'rsbml', details: >> ? ?call: dyn.load(file, DLLpath = DLLpath, ...) >> ? ?error: unable to load shared object >> '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rs bml/libs/x86_64/rsbml.so': >> >> ?dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/lib rary/rsbml/libs/x86_64/rsbml.so, >> 6): Symbol not found: _ASTNode_addChild >> ? ?Referenced from: >> /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64/rsbml.so >> ? ?Expected in: dynamic lookup >> >> ? Error: package/namespace load failed for 'rsbml' >> >> Any suggestions? >> >> Thanks! >> >> ?- Paul >> >> sessionInfo () >> R version 2.12.1 (2010-12-16) >> Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) >> >> locale: >> [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 >> >> attached base packages: >> [1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods ? base >> >> loaded via a namespace (and not attached): >> [1] graph_1.29.2 tools_2.12.1 >> >> >> >> >> >> >> On Feb 6, 2011, at 12:12 AM, Dan Tenenbaum wrote: >> >> > >> > >> > On Sat, Feb 5, 2011 at 8:23 PM, Paul Shannon < >> pshannon at systemsbiology.org> wrote: >> > The specific error is see (text below) suggests that libsbml is not being >> found. ?ASTNode appears to be a symbol in libsbml >> > >> > ?biocLite ('rbsml') >> > ?installing /usr/local/lib/libsbml.4.2.0.dylib >> > ?export DYLD_LIBRARY_PATH=/usr/local/lib >> > ?R >> > ?> library (rsbml) >> > >> > I get this error message: >> > >> > Error : .onLoad failed in loadNamespace() for 'rsbml', details: >> > ?call: dyn.load(file, DLLpath = DLLpath, ...) >> > ?error: unable to load shared object >> '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rs bml/libs/x86_64/rsbml.so': >> > >> ?dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/lib rary/rsbml/libs/x86_64/rsbml.so, >> 6): Symbol not found: _ASTNode_addChild >> > ?Referenced from: >> /Library/Frameworks/R.framework/Versions/2.12/Resources/library/rsb ml/libs/x86_64/rsbml.so >> > ?Expected in: dynamic lookup >> > >> > Error: package/namespace load failed for 'rsbml' >> > >> > rsbml.so is where it is supposed to be: >> > >> > >> ?/Library/Frameworks/R.framework/Versions/2.12/Resources/library/rs bml/libs/x86_64: >> > ? ? -rwxr-xr-x ?1 pshannon ?admin ?95328 Oct 19 22:08 rsbml.so >> > >> > Any suggestions? ?Thanks. >> > >> > ?- Paul >> > >> > >> > >> > Hi Paul, >> > >> > rsbml requires that you install libsbml. rsbml does not do this for you. >> > >> > You can get libsbml from http://www.sbml.org. >> > >> > Dan >> > >> > >> > > sessionInfo () >> > R version 2.12.1 (2010-12-16) >> > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) >> > >> > locale: >> > [1] en_US.utf-8/en_US.utf-8/C/C/en_US.utf-8/en_US.utf-8 >> > >> > attached base packages: >> > [1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods ? base >> > >> > loaded via a namespace (and not attached): >> > [1] graph_1.29.2 tools_2.12.1 >> > _______________________________________________ >> > Bioconductor mailing list >> > Bioconductor at r-project.org >> > https://stat.ethz.ch/mailman/listinfo/bioconductor >> > Search the archives: >> http://news.gmane.org/gmane.science.biology.informatics.conductor >> > >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at r-project.org >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: >> http://news.gmane.org/gmane.science.biology.informatics.conductor >> > > ? ? ? ?[[alternative HTML version deleted]] > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor >
ADD REPLYlink written 8.8 years ago by Vincent J. Carey, Jr.6.3k
Answer: difficulty loading rsbml
0
gravatar for den.kazakiewicz
3.7 years ago by
den.kazakiewicz0 wrote:

If you will face the same problem on Linux (as I was) here the fix:

1) Find where is actually PKG_CONFIG_PATH with

echo $(pkg-config --variable pc_path pkg-config)${PKG_CONFIG_PATH:+:}${PKG_CONFIG_PATH}

Find the directory where many *.pc files are actually located

2) Compile libsbml locally (http://sbml.org/Software/libSBML/docs/python-api/libsbml-installation.html#unix-advanced) in your local directory using CMAKE_INSTALL_PREFIX

 

3) make a link to the file <directory SBMLinstalled>/lib/pkgconfig/libsbml.pc

4) put that link in the folder you found at step 1. Rename the link to libsbml.pc

 

 

 

ADD COMMENTlink modified 3.7 years ago • written 3.7 years ago by den.kazakiewicz0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 222 users visited in the last hour