Question: unable to install lumi package
0
gravatar for Juliet Hannah
8.1 years ago by
Juliet Hannah360
United States
Juliet Hannah360 wrote:
I am unable to install the lumi package. I have printed the output and errors below. Below that is my sessionInfo. Other bioconductor packages I use installed without any problems. Thanks for any help. > biocLite("lumi") BioC_mirror: 'http://www.bioconductor.org' Using R version 2.14, BiocInstaller version 1.1.34. Installing package(s) 'lumi' also installing the dependencies ?rgl?, ?ks?, ?hdrcde? trying URL 'http://cran.fhcrc.org/src/contrib/rgl_0.92.798.tar.gz' Content type 'application/x-gzip' length 1677772 bytes (1.6 Mb) opened URL ================================================== downloaded 1.6 Mb trying URL 'http://cran.fhcrc.org/src/contrib/ks_1.8.3.tar.gz' Content type 'application/x-gzip' length 283507 bytes (276 Kb) opened URL ================================================== downloaded 276 Kb trying URL 'http://cran.fhcrc.org/src/contrib/hdrcde_2.15.tar.gz' Content type 'application/x-gzip' length 45583 bytes (44 Kb) opened URL ================================================== downloaded 44 Kb trying URL 'http://www.bioconductor.org/packages/2.9/bioc/src/contrib/ lumi_2.5.7.tar.gz' Content type 'application/x-gzip' length 11386085 bytes (10.9 Mb) opened URL ================================================== downloaded 10.9 Mb * installing *source* package ?rgl? ... checking for gcc... gcc -std=gnu99 checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc -std=gnu99 accepts -g... yes checking for gcc -std=gnu99 option to accept ISO C89... none needed checking how to run the C preprocessor... gcc -std=gnu99 -E checking for gcc... (cached) gcc -std=gnu99 checking whether we are using the GNU C compiler... (cached) yes checking whether gcc -std=gnu99 accepts -g... (cached) yes checking for gcc -std=gnu99 option to accept ISO C89... (cached) none needed checking for libpng-config... yes configure: using libpng-config configure: using libpng dynamic linkage checking for X... libraries , headers checking GL/gl.h usability... yes checking GL/gl.h presence... yes checking for GL/gl.h... yes checking GL/glu.h usability... no checking GL/glu.h presence... no checking for GL/glu.h... no configure: error: missing required header GL/glu.h ERROR: configuration failed for package ?rgl? * removing ?/home/R-2.14.0/library/rgl? ERROR: dependency ?rgl? is not available for package ?ks? * removing ?l/home/R-2.14.0/library/ks? ERROR: dependency ?ks? is not available for package ?hdrcde? * removing ?/home/R-2.14.0/library/hdrcde? ERROR: dependency ?hdrcde? is not available for package ?lumi? * removing ?/home/R-2.14.0/library/lumi? The downloaded packages are in ?/tmp/Rtmpeyt6CI/downloaded_packages? Warning messages: 1: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package ?rgl? had non-zero exit status 2: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package ?ks? had non-zero exit status 3: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package ?hdrcde? had non-zero exit status 4: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package ?lumi? had non-zero exit status > sessionInfo() R version 2.14.0 (2011-10-31) Platform: x86_64-unknown-linux-gnu (64-bit) locale: [1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C [3] LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8 [5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8 [7] LC_PAPER=C LC_NAME=C [9] LC_ADDRESS=C LC_TELEPHONE=C [11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] affy_1.31.6 Biobase_2.13.12 BiocInstaller_1.1.34 loaded via a namespace (and not attached): [1] affyio_1.21.2 preprocessCore_1.15.0 tools_2.14.0 [4] zlibbioc_0.99.0
lumi biocinstaller • 1.4k views
ADD COMMENTlink modified 8.1 years ago by James W. MacDonald52k • written 8.1 years ago by Juliet Hannah360
Answer: unable to install lumi package
0
gravatar for Dan Tenenbaum
8.1 years ago by
Dan Tenenbaum8.2k
United States
Dan Tenenbaum8.2k wrote:
Hi, On Mon, Oct 31, 2011 at 1:12 PM, Juliet Hannah <juliet.hannah at="" gmail.com=""> wrote: > I am unable to install the lumi package. I have printed the output and > errors below. Below that is my sessionInfo. Other bioconductor > packages I use installed without any problems. Thanks for any help. > > >> biocLite("lumi") > > BioC_mirror: 'http://www.bioconductor.org' > Using R version 2.14, BiocInstaller version 1.1.34. > Installing package(s) 'lumi' > also installing the dependencies ?rgl?, ?ks?, ?hdrcde? > > trying URL 'http://cran.fhcrc.org/src/contrib/rgl_0.92.798.tar.gz' > Content type 'application/x-gzip' length 1677772 bytes (1.6 Mb) > opened URL > ================================================== > downloaded 1.6 Mb > > trying URL 'http://cran.fhcrc.org/src/contrib/ks_1.8.3.tar.gz' > Content type 'application/x-gzip' length 283507 bytes (276 Kb) > opened URL > ================================================== > downloaded 276 Kb > > trying URL 'http://cran.fhcrc.org/src/contrib/hdrcde_2.15.tar.gz' > Content type 'application/x-gzip' length 45583 bytes (44 Kb) > opened URL > ================================================== > downloaded 44 Kb > > trying URL 'http://www.bioconductor.org/packages/2.9/bioc/src/contri b/lumi_2.5.7.tar.gz' > Content type 'application/x-gzip' length 11386085 bytes (10.9 Mb) > opened URL > ================================================== > downloaded 10.9 Mb > > * installing *source* package ?rgl? ... > checking for gcc... gcc -std=gnu99 > checking for C compiler default output file name... a.out > checking whether the C compiler works... yes > checking whether we are cross compiling... no > checking for suffix of executables... > checking for suffix of object files... o > checking whether we are using the GNU C compiler... yes > checking whether gcc -std=gnu99 accepts -g... yes > checking for gcc -std=gnu99 option to accept ISO C89... none needed > checking how to run the C preprocessor... gcc -std=gnu99 -E > checking for gcc... (cached) gcc -std=gnu99 > checking whether we are using the GNU C compiler... (cached) yes > checking whether gcc -std=gnu99 accepts -g... (cached) yes > checking for gcc -std=gnu99 option to accept ISO C89... (cached) none needed > checking for libpng-config... yes > configure: using libpng-config > configure: using libpng dynamic linkage > checking for X... libraries , headers > checking GL/gl.h usability... yes > checking GL/gl.h presence... yes > checking for GL/gl.h... yes > checking GL/glu.h usability... no > checking GL/glu.h presence... no > checking for GL/glu.h... no > configure: error: missing required header GL/glu.h > ERROR: configuration failed for package ?rgl? > * removing ?/home/R-2.14.0/library/rgl? > ERROR: dependency ?rgl? is not available for package ?ks? > * removing ?l/home/R-2.14.0/library/ks? > ERROR: dependency ?ks? is not available for package ?hdrcde? > * removing ?/home/R-2.14.0/library/hdrcde? > ERROR: dependency ?hdrcde? is not available for package ?lumi? > * removing ?/home/R-2.14.0/library/lumi? > > The downloaded packages are in > ? ? ? ??/tmp/Rtmpeyt6CI/downloaded_packages? > Warning messages: > 1: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package ?rgl? had non-zero exit status > 2: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package ?ks? had non-zero exit status > 3: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package ?hdrcde? had non-zero exit status > 4: In install.packages(pkgs = pkgs, repos = repos, ...) : > ?installation of package ?lumi? had non-zero exit status > > >> sessionInfo() > R version 2.14.0 (2011-10-31) > Platform: x86_64-unknown-linux-gnu (64-bit) > > locale: > ?[1] LC_CTYPE=en_US.UTF-8 ? ? ? LC_NUMERIC=C > ?[3] LC_TIME=en_US.UTF-8 ? ? ? ?LC_COLLATE=en_US.UTF-8 > ?[5] LC_MONETARY=en_US.UTF-8 ? ?LC_MESSAGES=en_US.UTF-8 > ?[7] LC_PAPER=C ? ? ? ? ? ? ? ? LC_NAME=C > ?[9] LC_ADDRESS=C ? ? ? ? ? ? ? LC_TELEPHONE=C > [11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C > > attached base packages: > [1] stats ? ? graphics ?grDevices utils ? ? datasets ?methods ? base > > other attached packages: > [1] affy_1.31.6 ? ? ? ? ?Biobase_2.13.12 ? ? ?BiocInstaller_1.1.34 > > loaded via a namespace (and not attached): > [1] affyio_1.21.2 ? ? ? ? preprocessCore_1.15.0 tools_2.14.0 > [4] zlibbioc_0.99.0 > lumi depends on something that depends on the CRAN package rgl. rgl has some system dependencies, as you can see on its home page: http://cran.fhcrc.org/web/packages/rgl/index.html The README for rgl has instructions for configuring your system. Download the rgl source tarball (the "Package source" link on the page above), open the tarball and read the README file. Dan > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor >
ADD COMMENTlink written 8.1 years ago by Dan Tenenbaum8.2k
Answer: unable to install lumi package
0
gravatar for James W. MacDonald
8.1 years ago by
United States
James W. MacDonald52k wrote:
Hi Juliet, On 10/31/2011 4:12 PM, Juliet Hannah wrote: > I am unable to install the lumi package. I have printed the output and > errors below. Below that is my sessionInfo. Other bioconductor > packages I use installed without any problems. Thanks for any help. > > >> biocLite("lumi") > BioC_mirror: 'http://www.bioconductor.org' > Using R version 2.14, BiocInstaller version 1.1.34. > Installing package(s) 'lumi' > also installing the dependencies ?rgl?, ?ks?, ?hdrcde? > > trying URL 'http://cran.fhcrc.org/src/contrib/rgl_0.92.798.tar.gz' > Content type 'application/x-gzip' length 1677772 bytes (1.6 Mb) > opened URL > ================================================== > downloaded 1.6 Mb > > trying URL 'http://cran.fhcrc.org/src/contrib/ks_1.8.3.tar.gz' > Content type 'application/x-gzip' length 283507 bytes (276 Kb) > opened URL > ================================================== > downloaded 276 Kb > > trying URL 'http://cran.fhcrc.org/src/contrib/hdrcde_2.15.tar.gz' > Content type 'application/x-gzip' length 45583 bytes (44 Kb) > opened URL > ================================================== > downloaded 44 Kb > > trying URL 'http://www.bioconductor.org/packages/2.9/bioc/src/contri b/lumi_2.5.7.tar.gz' > Content type 'application/x-gzip' length 11386085 bytes (10.9 Mb) > opened URL > ================================================== > downloaded 10.9 Mb > > * installing *source* package ?rgl? ... > checking for gcc... gcc -std=gnu99 > checking for C compiler default output file name... a.out > checking whether the C compiler works... yes > checking whether we are cross compiling... no > checking for suffix of executables... > checking for suffix of object files... o > checking whether we are using the GNU C compiler... yes > checking whether gcc -std=gnu99 accepts -g... yes > checking for gcc -std=gnu99 option to accept ISO C89... none needed > checking how to run the C preprocessor... gcc -std=gnu99 -E > checking for gcc... (cached) gcc -std=gnu99 > checking whether we are using the GNU C compiler... (cached) yes > checking whether gcc -std=gnu99 accepts -g... (cached) yes > checking for gcc -std=gnu99 option to accept ISO C89... (cached) none needed > checking for libpng-config... yes > configure: using libpng-config > configure: using libpng dynamic linkage > checking for X... libraries , headers > checking GL/gl.h usability... yes > checking GL/gl.h presence... yes > checking for GL/gl.h... yes > checking GL/glu.h usability... no > checking GL/glu.h presence... no > checking for GL/glu.h... no > configure: error: missing required header GL/glu.h Looks like you are missing the GL headers. You want to install the mesa-libGLU-devel rpm, using yum or apt, depending on your distro (or have your sysadmin do it if you don't have root privileges). See for instance http://fedoraforum.org/forum/showthread.php?t=243265 Best, Jim > ERROR: configuration failed for package ?rgl? > * removing ?/home/R-2.14.0/library/rgl? > ERROR: dependency ?rgl? is not available for package ?ks? > * removing ?l/home/R-2.14.0/library/ks? > ERROR: dependency ?ks? is not available for package ?hdrcde? > * removing ?/home/R-2.14.0/library/hdrcde? > ERROR: dependency ?hdrcde? is not available for package ?lumi? > * removing ?/home/R-2.14.0/library/lumi? > > The downloaded packages are in > ?/tmp/Rtmpeyt6CI/downloaded_packages? > Warning messages: > 1: In install.packages(pkgs = pkgs, repos = repos, ...) : > installation of package ?rgl? had non-zero exit status > 2: In install.packages(pkgs = pkgs, repos = repos, ...) : > installation of package ?ks? had non-zero exit status > 3: In install.packages(pkgs = pkgs, repos = repos, ...) : > installation of package ?hdrcde? had non-zero exit status > 4: In install.packages(pkgs = pkgs, repos = repos, ...) : > installation of package ?lumi? had non-zero exit status > > >> sessionInfo() > R version 2.14.0 (2011-10-31) > Platform: x86_64-unknown-linux-gnu (64-bit) > > locale: > [1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C > [3] LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8 > [5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8 > [7] LC_PAPER=C LC_NAME=C > [9] LC_ADDRESS=C LC_TELEPHONE=C > [11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] affy_1.31.6 Biobase_2.13.12 BiocInstaller_1.1.34 > > loaded via a namespace (and not attached): > [1] affyio_1.21.2 preprocessCore_1.15.0 tools_2.14.0 > [4] zlibbioc_0.99.0 > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor -- James W. MacDonald, M.S. Biostatistician Douglas Lab University of Michigan Department of Human Genetics 5912 Buhl 1241 E. Catherine St. Ann Arbor MI 48109-5618 734-615-7826 ********************************************************** Electronic Mail is not secure, may not be read every day, and should not be used for urgent or sensitive issues
ADD COMMENTlink written 8.1 years ago by James W. MacDonald52k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 360 users visited in the last hour