topGO dependency: Rgrapphviz
2
0
Entering edit mode
@thompson-kevin-5310
Last seen 7.1 years ago
Hi, FYI, I have recently updated the topGO package and it now appears the Rgraphviz is a dependency, although not listed as so. I do have graphviz installed (2.28) installed on OS X am working on the configuration issue. If anyone has any suggestions I would greatly appreciate them. > library(topGO) > data(GOdata) > showSigOfNodes(GOdata) Loading required package: Rgraphviz Error : .onLoad failed in loadNamespace() for 'Rgraphviz', details: call: value[[3L]](cond) error: unable to load shared object '/Library/Frameworks/R.framework /Versions/2.15/Resources/library/Rgraphviz/libs/x86_64/Rgraphviz.so': dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libra ry/Rgraphviz/libs/x86_64/Rgraphviz.so, 6): Library not loaded: /usr/local/lib/libgvc.5.dylib Referenced from: /Library/Frameworks/R.framework/Versions/2.15/Resou rces/library/Rgraphviz/libs/x86_64/Rgraphviz.so Reason: image not found Check that (1) graphviz is installed on your system; (2) the installed version of graphviz matches '2.26.3'; this is the version used to build this Rgraphviz package; (3) graphviz is accessible to R, e.g., the path to the graphviz 'bin' directory is in the system 'PATH' variable. See additional instructions in the 'README' file of the Rgraphviz 'source' distribution, available at http://bioconductor.org/packages/release/bioc/html/Rgraphviz.html Ask further questions on the Bioconductor mailing list http://bioconductor.org/docs/mailList.html Error in showSigOfNodes(GOdata) : package Rgraphviz is required > sessionInfo() R version 2.15.0 (2012-03-30) Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) locale: [1] C attached base packages: [1] grid stats graphics grDevices utils datasets methods [8] base other attached packages: [1] topGO_2.8.0 SparseM_0.96 GO.db_2.7.1 [4] RSQLite_0.11.1 DBI_0.2-5 AnnotationDbi_1.18.1 [7] Biobase_2.16.0 BiocGenerics_0.2.0 graph_1.34.0 loaded via a namespace (and not attached): [1] IRanges_1.14.3 lattice_0.20-6 stats4_2.15.0 tools_2.15.0 Thanks, Kevin
GO Rgraphviz topGO GO Rgraphviz topGO • 949 views
ADD COMMENT
0
Entering edit mode
Dan Tenenbaum ★ 8.2k
@dan-tenenbaum-4256
Last seen 7 months ago
United States
Hi Kevin, On Wed, May 30, 2012 at 10:17 AM, Thompson, Kevin <kthom110 at="" uncc.edu=""> wrote: > Hi, > > ? FYI, I have recently updated the topGO package and it now appears the Rgraphviz is a dependency, although not listed as so. ? ?I do have graphviz installed (2.28) installed on OS X am working on the configuration issue. ?If anyone has any suggestions I would greatly appreciate them. > >> library(topGO) >> data(GOdata) >> showSigOfNodes(GOdata) > > Loading required package: Rgraphviz > Error : .onLoad failed in loadNamespace() for 'Rgraphviz', details: > ?call: value[[3L]](cond) > ?error: unable to load shared object '/Library/Frameworks/R.framewor k/Versions/2.15/Resources/library/Rgraphviz/libs/x86_64/Rgraphviz.so': > ?dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libr ary/Rgraphviz/libs/x86_64/Rgraphviz.so, 6): Library not loaded: /usr/local/lib/libgvc.5.dylib > ?Referenced from: /Library/Frameworks/R.framework/Versions/2.15/Reso urces/library/Rgraphviz/libs/x86_64/Rgraphviz.so > ?Reason: image not found > > ?Check that (1) graphviz is installed on your system; (2) the > ?installed version of graphviz matches '2.26.3'; this is the version > ?used to build this Rgraphviz package; This is likely the problem right here. Rgraphviz can be particular about the version of graphviz that you use. It works on my system with 2.26.3, which you can get here: http://www.graphviz.org/pub/graphviz/stable/macos/snowleopard/graphviz -2.26.3.pkg (Don't worry about the 'snowleopard' in the directory name; this version will work on Leopard or Lion as well). > (3) graphviz is accessible to > ?R, e.g., the path to the graphviz 'bin' directory is in the system > ?'PATH' variable. ?See additional instructions in the 'README' file of > ?the Rgraphviz 'source' distribution, available at > You should doublecheck that graphviz is indeed in your path; maybe all that's necessary is to add it. Try this command in a terminal window: which neato If it returns something, then graphviz is in your path, otherwise it's not. Dan > ?http://bioconductor.org/packages/release/bioc/html/Rgraphviz.html > > ?Ask further questions on the Bioconductor mailing list > > ?http://bioconductor.org/docs/mailList.html > > > Error in showSigOfNodes(GOdata) : package Rgraphviz is required > > >> sessionInfo() > R version 2.15.0 (2012-03-30) > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > locale: > [1] C > > attached base packages: > [1] grid ? ? ?stats ? ? graphics ?grDevices utils ? ? datasets ?methods > [8] base > > other attached packages: > [1] topGO_2.8.0 ? ? ? ? ?SparseM_0.96 ? ? ? ? GO.db_2.7.1 > [4] RSQLite_0.11.1 ? ? ? DBI_0.2-5 ? ? ? ? ? ?AnnotationDbi_1.18.1 > [7] Biobase_2.16.0 ? ? ? BiocGenerics_0.2.0 ? graph_1.34.0 > > loaded via a namespace (and not attached): > [1] IRanges_1.14.3 lattice_0.20-6 stats4_2.15.0 ?tools_2.15.0 > > > Thanks, > Kevin > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT
0
Entering edit mode
Hi, I do have Rgraphviz installed and working now with graphviz 2.28 (sudo port install graphviz). dot -V -> dot - graphviz version 2.28.0 (20120530.1810) I was mainly trying to let the developers know that the dependency (Rgraphviz) is lot listed, nor does it initially load with the topGO library: > library(topGO) Loading required package: graph Loading required package: Biobase Loading required package: BiocGenerics ... Attaching package: 'BiocGenerics' ... Loading required package: GO.db Loading required package: AnnotationDbi Loading required package: DBI Previously it appears that the graph library was sufficient to produce the topGO graphics (showSigOfNodes), as Rgraphviz was not required. Thanks, Kevin ________________________________________ From: Dan Tenenbaum [dtenenba@fhcrc.org] Sent: Thursday, May 31, 2012 12:15 PM To: Thompson, Kevin Cc: bioconductor at r-project.org Subject: Re: [BioC] topGO dependency: Rgrapphviz Hi Kevin, On Wed, May 30, 2012 at 10:17 AM, Thompson, Kevin <kthom110 at="" uncc.edu=""> wrote: > Hi, > > FYI, I have recently updated the topGO package and it now appears the Rgraphviz is a dependency, although not listed as so. I do have graphviz installed (2.28) installed on OS X am working on the configuration issue. If anyone has any suggestions I would greatly appreciate them. > >> library(topGO) >> data(GOdata) >> showSigOfNodes(GOdata) > > Loading required package: Rgraphviz > Error : .onLoad failed in loadNamespace() for 'Rgraphviz', details: > call: value[[3L]](cond) > error: unable to load shared object '/Library/Frameworks/R.framewor k/Versions/2.15/Resources/library/Rgraphviz/libs/x86_64/Rgraphviz.so': > dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libr ary/Rgraphviz/libs/x86_64/Rgraphviz.so, 6): Library not loaded: /usr/local/lib/libgvc.5.dylib > Referenced from: /Library/Frameworks/R.framework/Versions/2.15/Reso urces/library/Rgraphviz/libs/x86_64/Rgraphviz.so > Reason: image not found > > Check that (1) graphviz is installed on your system; (2) the > installed version of graphviz matches '2.26.3'; this is the version > used to build this Rgraphviz package; This is likely the problem right here. Rgraphviz can be particular about the version of graphviz that you use. It works on my system with 2.26.3, which you can get here: http://www.graphviz.org/pub/graphviz/stable/macos/snowleopard/graphviz -2.26.3.pkg (Don't worry about the 'snowleopard' in the directory name; this version will work on Leopard or Lion as well). > (3) graphviz is accessible to > R, e.g., the path to the graphviz 'bin' directory is in the system > 'PATH' variable. See additional instructions in the 'README' file of > the Rgraphviz 'source' distribution, available at > You should doublecheck that graphviz is indeed in your path; maybe all that's necessary is to add it. Try this command in a terminal window: which neato If it returns something, then graphviz is in your path, otherwise it's not. Dan > http://bioconductor.org/packages/release/bioc/html/Rgraphviz.html > > Ask further questions on the Bioconductor mailing list > > http://bioconductor.org/docs/mailList.html > > > Error in showSigOfNodes(GOdata) : package Rgraphviz is required > > >> sessionInfo() > R version 2.15.0 (2012-03-30) > Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) > > locale: > [1] C > > attached base packages: > [1] grid stats graphics grDevices utils datasets methods > [8] base > > other attached packages: > [1] topGO_2.8.0 SparseM_0.96 GO.db_2.7.1 > [4] RSQLite_0.11.1 DBI_0.2-5 AnnotationDbi_1.18.1 > [7] Biobase_2.16.0 BiocGenerics_0.2.0 graph_1.34.0 > > loaded via a namespace (and not attached): > [1] IRanges_1.14.3 lattice_0.20-6 stats4_2.15.0 tools_2.15.0 > > > Thanks, > Kevin > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD REPLY
0
Entering edit mode
Dan Tenenbaum ★ 8.2k
@dan-tenenbaum-4256
Last seen 7 months ago
United States
On Thu, May 31, 2012 at 10:00 AM, Thompson, Kevin <kthom110 at="" uncc.edu=""> wrote: > Hi, > > ? I do have Rgraphviz installed and working now with graphviz 2.28 (sudo port install graphviz). > ? ? ? ? ? ?dot -V ? -> ?dot - graphviz version 2.28.0 (20120530.1810) > > ? I was mainly trying to let the developers know that the dependency (Rgraphviz) is lot listed, nor does it initially load with the topGO library: Thanks. I will contact the topGO maintainer and try to clarify the situation. Rgraphviz is listed in the Suggests field, but that doesn't cause it to be loaded automatically (as you point out). Dan > >> library(topGO) > Loading required package: graph > Loading required package: Biobase > Loading required package: BiocGenerics > ? ? ? ? ? ? ... > Attaching package: 'BiocGenerics' > ? ? ? ? ? ? ... > Loading required package: GO.db > Loading required package: AnnotationDbi > Loading required package: DBI > > > ? ?Previously it appears that the graph library was sufficient to produce the topGO graphics (showSigOfNodes), as Rgraphviz was not required. > > Thanks, > Kevin > > ________________________________________ > From: Dan Tenenbaum [dtenenba at fhcrc.org] > Sent: Thursday, May 31, 2012 12:15 PM > To: Thompson, Kevin > Cc: bioconductor at r-project.org > Subject: Re: [BioC] topGO dependency: Rgrapphviz > > Hi Kevin, > > On Wed, May 30, 2012 at 10:17 AM, Thompson, Kevin <kthom110 at="" uncc.edu=""> wrote: >> Hi, >> >> ? FYI, I have recently updated the topGO package and it now appears the Rgraphviz is a dependency, although not listed as so. ? ?I do have graphviz installed (2.28) installed on OS X am working on the configuration issue. ?If anyone has any suggestions I would greatly appreciate them. >> >>> library(topGO) >>> data(GOdata) >>> showSigOfNodes(GOdata) >> >> Loading required package: Rgraphviz >> Error : .onLoad failed in loadNamespace() for 'Rgraphviz', details: >> ?call: value[[3L]](cond) >> ?error: unable to load shared object '/Library/Frameworks/R.framewo rk/Versions/2.15/Resources/library/Rgraphviz/libs/x86_64/Rgraphviz.so' : >> ?dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/lib rary/Rgraphviz/libs/x86_64/Rgraphviz.so, 6): Library not loaded: /usr/local/lib/libgvc.5.dylib >> ?Referenced from: /Library/Frameworks/R.framework/Versions/2.15/Res ources/library/Rgraphviz/libs/x86_64/Rgraphviz.so >> ?Reason: image not found >> >> ?Check that (1) graphviz is installed on your system; (2) the >> ?installed version of graphviz matches '2.26.3'; this is the version >> ?used to build this Rgraphviz package; > > This is likely the problem right here. Rgraphviz can be particular > about the version of graphviz that you use. > It works on my system with 2.26.3, which you can get here: > > http://www.graphviz.org/pub/graphviz/stable/macos/snowleopard/graphv iz-2.26.3.pkg > > (Don't worry about the 'snowleopard' in the directory name; this > version will work on Leopard or Lion as well). > > > > >> (3) graphviz is accessible to >> ?R, e.g., the path to the graphviz 'bin' directory is in the system >> ?'PATH' variable. ?See additional instructions in the 'README' file of >> ?the Rgraphviz 'source' distribution, available at >> > > > You should doublecheck that graphviz is indeed in your path; maybe all > that's necessary is to add it. > Try this command in a terminal window: > > which neato > > If it returns something, then graphviz is in your path, otherwise it's not. > > Dan > >> ?http://bioconductor.org/packages/release/bioc/html/Rgraphviz.html >> >> ?Ask further questions on the Bioconductor mailing list >> >> ?http://bioconductor.org/docs/mailList.html >> >> >> Error in showSigOfNodes(GOdata) : package Rgraphviz is required >> >> >>> sessionInfo() >> R version 2.15.0 (2012-03-30) >> Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit) >> >> locale: >> [1] C >> >> attached base packages: >> [1] grid ? ? ?stats ? ? graphics ?grDevices utils ? ? datasets ?methods >> [8] base >> >> other attached packages: >> [1] topGO_2.8.0 ? ? ? ? ?SparseM_0.96 ? ? ? ? GO.db_2.7.1 >> [4] RSQLite_0.11.1 ? ? ? DBI_0.2-5 ? ? ? ? ? ?AnnotationDbi_1.18.1 >> [7] Biobase_2.16.0 ? ? ? BiocGenerics_0.2.0 ? graph_1.34.0 >> >> loaded via a namespace (and not attached): >> [1] IRanges_1.14.3 lattice_0.20-6 stats4_2.15.0 ?tools_2.15.0 >> >> >> Thanks, >> Kevin >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at r-project.org >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT

Login before adding your answer.

Traffic: 489 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6