Question: Problems installing EBImage - Symbol not found: _gdk_display
0
gravatar for Dan Tenenbaum
7.1 years ago by
Dan Tenenbaum8.2k
United States
Dan Tenenbaum8.2k wrote:
On Fri, Aug 17, 2012 at 9:21 AM, Olin Silander <olinsilander at="" gmail.com=""> wrote: > Thanks for the suggestion. Unfortunately this doesn't seem to work either - I get the same error that I did previously: Is Magick-config in your PATH? I also wonder if this could be a locale issue. Can you send your sessionInfo()? I am able to install EBImage from source using biocLite(). Maybe because /opt/local/bin is in my path? Dan > > biocLite("EBImage", type="source") > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Installing package(s) 'EBImage' > trying URL 'http://www.bioconductor.org/packages/2.10/bioc/src/contr ib/EBImage_3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... no > configure: error: "ImageMagick or ImageMagick includes not found!" > ERROR: configuration failed for package 'EBImage' > * removing '/Library/Frameworks/R.framework/Versions/2.15/Resources/ library/EBImage' > > The downloaded source packages are in > '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/Rt mpEwsd5x/downloaded_packages' > Warning: unable to access index for repository http://brainarray.mbn i.med.umich.edu/bioc/bin/macosx/leopard/contrib/2.15 > Warning message: > In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : > installation of package 'EBImage' had non-zero exit status > > > This seems very strange, as when I try to install from terminal, the ImageMagick check seems fine (as does the suggested check in the vignette): > > R CMD INSTALL EBImage > * installing to library ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? > * installing *source* package ?EBImage? ... > checking for Magick-config... yes > * found ImageMagick version 6.7.8 Q16 > * found ImageMagick includes in -I/opt/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > > Cheers, > Olin > > > On Aug 17, 2012, at 6:15 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: > >> On Fri, Aug 17, 2012 at 2:22 AM, Olin Silander <olinsilander at="" gmail.com=""> wrote: >>> I am having problems installing EBImage. I am running R 2.15.1 on OSX Mountain Lion and have X11 open using with Xquartz 2.7.2 >> >> The EBImage installation vignette, warns against installing the Mac >> binary package, and in fact there isn't one on Bioconductor. >> >> The recommended way to install it is: >> source("http://bioconductor.org/biocLite.R") >> biocLite("EBImage", type="source") >> >> Let us know if that works for you. >> Dan >> >> >>> >>> The output when I try to install EBImage: >>> >>> osilander$ R CMD INSTALL EBImage >>> * installing to library ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? >>> * installing *source* package ?EBImage? ... >>> checking for Magick-config... yes >>> * found ImageMagick version 6.7.8 Q16 >>> * found ImageMagick includes in -I/opt/local/include/ImageMagick >>> checking for pkg-config... yes >>> * compiling with GTK+ support >>> ----------------------------------------------------- >>> configure: creating ./config.status >>> config.status: creating src/Makevars >>> ** libs >>> *** arch - i386 >>> make: Nothing to be done for `all'. >>> installing to /Library/Frameworks/R.framework/Versions/2.15/Resour ces/library/EBImage/libs/i386 >>> ** R >>> ** inst >>> ** preparing package for lazy loading >>> ** help >>> *** installing help indices >>> ** building package indices >>> ** installing vignettes >>> ?EBImage-installation.Rnw? >>> ?EBImage-introduction.Rnw? >>> ** testing if installed package can be loaded >>> Error in dyn.load(file, DLLpath = DLLpath, ...) : >>> unable to load shared object '/Library/Frameworks/R.framework/Ver sions/2.15/Resources/library/EBImage/libs/i386/EBImage.so': >>> dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/li brary/EBImage/libs/i386/EBImage.so, 6): Symbol not found: _gdk_display >>> Referenced from: /Library/Frameworks/R.framework/Versions/2.15/Re sources/library/EBImage/libs/i386/EBImage.so >>> Expected in: flat namespace >>> in /Library/Frameworks/R.framework/Versions/2.15/Resources/library /EBImage/libs/i386/EBImage.so >>> Error: loading failed >>> Execution halted >>> ERROR: loading failed >>> * removing ?/Library/Frameworks/R.framework/Versions/2.15/Resource s/library/EBImage? >>> >>> I also tried installing from within the R GUI, and get the following errors: >>> >>> biocLite("EBImage") >>> BioC_mirror: http://bioconductor.org >>> Using R version 2.15, BiocInstaller version 1.4.7. >>> Warning: unable to access index for repository http://brainarray.m bni.med.umich.edu/bioc/bin/macosx/leopard/contrib/2.15 >>> Installing package(s) 'EBImage' >>> Warning: unable to access index for repository http://brainarray.m bni.med.umich.edu/bioc/bin/macosx/leopard/contrib/2.15 >>> Warning: unable to access index for repository http://brainarray.m bni.med.umich.edu/bioc/bin/macosx/leopard/contrib/2.15 >>> Warning message: >>> package 'EBImage' is not available (for R version 2.15.1) >>> >>> Finally, I tried using the R Package Installer, and get a different error: >>> >>> trying URL 'http://www.bioconductor.org/packages/2.10/bioc/src/con trib/EBImage_3.12.0.tar.gz' >>> Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) >>> opened URL >>> ================================================== >>> downloaded 4.5 Mb >>> >>> During startup - Warning messages: >>> 1: Setting LC_CTYPE failed, using "C" >>> 2: Setting LC_TIME failed, using "C" >>> 3: Setting LC_MESSAGES failed, using "C" >>> 4: Setting LC_PAPER failed, using "C" >>> * installing *source* package 'EBImage' ... >>> checking for Magick-config... no >>> configure: error: "ImageMagick or ImageMagick includes not found!" >>> ERROR: configuration failed for package 'EBImage' >>> * removing '/Library/Frameworks/R.framework/Versions/2.15/Resource s/library/EBImage' >>> >>> The downloaded source packages are in >>> '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/R tmpT9XfJ2/downloaded_packages' >>> >>> >>> I also tried using 'chooseBioCmirror()' to change my mirror to Seattle. >>> >>> The checks for gtk and ImageMagick seem okay except for a single warning: >>> >>> pz-mlm06020-02:Downloads osilander$ gtk-demo >>> (process:1307): Gtk-WARNING **: Locale not supported by C library. >>> Using the fallback 'C' locale. >>> >>> >>> osilander$ pkg-config gtk+-2.0 --libs >>> >>> -L/opt/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lintl >>> >>> >>> osilander$ convert -version >>> >>> Version: ImageMagick 6.7.8-3 2012-08-15 Q16 http://www.imagemagick.org >>> Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC >>> Features: OpenCL >>> >>> >>> osilander$ Magick-config --libs >>> >>> -L/opt/local/lib -lMagickCore >>> >>> Thanks in advance, >>> Olin >>> >>> ---------------------------------------- >>> Olin Silander >>> Computational and Systems Biology >>> Biozentrum, University of Basel >>> Klingelbergstr. 50/70 >>> CH-4056 Basel >>> Switzerland >>> 061 267 1621 >>> olinsilander at gmail.com >>> >>> _______________________________________________ >>> Bioconductor mailing list >>> Bioconductor at r-project.org >>> https://stat.ethz.ch/mailman/listinfo/bioconductor >>> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > >
ADD COMMENTlink modified 7.1 years ago • written 7.1 years ago by Dan Tenenbaum8.2k
Answer: Problems installing EBImage - Symbol not found: _gdk_display
0
gravatar for Dan Tenenbaum
7.1 years ago by
Dan Tenenbaum8.2k
United States
Dan Tenenbaum8.2k wrote:
On Fri, Aug 17, 2012 at 9:41 AM, Olin Silander <olinsilander at="" gmail.com=""> wrote: > Magick-config seems to be in my PATH: > > osilander$ which Magick-config > /opt/local/bin/Magick-config > > as does opt/local/bin: > > osilander$ echo $PATH > /opt/local/bin:/opt/local/sbin:/usr/local/bin//bin:/usr/bin:/bin:/us r/sbin:/sbin:/usr/local/bin:/opt/X11/bin: > > my sessionInfo (all of it) - I do have consistent locale issues but I have > ignored these mostly, maybe that is the problem: OK, forgetting about sessionInfo() and biocLite() for the moment, it seems like you get farther when you use R CMD INSTALL. But it seems like 'make' decided there was nothing to do, so maybe there were remnants of a previous incomplete build. So I suggest using either R CMD INSTALL --preclean or running R CMD INSTALL against a tarball, not a directory. Dan >> sessionInfo() > R version 2.15.1 (2012-06-22) > Platform: i386-apple-darwin9.8.0/i386 (32-bit) > > locale: > [1] C > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] BiocInstaller_1.4.7 > > loaded via a namespace (and not attached): > [1] tools_2.15.1 > > And the messages when I start R: > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_COLLATE failed, using "C" > 3: Setting LC_TIME failed, using "C" > 4: Setting LC_MESSAGES failed, using "C" > 5: Setting LC_PAPER failed, using "C" > [R.app GUI 1.52 (6188) i386-apple-darwin9.8.0] > > WARNING: You're using a non-UTF8 locale, therefore only ASCII characters > will work. > Please read R for Mac OS X FAQ (see Help) section 9 and adjust your system > preferences accordingly. > [History restored from /Users/osilander/.Rhistory] > >> source("http://bioconductor.org/biocLite.R") > BiocInstaller version 1.4.7, ?biocLite for help >> biocLite("EBImage", type="source") > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Installing package(s) 'EBImage' > trying URL > 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage_ 3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... no > configure: error: "ImageMagick or ImageMagick includes not found!" > ERROR: configuration failed for package 'EBImage' > * removing > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage' > > The downloaded source packages are in > '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpKkCErx /downloaded_packages' > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning message: > In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : > installation of package 'EBImage' had non-zero exit status > > > On Aug 17, 2012, at 6:31 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: > > On Fri, Aug 17, 2012 at 9:21 AM, Olin Silander <olinsilander at="" gmail.com=""> > wrote: > > Thanks for the suggestion. Unfortunately this doesn't seem to work either - > I get the same error that I did previously: > > > Is Magick-config in your PATH? > > I also wonder if this could be a locale issue. Can you send your > sessionInfo()? > > I am able to install EBImage from source using biocLite(). Maybe > because /opt/local/bin is in my path? > Dan > > > > > > > biocLite("EBImage", type="source") > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Installing package(s) 'EBImage' > trying URL > 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage_ 3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... no > configure: error: "ImageMagick or ImageMagick includes not found!" > ERROR: configuration failed for package 'EBImage' > * removing > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage' > > The downloaded source packages are in > > '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpEwsd5x /downloaded_packages' > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning message: > In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : > installation of package 'EBImage' had non-zero exit status > > > This seems very strange, as when I try to install from terminal, the > ImageMagick check seems fine (as does the suggested check in the vignette): > > R CMD INSTALL EBImage > * installing to library > ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? > * installing *source* package ?EBImage? ... > checking for Magick-config... yes > * found ImageMagick version 6.7.8 Q16 > * found ImageMagick includes in -I/opt/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > > Cheers, > Olin > > > On Aug 17, 2012, at 6:15 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: > > On Fri, Aug 17, 2012 at 2:22 AM, Olin Silander <olinsilander at="" gmail.com=""> > wrote: > > I am having problems installing EBImage. I am running R 2.15.1 on OSX > Mountain Lion and have X11 open using with Xquartz 2.7.2 > > > The EBImage installation vignette, warns against installing the Mac > binary package, and in fact there isn't one on Bioconductor. > > The recommended way to install it is: > source("http://bioconductor.org/biocLite.R") > biocLite("EBImage", type="source") > > Let us know if that works for you. > Dan > > > > The output when I try to install EBImage: > > osilander$ R CMD INSTALL EBImage > * installing to library > ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? > * installing *source* package ?EBImage? ... > checking for Magick-config... yes > * found ImageMagick version 6.7.8 Q16 > * found ImageMagick includes in -I/opt/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > ----------------------------------------------------- > configure: creating ./config.status > config.status: creating src/Makevars > ** libs > *** arch - i386 > make: Nothing to be done for `all'. > installing to > /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBIm age/libs/i386 > ** R > ** inst > ** preparing package for lazy loading > ** help > *** installing help indices > ** building package indices > ** installing vignettes > ?EBImage-installation.Rnw? > ?EBImage-introduction.Rnw? > ** testing if installed package can be loaded > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared object > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386/EBImage.so': > dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libra ry/EBImage/libs/i386/EBImage.so, > 6): Symbol not found: _gdk_display > Referenced from: > /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBIm age/libs/i386/EBImage.so > Expected in: flat namespace > in > /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBIm age/libs/i386/EBImage.so > Error: loading failed > Execution halted > ERROR: loading failed > * removing > ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage? > > I also tried installing from within the R GUI, and get the following errors: > > biocLite("EBImage") > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Installing package(s) 'EBImage' > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning message: > package 'EBImage' is not available (for R version 2.15.1) > > Finally, I tried using the R Package Installer, and get a different error: > > trying URL > 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage_ 3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... no > configure: error: "ImageMagick or ImageMagick includes not found!" > ERROR: configuration failed for package 'EBImage' > * removing > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage' > > The downloaded source packages are in > > '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpT9XfJ2 /downloaded_packages' > > > I also tried using 'chooseBioCmirror()' to change my mirror to Seattle. > > The checks for gtk and ImageMagick seem okay except for a single warning: > > pz-mlm06020-02:Downloads osilander$ gtk-demo > (process:1307): Gtk-WARNING **: Locale not supported by C library. > Using the fallback 'C' locale. > > > osilander$ pkg-config gtk+-2.0 --libs > > -L/opt/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 > -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage > -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 > -lm -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lintl > > > osilander$ convert -version > > Version: ImageMagick 6.7.8-3 2012-08-15 Q16 http://www.imagemagick.org > Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC > Features: OpenCL > > > osilander$ Magick-config --libs > > -L/opt/local/lib -lMagickCore > > Thanks in advance, > Olin > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > > > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > >
ADD COMMENTlink written 7.1 years ago by Dan Tenenbaum8.2k
I tried: R CMD INSTALL --preclean EBImage R CMD INSTALL --preclean EBImage_4.0.1.tar.gz R CMD INSTALL EBImage_4.0.1.tar.gz but all failed again with the same error: installing to /Library/Frameworks/R.framework/Versions/2.15/Resources/ library/EBImage/libs/i386 ** R ** inst ** preparing package for lazy loading ** help *** installing help indices ** building package indices ** installing vignettes ?EBImage-installation.Rnw? ?EBImage-introduction.Rnw? ** testing if installed package can be loaded Error in dyn.load(file, DLLpath = DLLpath, ...) : unable to load shared object '/Library/Frameworks/R.framework/Versio ns/2.15/Resources/library/EBImage/libs/i386/EBImage.so': dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libra ry/EBImage/libs/i386/EBImage.so, 6): Symbol not found: _gdk_display Referenced from: /Library/Frameworks/R.framework/Versions/2.15/Resou rces/library/EBImage/libs/i386/EBImage.so Expected in: flat namespace in /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image/libs/i386/EBImage.so Error: loading failed Execution halted ERROR: loading failed * removing ?/Library/Frameworks/R.framework/Versions/2.15/Resources/li brary/EBImage? I did see some warnings for ImageMagick which I did not see previously or which were not there previously: conversions.c: In function ?magick2SEXP?: conversions.c:135: warning: ?DispatchImage? is deprecated (declared at /opt/local/include/ImageMagick/magick/deprecate.h:280) conversions.c:137: warning: ?DispatchImage? is deprecated (declared at /opt/local/include/ImageMagick/magick/deprecate.h:280) conversions.c:139: warning: ?DispatchImage? is deprecated (declared at /opt/local/include/ImageMagick/magick/deprecate.h:280) conversions.c:144: warning: ?DispatchImage? is deprecated (declared at /opt/local/include/ImageMagick/magick/deprecate.h:280) tile.c: In function ?untile?: tile.c:130: warning: unused variable ?id? and a long series (about 25) of warnings along the following lines: ld: warning: ld: warning: ld: warning: ld: warning: ignoring file /opt/local/lib/libpangocairo-1.0.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /opt/local/lib/libpangocairo-1.0.dylibignoring file /opt/local/lib/libgtk-x11-2.0.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): -Olin On Aug 17, 2012, at 9:16 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: > On Fri, Aug 17, 2012 at 9:41 AM, Olin Silander <olinsilander at="" gmail.com=""> wrote: >> Magick-config seems to be in my PATH: >> >> osilander$ which Magick-config >> /opt/local/bin/Magick-config >> >> as does opt/local/bin: >> >> osilander$ echo $PATH >> /opt/local/bin:/opt/local/sbin:/usr/local/bin//bin:/usr/bin:/bin:/u sr/sbin:/sbin:/usr/local/bin:/opt/X11/bin: >> >> my sessionInfo (all of it) - I do have consistent locale issues but I have >> ignored these mostly, maybe that is the problem: > > > OK, forgetting about sessionInfo() and biocLite() for the moment, it > seems like you get farther when you use R CMD INSTALL. > But it seems like 'make' decided there was nothing to do, so maybe > there were remnants of a previous incomplete build. So I suggest > using either > R CMD INSTALL --preclean > or running > R CMD INSTALL against a tarball, not a directory. > Dan > > >>> sessionInfo() >> R version 2.15.1 (2012-06-22) >> Platform: i386-apple-darwin9.8.0/i386 (32-bit) >> >> locale: >> [1] C >> >> attached base packages: >> [1] stats graphics grDevices utils datasets methods base >> >> other attached packages: >> [1] BiocInstaller_1.4.7 >> >> loaded via a namespace (and not attached): >> [1] tools_2.15.1 >> >> And the messages when I start R: >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_COLLATE failed, using "C" >> 3: Setting LC_TIME failed, using "C" >> 4: Setting LC_MESSAGES failed, using "C" >> 5: Setting LC_PAPER failed, using "C" >> [R.app GUI 1.52 (6188) i386-apple-darwin9.8.0] >> >> WARNING: You're using a non-UTF8 locale, therefore only ASCII characters >> will work. >> Please read R for Mac OS X FAQ (see Help) section 9 and adjust your system >> preferences accordingly. >> [History restored from /Users/osilander/.Rhistory] >> >>> source("http://bioconductor.org/biocLite.R") >> BiocInstaller version 1.4.7, ?biocLite for help >>> biocLite("EBImage", type="source") >> BioC_mirror: http://bioconductor.org >> Using R version 2.15, BiocInstaller version 1.4.7. >> Installing package(s) 'EBImage' >> trying URL >> 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage _3.12.0.tar.gz' >> Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) >> opened URL >> ================================================== >> downloaded 4.5 Mb >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_TIME failed, using "C" >> 3: Setting LC_MESSAGES failed, using "C" >> 4: Setting LC_PAPER failed, using "C" >> * installing *source* package 'EBImage' ... >> checking for Magick-config... no >> configure: error: "ImageMagick or ImageMagick includes not found!" >> ERROR: configuration failed for package 'EBImage' >> * removing >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image' >> >> The downloaded source packages are in >> '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpKkCEr x/downloaded_packages' >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning message: >> In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : >> installation of package 'EBImage' had non-zero exit status >> >> >> On Aug 17, 2012, at 6:31 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: >> >> On Fri, Aug 17, 2012 at 9:21 AM, Olin Silander <olinsilander at="" gmail.com=""> >> wrote: >> >> Thanks for the suggestion. Unfortunately this doesn't seem to work either - >> I get the same error that I did previously: >> >> >> Is Magick-config in your PATH? >> >> I also wonder if this could be a locale issue. Can you send your >> sessionInfo()? >> >> I am able to install EBImage from source using biocLite(). Maybe >> because /opt/local/bin is in my path? >> Dan >> >> >> >> >> >> >> biocLite("EBImage", type="source") >> BioC_mirror: http://bioconductor.org >> Using R version 2.15, BiocInstaller version 1.4.7. >> Installing package(s) 'EBImage' >> trying URL >> 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage _3.12.0.tar.gz' >> Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) >> opened URL >> ================================================== >> downloaded 4.5 Mb >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_TIME failed, using "C" >> 3: Setting LC_MESSAGES failed, using "C" >> 4: Setting LC_PAPER failed, using "C" >> * installing *source* package 'EBImage' ... >> checking for Magick-config... no >> configure: error: "ImageMagick or ImageMagick includes not found!" >> ERROR: configuration failed for package 'EBImage' >> * removing >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image' >> >> The downloaded source packages are in >> >> '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpEwsd5 x/downloaded_packages' >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning message: >> In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : >> installation of package 'EBImage' had non-zero exit status >> >> >> This seems very strange, as when I try to install from terminal, the >> ImageMagick check seems fine (as does the suggested check in the vignette): >> >> R CMD INSTALL EBImage >> * installing to library >> ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? >> * installing *source* package ?EBImage? ... >> checking for Magick-config... yes >> * found ImageMagick version 6.7.8 Q16 >> * found ImageMagick includes in -I/opt/local/include/ImageMagick >> checking for pkg-config... yes >> * compiling with GTK+ support >> >> Cheers, >> Olin >> >> >> On Aug 17, 2012, at 6:15 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: >> >> On Fri, Aug 17, 2012 at 2:22 AM, Olin Silander <olinsilander at="" gmail.com=""> >> wrote: >> >> I am having problems installing EBImage. I am running R 2.15.1 on OSX >> Mountain Lion and have X11 open using with Xquartz 2.7.2 >> >> >> The EBImage installation vignette, warns against installing the Mac >> binary package, and in fact there isn't one on Bioconductor. >> >> The recommended way to install it is: >> source("http://bioconductor.org/biocLite.R") >> biocLite("EBImage", type="source") >> >> Let us know if that works for you. >> Dan >> >> >> >> The output when I try to install EBImage: >> >> osilander$ R CMD INSTALL EBImage >> * installing to library >> ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? >> * installing *source* package ?EBImage? ... >> checking for Magick-config... yes >> * found ImageMagick version 6.7.8 Q16 >> * found ImageMagick includes in -I/opt/local/include/ImageMagick >> checking for pkg-config... yes >> * compiling with GTK+ support >> ----------------------------------------------------- >> configure: creating ./config.status >> config.status: creating src/Makevars >> ** libs >> *** arch - i386 >> make: Nothing to be done for `all'. >> installing to >> /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386 >> ** R >> ** inst >> ** preparing package for lazy loading >> ** help >> *** installing help indices >> ** building package indices >> ** installing vignettes >> ?EBImage-installation.Rnw? >> ?EBImage-introduction.Rnw? >> ** testing if installed package can be loaded >> Error in dyn.load(file, DLLpath = DLLpath, ...) : >> unable to load shared object >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image/libs/i386/EBImage.so': >> dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libr ary/EBImage/libs/i386/EBImage.so, >> 6): Symbol not found: _gdk_display >> Referenced from: >> /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386/EBImage.so >> Expected in: flat namespace >> in >> /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386/EBImage.so >> Error: loading failed >> Execution halted >> ERROR: loading failed >> * removing >> ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image? >> >> I also tried installing from within the R GUI, and get the following errors: >> >> biocLite("EBImage") >> BioC_mirror: http://bioconductor.org >> Using R version 2.15, BiocInstaller version 1.4.7. >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Installing package(s) 'EBImage' >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning message: >> package 'EBImage' is not available (for R version 2.15.1) >> >> Finally, I tried using the R Package Installer, and get a different error: >> >> trying URL >> 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage _3.12.0.tar.gz' >> Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) >> opened URL >> ================================================== >> downloaded 4.5 Mb >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_TIME failed, using "C" >> 3: Setting LC_MESSAGES failed, using "C" >> 4: Setting LC_PAPER failed, using "C" >> * installing *source* package 'EBImage' ... >> checking for Magick-config... no >> configure: error: "ImageMagick or ImageMagick includes not found!" >> ERROR: configuration failed for package 'EBImage' >> * removing >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image' >> >> The downloaded source packages are in >> >> '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpT9XfJ 2/downloaded_packages' >> >> >> I also tried using 'chooseBioCmirror()' to change my mirror to Seattle. >> >> The checks for gtk and ImageMagick seem okay except for a single warning: >> >> pz-mlm06020-02:Downloads osilander$ gtk-demo >> (process:1307): Gtk-WARNING **: Locale not supported by C library. >> Using the fallback 'C' locale. >> >> >> osilander$ pkg-config gtk+-2.0 --libs >> >> -L/opt/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 >> -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage >> -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 >> -lm -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lintl >> >> >> osilander$ convert -version >> >> Version: ImageMagick 6.7.8-3 2012-08-15 Q16 http://www.imagemagick.org >> Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC >> Features: OpenCL >> >> >> osilander$ Magick-config --libs >> >> -L/opt/local/lib -lMagickCore >> >> Thanks in advance, >> Olin >> >> ---------------------------------------- >> Olin Silander >> Computational and Systems Biology >> Biozentrum, University of Basel >> Klingelbergstr. 50/70 >> CH-4056 Basel >> Switzerland >> 061 267 1621 >> olinsilander at gmail.com >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor at r-project.org >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: >> http://news.gmane.org/gmane.science.biology.informatics.conductor >> >> >> ---------------------------------------- >> Olin Silander >> Computational and Systems Biology >> Biozentrum, University of Basel >> Klingelbergstr. 50/70 >> CH-4056 Basel >> Switzerland >> 061 267 1621 >> olinsilander at gmail.com >> >> >> >> >> ---------------------------------------- >> Olin Silander >> Computational and Systems Biology >> Biozentrum, University of Basel >> Klingelbergstr. 50/70 >> CH-4056 Basel >> Switzerland >> 061 267 1621 >> olinsilander at gmail.com >> >> >> ---------------------------------------- Olin Silander Computational and Systems Biology Biozentrum, University of Basel Klingelbergstr. 50/70 CH-4056 Basel Switzerland 061 267 1621 olinsilander at gmail.com
ADD REPLYlink written 7.1 years ago by Olin Silander30
I also tried to reinstall gtk and imagemagick using homebrew instead of MacPorts, as there seemed to be some forums suggesting that MacPorts installs are not as good on Mountain Lion. Doing this fixed my previous problem with ImageMagick, but resulted in more errors (e.g.): BiocInstaller version 1.4.7, ?biocLite for help > biocLite("EBImage", type="source") BioC_mirror: http://bioconductor.org Using R version 2.15, BiocInstaller version 1.4.7. Installing package(s) 'EBImage' trying URL 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib /EBImage_3.12.0.tar.gz' Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) opened URL ================================================== downloaded 4.5 Mb During startup - Warning messages: 1: Setting LC_CTYPE failed, using "C" 2: Setting LC_TIME failed, using "C" 3: Setting LC_MESSAGES failed, using "C" 4: Setting LC_PAPER failed, using "C" * installing *source* package 'EBImage' ... checking for Magick-config... yes * found ImageMagick version 6.7.7 Q16 * found ImageMagick includes in -I/usr/local/Cellar/imagemagick/6.7.7-6/include/ImageMagick checking for pkg-config... yes Package cairo was not found in the pkg-config search path. Perhaps you should add the directory containing `cairo.pc' to the PKG_CONFIG_PATH environment variable Package 'cairo', required by 'Pango Cairo', not found which I sequentially fixed by installing (when necessary) and linking using homebrew (which I understand is not a great thing to do anyway). This worked until I got to xcb-shm, required by cairo, which I could not find a package for or figure out how to link, and so got stuck on that error: checking for Magick-config... yes * found ImageMagick version 6.7.7 Q16 * found ImageMagick includes in -I/usr/local/Cellar/imagemagick/6.7.7-6/include/ImageMagick checking for pkg-config... yes Package xcb-shm was not found in the pkg-config search path. Perhaps you should add the directory containing `xcb-shm.pc' to the PKG_CONFIG_PATH environment variable Package 'xcb-shm', required by 'cairo', not found That's about all I can figure out to try. Thanks for your suggestions. Cheers, Olin On Aug 17, 2012, at 9:16 PM, Dan Tenenbaum <dtenenba@fhcrc.org> wrote: > On Fri, Aug 17, 2012 at 9:41 AM, Olin Silander <olinsilander@gmail.com> wrote: >> Magick-config seems to be in my PATH: >> >> osilander$ which Magick-config >> /opt/local/bin/Magick-config >> >> as does opt/local/bin: >> >> osilander$ echo $PATH >> /opt/local/bin:/opt/local/sbin:/usr/local/bin//bin:/usr/bin:/bin:/u sr/sbin:/sbin:/usr/local/bin:/opt/X11/bin: >> >> my sessionInfo (all of it) - I do have consistent locale issues but I have >> ignored these mostly, maybe that is the problem: > > > OK, forgetting about sessionInfo() and biocLite() for the moment, it > seems like you get farther when you use R CMD INSTALL. > But it seems like 'make' decided there was nothing to do, so maybe > there were remnants of a previous incomplete build. So I suggest > using either > R CMD INSTALL --preclean > or running > R CMD INSTALL against a tarball, not a directory. > Dan > > >>> sessionInfo() >> R version 2.15.1 (2012-06-22) >> Platform: i386-apple-darwin9.8.0/i386 (32-bit) >> >> locale: >> [1] C >> >> attached base packages: >> [1] stats graphics grDevices utils datasets methods base >> >> other attached packages: >> [1] BiocInstaller_1.4.7 >> >> loaded via a namespace (and not attached): >> [1] tools_2.15.1 >> >> And the messages when I start R: >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_COLLATE failed, using "C" >> 3: Setting LC_TIME failed, using "C" >> 4: Setting LC_MESSAGES failed, using "C" >> 5: Setting LC_PAPER failed, using "C" >> [R.app GUI 1.52 (6188) i386-apple-darwin9.8.0] >> >> WARNING: You're using a non-UTF8 locale, therefore only ASCII characters >> will work. >> Please read R for Mac OS X FAQ (see Help) section 9 and adjust your system >> preferences accordingly. >> [History restored from /Users/osilander/.Rhistory] >> >>> source("http://bioconductor.org/biocLite.R") >> BiocInstaller version 1.4.7, ?biocLite for help >>> biocLite("EBImage", type="source") >> BioC_mirror: http://bioconductor.org >> Using R version 2.15, BiocInstaller version 1.4.7. >> Installing package(s) 'EBImage' >> trying URL >> 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage _3.12.0.tar.gz' >> Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) >> opened URL >> ================================================== >> downloaded 4.5 Mb >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_TIME failed, using "C" >> 3: Setting LC_MESSAGES failed, using "C" >> 4: Setting LC_PAPER failed, using "C" >> * installing *source* package 'EBImage' ... >> checking for Magick-config... no >> configure: error: "ImageMagick or ImageMagick includes not found!" >> ERROR: configuration failed for package 'EBImage' >> * removing >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image' >> >> The downloaded source packages are in >> '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpKkCEr x/downloaded_packages' >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning message: >> In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : >> installation of package 'EBImage' had non-zero exit status >> >> >> On Aug 17, 2012, at 6:31 PM, Dan Tenenbaum <dtenenba@fhcrc.org> wrote: >> >> On Fri, Aug 17, 2012 at 9:21 AM, Olin Silander <olinsilander@gmail.com> >> wrote: >> >> Thanks for the suggestion. Unfortunately this doesn't seem to work either - >> I get the same error that I did previously: >> >> >> Is Magick-config in your PATH? >> >> I also wonder if this could be a locale issue. Can you send your >> sessionInfo()? >> >> I am able to install EBImage from source using biocLite(). Maybe >> because /opt/local/bin is in my path? >> Dan >> >> >> >> >> >> >> biocLite("EBImage", type="source") >> BioC_mirror: http://bioconductor.org >> Using R version 2.15, BiocInstaller version 1.4.7. >> Installing package(s) 'EBImage' >> trying URL >> 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage _3.12.0.tar.gz' >> Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) >> opened URL >> ================================================== >> downloaded 4.5 Mb >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_TIME failed, using "C" >> 3: Setting LC_MESSAGES failed, using "C" >> 4: Setting LC_PAPER failed, using "C" >> * installing *source* package 'EBImage' ... >> checking for Magick-config... no >> configure: error: "ImageMagick or ImageMagick includes not found!" >> ERROR: configuration failed for package 'EBImage' >> * removing >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image' >> >> The downloaded source packages are in >> >> '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpEwsd5 x/downloaded_packages' >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning message: >> In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : >> installation of package 'EBImage' had non-zero exit status >> >> >> This seems very strange, as when I try to install from terminal, the >> ImageMagick check seems fine (as does the suggested check in the vignette): >> >> R CMD INSTALL EBImage >> * installing to library >> ‘/Library/Frameworks/R.framework/Versions/2.15/Resources/library’ >> * installing *source* package ‘EBImage’ ... >> checking for Magick-config... yes >> * found ImageMagick version 6.7.8 Q16 >> * found ImageMagick includes in -I/opt/local/include/ImageMagick >> checking for pkg-config... yes >> * compiling with GTK+ support >> >> Cheers, >> Olin >> >> >> On Aug 17, 2012, at 6:15 PM, Dan Tenenbaum <dtenenba@fhcrc.org> wrote: >> >> On Fri, Aug 17, 2012 at 2:22 AM, Olin Silander <olinsilander@gmail.com> >> wrote: >> >> I am having problems installing EBImage. I am running R 2.15.1 on OSX >> Mountain Lion and have X11 open using with Xquartz 2.7.2 >> >> >> The EBImage installation vignette, warns against installing the Mac >> binary package, and in fact there isn't one on Bioconductor. >> >> The recommended way to install it is: >> source("http://bioconductor.org/biocLite.R") >> biocLite("EBImage", type="source") >> >> Let us know if that works for you. >> Dan >> >> >> >> The output when I try to install EBImage: >> >> osilander$ R CMD INSTALL EBImage >> * installing to library >> ‘/Library/Frameworks/R.framework/Versions/2.15/Resources/library’ >> * installing *source* package ‘EBImage’ ... >> checking for Magick-config... yes >> * found ImageMagick version 6.7.8 Q16 >> * found ImageMagick includes in -I/opt/local/include/ImageMagick >> checking for pkg-config... yes >> * compiling with GTK+ support >> ----------------------------------------------------- >> configure: creating ./config.status >> config.status: creating src/Makevars >> ** libs >> *** arch - i386 >> make: Nothing to be done for `all'. >> installing to >> /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386 >> ** R >> ** inst >> ** preparing package for lazy loading >> ** help >> *** installing help indices >> ** building package indices >> ** installing vignettes >> ‘EBImage-installation.Rnw’ >> ‘EBImage-introduction.Rnw’ >> ** testing if installed package can be loaded >> Error in dyn.load(file, DLLpath = DLLpath, ...) : >> unable to load shared object >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image/libs/i386/EBImage.so': >> dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libr ary/EBImage/libs/i386/EBImage.so, >> 6): Symbol not found: _gdk_display >> Referenced from: >> /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386/EBImage.so >> Expected in: flat namespace >> in >> /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386/EBImage.so >> Error: loading failed >> Execution halted >> ERROR: loading failed >> * removing >> ‘/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image’ >> >> I also tried installing from within the R GUI, and get the following errors: >> >> biocLite("EBImage") >> BioC_mirror: http://bioconductor.org >> Using R version 2.15, BiocInstaller version 1.4.7. >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Installing package(s) 'EBImage' >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning: unable to access index for repository >> http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contri b/2.15 >> Warning message: >> package 'EBImage' is not available (for R version 2.15.1) >> >> Finally, I tried using the R Package Installer, and get a different error: >> >> trying URL >> 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage _3.12.0.tar.gz' >> Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) >> opened URL >> ================================================== >> downloaded 4.5 Mb >> >> During startup - Warning messages: >> 1: Setting LC_CTYPE failed, using "C" >> 2: Setting LC_TIME failed, using "C" >> 3: Setting LC_MESSAGES failed, using "C" >> 4: Setting LC_PAPER failed, using "C" >> * installing *source* package 'EBImage' ... >> checking for Magick-config... no >> configure: error: "ImageMagick or ImageMagick includes not found!" >> ERROR: configuration failed for package 'EBImage' >> * removing >> '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EB Image' >> >> The downloaded source packages are in >> >> '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpT9XfJ 2/downloaded_packages' >> >> >> I also tried using 'chooseBioCmirror()' to change my mirror to Seattle. >> >> The checks for gtk and ImageMagick seem okay except for a single warning: >> >> pz-mlm06020-02:Downloads osilander$ gtk-demo >> (process:1307): Gtk-WARNING **: Locale not supported by C library. >> Using the fallback 'C' locale. >> >> >> osilander$ pkg-config gtk+-2.0 --libs >> >> -L/opt/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 >> -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage >> -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 >> -lm -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lintl >> >> >> osilander$ convert -version >> >> Version: ImageMagick 6.7.8-3 2012-08-15 Q16 http://www.imagemagick.org >> Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC >> Features: OpenCL >> >> >> osilander$ Magick-config --libs >> >> -L/opt/local/lib -lMagickCore >> >> Thanks in advance, >> Olin >> >> ---------------------------------------- >> Olin Silander >> Computational and Systems Biology >> Biozentrum, University of Basel >> Klingelbergstr. 50/70 >> CH-4056 Basel >> Switzerland >> 061 267 1621 >> olinsilander@gmail.com >> >> _______________________________________________ >> Bioconductor mailing list >> Bioconductor@r-project.org >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> Search the archives: >> http://news.gmane.org/gmane.science.biology.informatics.conductor >> >> >> ---------------------------------------- >> Olin Silander >> Computational and Systems Biology >> Biozentrum, University of Basel >> Klingelbergstr. 50/70 >> CH-4056 Basel >> Switzerland >> 061 267 1621 >> olinsilander@gmail.com >> >> >> >> >> ---------------------------------------- >> Olin Silander >> Computational and Systems Biology >> Biozentrum, University of Basel >> Klingelbergstr. 50/70 >> CH-4056 Basel >> Switzerland >> 061 267 1621 >> olinsilander@gmail.com >> >> >> ---------------------------------------- Olin Silander Computational and Systems Biology Biozentrum, University of Basel Klingelbergstr. 50/70 CH-4056 Basel Switzerland 061 267 1621 olinsilander@gmail.com [[alternative HTML version deleted]]
ADD REPLYlink written 7.1 years ago by Olin Silander30
On Mon, Aug 20, 2012 at 7:04 AM, Olin Silander <olinsilander at="" gmail.com=""> wrote: > I also tried to reinstall gtk and imagemagick using homebrew instead of > MacPorts, as there seemed to be some forums suggesting that MacPorts > installs are not as good on Mountain Lion. Doing this fixed my previous > problem with ImageMagick, but resulted in more errors (e.g.): Mountain Lion does not include X11. Did you install X11? If not, try this: 1)Install X11 per these instructions: http://support.apple.com/kb/HT5293 2) Create a symlink: sudo ln -s /opt/X11/ /usr/X11 Let me know if that helps. Dan > > BiocInstaller version 1.4.7, ?biocLite for help >> biocLite("EBImage", type="source") > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Installing package(s) 'EBImage' > trying URL > 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage_ 3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... yes > * found ImageMagick version 6.7.7 Q16 > * found ImageMagick includes in > -I/usr/local/Cellar/imagemagick/6.7.7-6/include/ImageMagick > checking for pkg-config... yes > Package cairo was not found in the pkg-config search path. > Perhaps you should add the directory containing `cairo.pc' > to the PKG_CONFIG_PATH environment variable > Package 'cairo', required by 'Pango Cairo', not found > > which I sequentially fixed by installing (when necessary) and linking using > homebrew (which I understand is not a great thing to do anyway). This worked > until I got to xcb-shm, required by cairo, which I could not find a package > for or figure out how to link, and so got stuck on that error: > > checking for Magick-config... yes > * found ImageMagick version 6.7.7 Q16 > * found ImageMagick includes in > -I/usr/local/Cellar/imagemagick/6.7.7-6/include/ImageMagick > checking for pkg-config... yes > Package xcb-shm was not found in the pkg-config search path. > Perhaps you should add the directory containing `xcb-shm.pc' > to the PKG_CONFIG_PATH environment variable > Package 'xcb-shm', required by 'cairo', not found > > > That's about all I can figure out to try. Thanks for your suggestions. > > Cheers, > Olin > > On Aug 17, 2012, at 9:16 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: > > On Fri, Aug 17, 2012 at 9:41 AM, Olin Silander <olinsilander at="" gmail.com=""> > wrote: > > Magick-config seems to be in my PATH: > > osilander$ which Magick-config > /opt/local/bin/Magick-config > > as does opt/local/bin: > > osilander$ echo $PATH > /opt/local/bin:/opt/local/sbin:/usr/local/bin//bin:/usr/bin:/bin:/us r/sbin:/sbin:/usr/local/bin:/opt/X11/bin: > > my sessionInfo (all of it) - I do have consistent locale issues but I have > ignored these mostly, maybe that is the problem: > > > > OK, forgetting about sessionInfo() and biocLite() for the moment, it > seems like you get farther when you use R CMD INSTALL. > But it seems like 'make' decided there was nothing to do, so maybe > there were remnants of a previous incomplete build. So I suggest > using either > R CMD INSTALL --preclean > or running > R CMD INSTALL against a tarball, not a directory. > Dan > > > sessionInfo() > > R version 2.15.1 (2012-06-22) > Platform: i386-apple-darwin9.8.0/i386 (32-bit) > > locale: > [1] C > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] BiocInstaller_1.4.7 > > loaded via a namespace (and not attached): > [1] tools_2.15.1 > > And the messages when I start R: > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_COLLATE failed, using "C" > 3: Setting LC_TIME failed, using "C" > 4: Setting LC_MESSAGES failed, using "C" > 5: Setting LC_PAPER failed, using "C" > [R.app GUI 1.52 (6188) i386-apple-darwin9.8.0] > > WARNING: You're using a non-UTF8 locale, therefore only ASCII characters > will work. > Please read R for Mac OS X FAQ (see Help) section 9 and adjust your system > preferences accordingly. > [History restored from /Users/osilander/.Rhistory] > > source("http://bioconductor.org/biocLite.R") > > BiocInstaller version 1.4.7, ?biocLite for help > > biocLite("EBImage", type="source") > > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Installing package(s) 'EBImage' > trying URL > 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage_ 3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... no > configure: error: "ImageMagick or ImageMagick includes not found!" > ERROR: configuration failed for package 'EBImage' > * removing > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage' > > The downloaded source packages are in > '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpKkCErx /downloaded_packages' > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning message: > In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : > installation of package 'EBImage' had non-zero exit status > > > On Aug 17, 2012, at 6:31 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: > > On Fri, Aug 17, 2012 at 9:21 AM, Olin Silander <olinsilander at="" gmail.com=""> > wrote: > > Thanks for the suggestion. Unfortunately this doesn't seem to work either - > I get the same error that I did previously: > > > Is Magick-config in your PATH? > > I also wonder if this could be a locale issue. Can you send your > sessionInfo()? > > I am able to install EBImage from source using biocLite(). Maybe > because /opt/local/bin is in my path? > Dan > > > > > > > biocLite("EBImage", type="source") > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Installing package(s) 'EBImage' > trying URL > 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage_ 3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... no > configure: error: "ImageMagick or ImageMagick includes not found!" > ERROR: configuration failed for package 'EBImage' > * removing > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage' > > The downloaded source packages are in > > '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpEwsd5x /downloaded_packages' > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning message: > In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) : > installation of package 'EBImage' had non-zero exit status > > > This seems very strange, as when I try to install from terminal, the > ImageMagick check seems fine (as does the suggested check in the vignette): > > R CMD INSTALL EBImage > * installing to library > ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? > * installing *source* package ?EBImage? ... > checking for Magick-config... yes > * found ImageMagick version 6.7.8 Q16 > * found ImageMagick includes in -I/opt/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > > Cheers, > Olin > > > On Aug 17, 2012, at 6:15 PM, Dan Tenenbaum <dtenenba at="" fhcrc.org=""> wrote: > > On Fri, Aug 17, 2012 at 2:22 AM, Olin Silander <olinsilander at="" gmail.com=""> > wrote: > > I am having problems installing EBImage. I am running R 2.15.1 on OSX > Mountain Lion and have X11 open using with Xquartz 2.7.2 > > > The EBImage installation vignette, warns against installing the Mac > binary package, and in fact there isn't one on Bioconductor. > > The recommended way to install it is: > source("http://bioconductor.org/biocLite.R") > biocLite("EBImage", type="source") > > Let us know if that works for you. > Dan > > > > The output when I try to install EBImage: > > osilander$ R CMD INSTALL EBImage > * installing to library > ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library? > * installing *source* package ?EBImage? ... > checking for Magick-config... yes > * found ImageMagick version 6.7.8 Q16 > * found ImageMagick includes in -I/opt/local/include/ImageMagick > checking for pkg-config... yes > * compiling with GTK+ support > ----------------------------------------------------- > configure: creating ./config.status > config.status: creating src/Makevars > ** libs > *** arch - i386 > make: Nothing to be done for `all'. > installing to > /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBIm age/libs/i386 > ** R > ** inst > ** preparing package for lazy loading > ** help > *** installing help indices > ** building package indices > ** installing vignettes > ?EBImage-installation.Rnw? > ?EBImage-introduction.Rnw? > ** testing if installed package can be loaded > Error in dyn.load(file, DLLpath = DLLpath, ...) : > unable to load shared object > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage/libs/i386/EBImage.so': > dlopen(/Library/Frameworks/R.framework/Versions/2.15/Resources/libra ry/EBImage/libs/i386/EBImage.so, > 6): Symbol not found: _gdk_display > Referenced from: > /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBIm age/libs/i386/EBImage.so > Expected in: flat namespace > in > /Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBIm age/libs/i386/EBImage.so > Error: loading failed > Execution halted > ERROR: loading failed > * removing > ?/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage? > > I also tried installing from within the R GUI, and get the following errors: > > biocLite("EBImage") > BioC_mirror: http://bioconductor.org > Using R version 2.15, BiocInstaller version 1.4.7. > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Installing package(s) 'EBImage' > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning: unable to access index for repository > http://brainarray.mbni.med.umich.edu/bioc/bin/macosx/leopard/contrib /2.15 > Warning message: > package 'EBImage' is not available (for R version 2.15.1) > > Finally, I tried using the R Package Installer, and get a different error: > > trying URL > 'http://www.bioconductor.org/packages/2.10/bioc/src/contrib/EBImage_ 3.12.0.tar.gz' > Content type 'application/x-gzip' length 4738660 bytes (4.5 Mb) > opened URL > ================================================== > downloaded 4.5 Mb > > During startup - Warning messages: > 1: Setting LC_CTYPE failed, using "C" > 2: Setting LC_TIME failed, using "C" > 3: Setting LC_MESSAGES failed, using "C" > 4: Setting LC_PAPER failed, using "C" > * installing *source* package 'EBImage' ... > checking for Magick-config... no > configure: error: "ImageMagick or ImageMagick includes not found!" > ERROR: configuration failed for package 'EBImage' > * removing > '/Library/Frameworks/R.framework/Versions/2.15/Resources/library/EBI mage' > > The downloaded source packages are in > > '/private/var/folders/xq/60l5wb_91c71yn4y2lz8f4_w0000gq/T/RtmpT9XfJ2 /downloaded_packages' > > > I also tried using 'chooseBioCmirror()' to change my mirror to Seattle. > > The checks for gtk and ImageMagick seem okay except for a single warning: > > pz-mlm06020-02:Downloads osilander$ gtk-demo > (process:1307): Gtk-WARNING **: Locale not supported by C library. > Using the fallback 'C' locale. > > > osilander$ pkg-config gtk+-2.0 --libs > > -L/opt/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 > -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage > -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 > -lm -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lintl > > > osilander$ convert -version > > Version: ImageMagick 6.7.8-3 2012-08-15 Q16 http://www.imagemagick.org > Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC > Features: OpenCL > > > osilander$ Magick-config --libs > > -L/opt/local/lib -lMagickCore > > Thanks in advance, > Olin > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: > http://news.gmane.org/gmane.science.biology.informatics.conductor > > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > > > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > > > > ---------------------------------------- > Olin Silander > Computational and Systems Biology > Biozentrum, University of Basel > Klingelbergstr. 50/70 > CH-4056 Basel > Switzerland > 061 267 1621 > olinsilander at gmail.com > > >
ADD REPLYlink written 7.1 years ago by Dan Tenenbaum8.2k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 129 users visited in the last hour