flowQ qaProcess fails to run in both Windows and Mac OS: What am I doing wrong?
1
0
Entering edit mode
Guest User ★ 12k
@guest-user-4897
Last seen 7.7 years ago
Hi everyone, I am a newcomer to R and Bioconductor. I have been working to set up flow cytometry packages for analysis of data from our instrument. For a native R package, I've installed flowCore, flowQ, flowViz and flowStats libaries, and have been following along with the tutorials (i.e. file:///C:/Program%20Files/R/R-2.15.3/library/flowQ/doc/DataQual ityAssessment.pdf). However, despite best efforts, and trying installs in both Windows and Linux, the qaProcess fails to run in the flowQ library. It looks like there might be a missing library, but frankly I'm stumped as to how to procede. I would greatly appreciate your advice! Jason Here is an example, taken from the flowCore tutorial, where the program fails and generates an error. I have little idea what these errors mean. > library(flowQ) > data(GvHD) > GvHD <- GvHD[1:10] > dest <- file.path(tempdir(), "flowQ") > qp1 <- qaProcess.cellnumber(GvHD, outdir=dest, cFactor=0.75) creating summary plots...Error in if (scaleFac != 1) newDims <- dims * scaleFac : missing value where TRUE/FALSE needed In addition: Warning messages: 1: running command 'C:\Windows\system32\cmd.exe /c identify "C:/Users/ jeriksen/AppData/Local/Temp/RtmpyWMjlk/flowQ/images/rQ2ZMUQHWQ/summary .pdf"' had status 1 2: In .local(.Object, ...) : NAs introduced by coercion -- output of sessionInfo(): R version 2.15.3 (2013-03-01) Platform: x86_64-w64-mingw32/x64 (64-bit) locale: [1] LC_COLLATE=English_United States.1252 [2] LC_CTYPE=English_United States.1252 [3] LC_MONETARY=English_United States.1252 [4] LC_NUMERIC=C [5] LC_TIME=English_United States.1252 attached base packages: [1] tools grid splines stats graphics grDevices [7] utils datasets methods base other attached packages: [1] flowQ_1.18.0 latticeExtra_0.6-24 RColorBrewer_1.0-5 [4] parody_1.16.0 bioDist_1.30.0 KernSmooth_2.23-10 [7] outliers_0.14 flowStats_1.16.0 flowWorkspace_1.4.0 [10] hexbin_1.26.2 IDPmisc_1.1.17 flowViz_1.22.0 [13] XML_3.96-1.1 RBGL_1.34.0 graph_1.36.2 [16] Cairo_1.5-2 cluster_1.14.4 mvoutlier_1.9.9 [19] sgeostat_1.0-25 robCompositions_1.6.3 car_2.0-16 [22] nnet_7.3-6 compositions_1.30-1 energy_1.5.0 [25] MASS_7.3-23 boot_1.3-7 tensorA_0.36 [28] rgl_0.93.935 fda_2.3.4 Matrix_1.0-12 [31] lattice_0.20-15 zoo_1.7-9 flowCore_1.24.2 [34] rrcov_1.3-3 pcaPP_1.9-49 mvtnorm_0.9-9994 [37] robustbase_0.9-7 Biobase_2.18.0 BiocGenerics_0.4.0 [40] BiocInstaller_1.8.3 loaded via a namespace (and not attached): [1] annotate_1.36.0 AnnotationDbi_1.20.7 DBI_0.2-6 [4] feature_1.2.8 geneplotter_1.36.0 IRanges_1.16.6 [7] ks_1.8.12 parallel_2.15.3 RSQLite_0.11.3 [10] stats4_2.15.3 xtable_1.7-1 -- Sent via the guest posting facility at bioconductor.org.
flowCore flowViz flowQ flowCore flowViz flowQ • 937 views
ADD COMMENT
0
Entering edit mode
Dan Tenenbaum ★ 8.2k
@dan-tenenbaum-4256
Last seen 15 months ago
United States
On Mon, May 6, 2013 at 1:56 PM, Jason Eriksen [guest] <guest at="" bioconductor.org=""> wrote: > > Hi everyone, > > I am a newcomer to R and Bioconductor. I have been working to set up flow cytometry packages for analysis of data from our instrument. For a native R package, I've installed flowCore, flowQ, flowViz and flowStats libaries, and have been following along with the tutorials (i.e. file:///C:/Program%20Files/R/R-2.15.3/library/flowQ/doc/DataQual ityAssessment.pdf). > > However, despite best efforts, and trying installs in both Windows and Linux, the qaProcess fails to run in the flowQ library. It looks like there might be a missing library, but frankly I'm stumped as to how to procede. > Which operating systems did you try it on? Your subject line says Windows and Mac OS, but your email says Windows and Linux. (Note that flowQ support in Windows was dropped in Bioconductor releases subsequent to the one you are using). > I would greatly appreciate your advice! > > Jason > > Here is an example, taken from the flowCore tutorial, where the program fails and generates an error. I have little idea what these errors mean. > >> library(flowQ) >> data(GvHD) >> GvHD <- GvHD[1:10] >> dest <- file.path(tempdir(), "flowQ") >> qp1 <- qaProcess.cellnumber(GvHD, outdir=dest, cFactor=0.75) > creating summary plots...Error in if (scaleFac != 1) newDims <- dims * scaleFac : > missing value where TRUE/FALSE needed > In addition: Warning messages: > 1: running command 'C:\Windows\system32\cmd.exe /c identify "C:/User s/jeriksen/AppData/Local/Temp/RtmpyWMjlk/flowQ/images/rQ2ZMUQHWQ/summa ry.pdf"' had status 1 > 2: In .local(.Object, ...) : NAs introduced by coercion > > This suggests that perhaps ImageMagick is not installed. It needs to be installed with the directory containing its executables (identify, convert, etc) in your PATH. Dan > -- output of sessionInfo(): > > R version 2.15.3 (2013-03-01) > Platform: x86_64-w64-mingw32/x64 (64-bit) > > locale: > [1] LC_COLLATE=English_United States.1252 > [2] LC_CTYPE=English_United States.1252 > [3] LC_MONETARY=English_United States.1252 > [4] LC_NUMERIC=C > [5] LC_TIME=English_United States.1252 > > attached base packages: > [1] tools grid splines stats graphics grDevices > [7] utils datasets methods base > > other attached packages: > [1] flowQ_1.18.0 latticeExtra_0.6-24 RColorBrewer_1.0-5 > [4] parody_1.16.0 bioDist_1.30.0 KernSmooth_2.23-10 > [7] outliers_0.14 flowStats_1.16.0 flowWorkspace_1.4.0 > [10] hexbin_1.26.2 IDPmisc_1.1.17 flowViz_1.22.0 > [13] XML_3.96-1.1 RBGL_1.34.0 graph_1.36.2 > [16] Cairo_1.5-2 cluster_1.14.4 mvoutlier_1.9.9 > [19] sgeostat_1.0-25 robCompositions_1.6.3 car_2.0-16 > [22] nnet_7.3-6 compositions_1.30-1 energy_1.5.0 > [25] MASS_7.3-23 boot_1.3-7 tensorA_0.36 > [28] rgl_0.93.935 fda_2.3.4 Matrix_1.0-12 > [31] lattice_0.20-15 zoo_1.7-9 flowCore_1.24.2 > [34] rrcov_1.3-3 pcaPP_1.9-49 mvtnorm_0.9-9994 > [37] robustbase_0.9-7 Biobase_2.18.0 BiocGenerics_0.4.0 > [40] BiocInstaller_1.8.3 > > loaded via a namespace (and not attached): > [1] annotate_1.36.0 AnnotationDbi_1.20.7 DBI_0.2-6 > [4] feature_1.2.8 geneplotter_1.36.0 IRanges_1.16.6 > [7] ks_1.8.12 parallel_2.15.3 RSQLite_0.11.3 > [10] stats4_2.15.3 xtable_1.7-1 > > -- > Sent via the guest posting facility at bioconductor.org. > > _______________________________________________ > Bioconductor mailing list > Bioconductor at r-project.org > https://stat.ethz.ch/mailman/listinfo/bioconductor > Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor
ADD COMMENT

Login before adding your answer.

Traffic: 248 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6