Can't load DirichletMultinomial on R 3.3.0
2
0
Entering edit mode
422171 • 0
@422171-9758
Last seen 5.2 years ago

I library DirichletMultinomial (v. 1.13.3) won't load with R 3.3.0.

This is the error I get:

Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared object '/Library/Frameworks/R.framework/Versions/3.3/Resources/library/DirichletMultinomial/libs/DirichletMultinomial.so':
  dlopen(/Library/Frameworks/R.framework/Versions/3.3/Resources/library/DirichletMultinomial/libs/DirichletMultinomial.so, 6): Library not loaded: /usr/local/lib/libgsl.0.dylib
  Referenced from: /Library/Frameworks/R.framework/Versions/3.3/Resources/library/DirichletMultinomial/libs/DirichletMultinomial.so
  Reason: image not found
Error: package or namespace load failed for ‘DirichletMultinomial’

Any suggestions how to solve thi issue?

 

DirichletMultinomial • 1.5k views
ADD COMMENT
1
Entering edit mode
Dan Tenenbaum ★ 8.2k
@dan-tenenbaum-4256
Last seen 9 weeks ago
United States

You need to install the Gnu Scientific Library (GSL).

On Mac you can do that with the following commands in a Terminal window:

curl -LO http://r.research.att.com/libs/gsl-1.16-darwin.13-x86_64.tar.gz
sudo tar fvxz gsl-1.16-darwin.13-x86_64.tar.gz -C /

 

ADD COMMENT
0
Entering edit mode

I already installed gsl using Homebrew (brew install gsl), but I still get the same error.

ADD REPLY
0
Entering edit mode

DirichletMultinomial is looking for the library in /usr/local/lib but brew probably installs it in a different place (under /opt). So I'd recommend removing the brew installation of gsl and installing the one from research.att.com as described above. This is the version of gsl used on CRAN and Bioconductor build systems (which do not use brew) so it should work.

ADD REPLY
0
Entering edit mode

So I tried what you recommended, but it is still the same. I am starting to be quite desperate. But anyways thanks for help.

ADD REPLY
0
Entering edit mode

So I tried what you recommended, but it is still the same. I am starting to be quite desperate. But anyways thanks for help.

ADD REPLY
0
Entering edit mode

Even after uninstalling the brew version and installing how you recommended I do not have file /usr/local/lib/libgsl.0.dylib

ADD REPLY
1
Entering edit mode

If you have Xcode command line tools installed then try installing DirichletMultinomial from source:

library(BiocInstaller)
biocLite("DirichletMultinomial", type="source")

ADD REPLY
0
Entering edit mode
Dan Tenenbaum ★ 8.2k
@dan-tenenbaum-4256
Last seen 9 weeks ago
United States

Turns out this was a problem on our side--our mac build machine somehow had that .dylib file installed when we should have been pulling in the static version of the GSL library. I've fixed this and the corrected versions will be available tomorrow (Monday) at around noon Seattle time. Sorry for the inconvenience. 

ADD COMMENT

Login before adding your answer.

Traffic: 490 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6