Search
Question: Error in "getGSEDataTables" in GSEquery package
1
gravatar for ajwijeratne.1
20 months ago by
United States
ajwijeratne.110 wrote:

 

I am trying to use "getGSEDataTables" from GSEquery package, but it gives the following error:

> dfl = getGSEDataTables("GSE3494")
error : Unknown IO error
I/O warning : failed to load external entity "http://www.ncbi.nlm.nih.gov/projects/geo/query/acc.cgi?targ=self&form=xml&view=full&acc=GSE3494"
Error in UseMethod("xmlRoot") : 
  no applicable method for 'xmlRoot' applied to an object of class "NULL"

My session info:

> sessionInfo()
R version 3.2.3 (2015-12-10)
Platform: x86_64-apple-darwin14.5.0 (64-bit)
Running under: OS X 10.11.3 (El Capitan)

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] GEOquery_2.36.0              devtools_1.9.1               hgu133ahsentrezg.db_20.0.0   org.Hs.eg.db_3.2.3          
 [5] pd.hgu133a.hs.entrezg_0.0.1  oligo_1.34.2                 oligoClasses_1.32.0          RSQLite_1.0.0               
 [9] DBI_0.3.1                    Biostrings_2.38.4            XVector_0.10.0               hgu133ahsentrezgprobe_20.0.0
[13] hgu133ahsentrezgcdf_20.0.0   AnnotationDbi_1.32.3         IRanges_2.4.8                S4Vectors_0.8.11            
[17] gcrma_2.42.0                 affy_1.48.0                  Biobase_2.30.0               BiocGenerics_0.16.1         
[21] BiocInstaller_1.20.1        

loaded via a namespace (and not attached):
 [1] GenomeInfoDb_1.6.3         bitops_1.0-6               iterators_1.0.8            tools_3.2.3               
 [5] zlibbioc_1.16.0            digest_0.6.8               bit_1.1-12                 memoise_0.2.1             
 [9] preprocessCore_1.32.0      ff_2.2-13                  foreach_1.4.3              curl_0.9.4                
[13] httr_1.0.0                 stringr_1.0.0              affxparser_1.42.0          R6_2.1.1                  
[17] XML_3.98-1.3               magrittr_1.5               codetools_0.2-14           splines_3.2.3             
[21] GenomicRanges_1.22.4       SummarizedExperiment_1.0.2 stringi_1.0-1              RCurl_1.95-4.7            
[25] affyio_1.40.0           
ADD COMMENTlink modified 11 months ago by Sean Davis21k • written 20 months ago by ajwijeratne.110
0
gravatar for sharvari gujja
11 months ago by
United States
sharvari gujja10 wrote:

Hello,

I get the same error, and wondered if you have any suggestions to fix it.

Thanks

Sharvari

ADD COMMENTlink written 11 months ago by sharvari gujja10
0
gravatar for Sean Davis
11 months ago by
Sean Davis21k
United States
Sean Davis21k wrote:

Sorry I missed this question the first time.  The solution is to upgrade to GEOquery 2.40 or higher due to a change at NCBI from "http" to "https". 

ADD COMMENTlink written 11 months ago by Sean Davis21k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 145 users visited in the last hour