normalize.AffyBatch.vsn not expressed in vsn
2
0
Entering edit mode
@claudio-lottaz-2756
Last seen 4.6 years ago

Hi all,

I use the function expresso from the affy package for normalizing microarray data, and tell expresso to use vsn as normalization method. This went fine for years but the current version of vsn (3.42.3) no longer exports the normalize.AffyBatch.vsn method. Hence, expresso no longer finds vsn as normalization method. Is this a bug or intention? If I force the export, expresso seems to execute vsn-normalisation as expected.

Cheers,

Claudio

 

software error vsn affy • 721 views
ADD COMMENT
0
Entering edit mode
@james-w-macdonald-5106
Last seen 1 day ago
United States

It's still there for me.

> library(affy)

> library(vsn)
> normalize.AffyBatch.methods()
[1] "constant"         "contrasts"        "invariantset"     "loess"         
[5] "methods"          "qspline"          "quantiles"        "quantiles.robust"
[9] "vsn"           
> sessionInfo()
R version 3.3.1 (2016-06-21)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Debian GNU/Linux 8 (jessie)

locale:
[1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C            
[3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8  
[5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8 
[7] LC_PAPER=en_US.UTF-8       LC_NAME=C               
[9] LC_ADDRESS=C               LC_TELEPHONE=C          
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] parallel  stats     graphics  grDevices utils     datasets  methods
[8] base     

other attached packages:
[1] vsn_3.42.3          affy_1.52.0         Biobase_2.34.0   
[4] BiocGenerics_0.20.0

loaded via a namespace (and not attached):
[1] Rcpp_0.12.7           lattice_0.20-34       assertthat_0.1     
[4] plyr_1.8.4            grid_3.3.1            gtable_0.2.0       
[7] scales_0.4.1          ggplot2_2.2.0         BiocInstaller_1.24.0
[10] zlibbioc_1.20.0       lazyeval_0.2.0.9000   affyio_1.44.0      
[13] limma_3.30.3          preprocessCore_1.36.0 tools_3.3.1        
[16] munsell_0.4.3         compiler_3.3.1        colorspace_1.3-0   
[19] tibble_1.2         
>
ADD COMMENT
0
Entering edit mode
@claudio-lottaz-2756
Last seen 4.6 years ago

Oops, it seems that I messed up my previous installation (with vsn version 3.42.0). Now thinks work fine for me as well.Thanks for the hint!

Cheers, Claudio

ADD COMMENT

Login before adding your answer.

Traffic: 340 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6