Error when using EnrichmentBrowser's sbea function with RNA-seq data
1
0
Entering edit mode
aichen620 • 0
@aichen620-12055
Last seen 5.6 years ago

When I run gsea method by sbea function with correct expression set, I got an error says "can't find object 'eset'   ", which is weird that I run 'globaltest' method by sbea function without any error.

### call a error : "can't find object 'eset' 
gsea.res =  sbea(method='gsea', eset=exset, gs=gsets, alpha=0.999, perm=100)

#### GLOBALTEST runs well ####
gb.res = sbea(method='globaltest', eset=exset, gs=gsets, alpha=0.999, perm=100)

 

Could anyone help me?

EnrichmentBrowser rnaseq • 716 views
ADD COMMENT
0
Entering edit mode
@ludwig-geistlinger-3939
Last seen 24 days ago
USA/Boston/HMS

Hi Ai Chen,

(1) perhaps you want to change the title of your post to something more precise such as:

"Error when using EnrichmentBrowser's sbea function with RNA-seq data"

(2) You maybe by accident also created another post

RNA-Seq type of data sbea gos wrong

reporting on the same error twice. I suggest you to delete / merge with this one to avoid redundancy.

(3) Besides, thank you for reporting this bug. This is now fixed in the new version of the EnrichmentBrowser package. Watch out for version 2.4.5, which should be available within 24 hours under

http://www.bioconductor.org/packages/release/bioc/html/EnrichmentBrowser.html

Best,

Ludwig

 

ADD COMMENT
0
Entering edit mode

Many thanks! I'm waiting for the new version :-)

ADD REPLY

Login before adding your answer.

Traffic: 214 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6