GMM/DEP Package lib/libgomp.1.dylib: mach-o, but wrong architecture
0
Entering edit mode
Tomaž • 0
@Tomaž-24553
Last seen 5 days ago

Hi,

after installing bioconductor (as on webpage), I get into a problem with DEP and GMM. When I try to run library(DEP) or library(GMM) the following error occurs:

Ony these two packages seem to have a problem.

library(gmm) Loading required package: sandwich Error: package or namespace load failed for ‘gmm’ in dyn.load(file, DLLpath = DLLpath, ...): unable to load shared object '/Library/Frameworks/R.framework/Versions/4.0/Resources/library/gmm/libs/gmm.so': dlopen(/Library/Frameworks/R.framework/Versions/4.0/Resources/library/gmm/libs/gmm.so, 6): Library not loaded: /usr/local/gfortran/lib/libgomp.1.dylib Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/library/gmm/libs/gmm.so Reason: no suitable image found. Did find: /usr/local/gfortran/lib/libgomp.1.dylib: mach-o, but wrong architecture /usr/local/gfortran/lib/libgomp.1.dylib: mach-o, but wrong architecture

or

library(DEP) Error: package or namespace load failed for ‘DEP’ in dyn.load(file, DLLpath = DLLpath, ...): unable to load shared object '/Library/Frameworks/R.framework/Versions/4.0/Resources/library/gmm/libs/gmm.so': dlopen(/Library/Frameworks/R.framework/Versions/4.0/Resources/library/gmm/libs/gmm.so, 6): Library not loaded: /usr/local/gfortran/lib/libgomp.1.dylib Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/library/gmm/libs/gmm.so Reason: no suitable image found. Did find: /usr/local/gfortran/lib/libgomp.1.dylib: mach-o, but wrong architecture /usr/local/gfortran/lib/libgomp.1.dylib: mach-o, but wrong architecture

Latest XCode is installed.

ProblemloadingDEP/GMMpackageinRStudio DEP • 32 views
ADD COMMENTlink

Login before adding your answer.

Similar Posts
Loading Similar Posts
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.3