Question: Iso-maSigPro errors in IsoModel and PodiumChange
0
gravatar for xin.zhou
24 months ago by
xin.zhou0
xin.zhou0 wrote:

Hi,

I'm trying out the development version of the new maSigPro from bioconductor 3.6. I've run into some errors with different RNA-seq datasets using the new Iso-maSigPro tools. The input data are counts with DESeq2 normalization. It seems to work pretty well at gene level but not so smooth with isoform level analysis. 

With one dataset, I got an error while running PodiumChange as below:

> det.126Vs128 <- getDS(iso.126Vs128, rsq = 0.5)
[1] "322  DSG selected"
[1] "677  DETs selected"
DSG_distributed_by_number_of_DETs
  1   2   3   4   5   6   7 
 75 179  39  18   7   1   2 
> PC_126Vs128 <- PodiumChange(det.126Vs128, comparison = 'any')
Error in tapply(zzM, repvect, mean) : arguments must have same length

With another dataset, I got stuck at IsoModel as below:

> iso.486Vs486_daf2 <- IsoModel(data=iso.data.486Vs486_daf2[,-1], gen=iso.data.486Vs486_daf2[,1], design=design.mat.486Vs486_daf2, counts=TRUE, Q = 0.005)
[1] "32325 transcripts"
[1] "21667 genes"
[1] "fitting gene 100 out of 5259"
[1] "fitting gene 200 out of 5259"
                        ...
[1] "fitting gene 4800 out of 5259"
[1] "fitting gene 4900 out of 5259"
Error in glm.fit(x = c(1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,  : 
  NA/NaN/Inf in 'x'
In addition: There were 13 warnings (use warnings() to see them)

Removing zero values from the counts data didn't make a difference in either case. Could anyone point out how to fix it please? Thanks a lot!

masigpro • 360 views
ADD COMMENTlink modified 24 months ago • written 24 months ago by xin.zhou0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 318 users visited in the last hour