Search
Question: ProStaR Not working, gives error in code?
0
gravatar for van.theodorakis
14 months ago by
van.theodorakis0 wrote:
Have I done anything wrong, or something in the original code is broken?

source("http://www.bioconductor.org/biocLite.R")
biocLite("DAPAR")
biocLite("Prostar")
library(DAPAR)
library(Prostar)
Prostar()

Listening on http://127.0.0.1:6064
Warning: Error in $: $ operator is invalid for atomic vectors

 

R version 3.4.0 (2017-04-21)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices
[6] utils     datasets  methods   base     

other attached packages:
 [1] imp4p_0.4           imputeLCMD_2.0     
 [3] impute_1.50.1       pcaMethods_1.68.0  
 [5] norm_1.0-9.5        tmvtnorm_1.4-10    
 [7] gmm_1.6-1           sandwich_2.4-0     
 [9] Matrix_1.2-11       mvtnorm_1.0-6      
[11] truncnorm_1.0-7     Iso_0.0-17         
[13] sm_2.2-5.4          openxlsx_4.0.17    
[15] MSnbase_2.2.0       ProtGenerics_1.8.0 
[17] BiocParallel_1.10.1 mzR_2.10.0         
[19] Rcpp_0.12.13        Biobase_2.36.2     
[21] BiocGenerics_0.22.1 DT_0.2             
[23] reshape2_1.4.2      highcharter_0.5.0  
[25] shinyAce_0.2.1      shinyjs_0.9.1      
[27] data.table_1.10.4-2 rhandsontable_0.3.4
[29] DAPARdata_1.4.0     shiny_1.0.5        
[31] Prostar_1.8.5       DAPAR_1.8.7 
ADD COMMENTlink modified 13 months ago by Samuel Wieczorek0 • written 14 months ago by van.theodorakis0
0
gravatar for Samuel Wieczorek
13 months ago by
France
Samuel Wieczorek0 wrote:

Hi

this error was due to some updates in dependancy packages. The new version of DAPAR and Prostar (in Bioconductor 3.6) should work now.

 

Please let me know if all if ok

 

Sam

ADD COMMENTlink written 13 months ago by Samuel Wieczorek0

Dear Sam

Having tried to install both of these packages on my personal Mac and windows based computer, i am also having the same issues despite updating to the latest packages (dependencies included). 

Any help would be much appreciated.

Laura

ADD REPLYlink written 12 months ago by laural7100

It's usually valuable to provide the output of sessionInfo() and to cut-and-paste the code and output that causes the error.

ADD REPLYlink written 12 months ago by Martin Morgan ♦♦ 22k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 233 users visited in the last hour