Bumphunter error: subscript out of bounds
0
0
Entering edit mode
@arcedomingo1407-15781
Last seen 3.4 years ago

Hi,

I am running bumphunter in an ubuntu server (443 G of RAM and 75 G of swap) on data from approx. 2000 EPIC arrays. This is the error I am getting when trying to run it with multicore: "Error in nulltabs[[i]] : subscript out of bounds". When running it with a single core, this error is not happening (but the process lasts two weeks, so this is not a solution).

This is my command line:

 

registerDoParallel( cores = 3)

res <- bumphunter(M.combat, design, coeff=2, chr= manifestInfo$chr, pos=manifestInfo$pos, maxGap=300, B=2000, cutoff=NULL, pickCutoff=TRUE, pickCutoffQ=0.995,nullMethod="bootstrap",verbose=TRUE)

[bumphunterEngine] Parallelizing using 3 workers/cores (backend: doParallelMC, version: 1.0.10).
[bumphunterEngine] Computing coefficients.
[bumphunterEngine] Performing 2000 bootstraps.
[bumphunterEngine] Computing marginal bootstrap p-values.
[bumphunterEngine] cutoff: 0.085
[bumphunterEngine] Finding regions.
[bumphunterEngine] Found 11510 bumps.
[bumphunterEngine] Computing regions for each bootstrap.
[bumphunterEngine] Estimating p-values and FWER.
Error in nulltabs[[i]] : subscript out of bounds

 

 

This is my session info:

R version 3.4.4 (2018-03-15)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 16.04.4 LTS

Matrix products: default
BLAS: /usr/lib/libblas/libblas.so.3.6.0
LAPACK: /usr/lib/lapack/liblapack.so.3.6.0

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=es_ES.UTF-8        LC_COLLATE=en_US.UTF-8
 [5] LC_MONETARY=es_ES.UTF-8    LC_MESSAGES=en_US.UTF-8
 [7] LC_PAPER=es_ES.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=es_ES.UTF-8 LC_IDENTIFICATION=C

attached base packages:
 [1] parallel  stats4    grid      stats     graphics  grDevices utils
 [8] datasets  methods   base

other attached packages:
 [1] bumphunter_1.20.0    locfit_1.5-9.1       iterators_1.0.9
 [4] foreach_1.4.4        GenomicRanges_1.30.3 GenomeInfoDb_1.14.0
 [7] IRanges_2.12.0       S4Vectors_0.16.0     BiocGenerics_0.24.0
[10] readstata13_0.9.0    readr_1.1.1          survey_3.33-2
[13] Matrix_1.2-12        foreign_0.8-70       Hmisc_4.1-1
[16] ggplot2_2.2.1        Formula_1.2-2        lattice_0.20-35
[19] survival_2.42-3

loaded via a namespace (and not attached):
 [1] httr_1.3.1                 Biobase_2.38.0
 [3] RMySQL_0.10.14             bit64_0.9-7
 [5] splines_3.4.4              assertthat_0.2.0
 [7] latticeExtra_0.6-28        doRNG_1.6.6
 [9] blob_1.1.1                 Rsamtools_1.30.0
[11] GenomeInfoDbData_1.0.0     progress_1.1.2
[13] pillar_1.2.2               RSQLite_2.1.0
[15] backports_1.1.2            digest_0.6.15
[17] RColorBrewer_1.1-2         XVector_0.18.0
[19] checkmate_1.8.5            colorspace_1.3-2
[21] htmltools_0.3.6            plyr_1.8.4
[23] XML_3.98-1.11              pkgconfig_2.0.1
[25] biomaRt_2.34.2             zlibbioc_1.24.0
[27] xtable_1.8-2               scales_0.5.0
[29] BiocParallel_1.12.0        htmlTable_1.11.2
[31] tibble_1.4.2               pkgmaker_0.22
[33] SummarizedExperiment_1.8.1 GenomicFeatures_1.30.3
[35] nnet_7.3-12                lazyeval_0.2.1
[37] magrittr_1.5               memoise_1.1.0
[39] prettyunits_1.0.2          tools_3.4.4
[41] registry_0.5               data.table_1.10.4-3
[43] hms_0.4.2                  matrixStats_0.53.1
[45] stringr_1.3.0              munsell_0.4.3
[47] cluster_2.0.6              rngtools_1.2.4
[49] DelayedArray_0.4.1         AnnotationDbi_1.40.0
[51] Biostrings_2.46.0          compiler_3.4.4
[53] rlang_0.2.0                RCurl_1.95-4.10
[55] rstudioapi_0.7             htmlwidgets_1.2
[57] bitops_1.0-6               base64enc_0.1-3
[59] gtable_0.2.0               codetools_0.2-15
[61] DBI_0.8                    R6_2.2.2
[63] GenomicAlignments_1.14.2   gridExtra_2.3
[65] rtracklayer_1.38.3         knitr_1.20
[67] bit_1.1-12                 stringi_1.1.7
[69] Rcpp_0.12.16               rpart_4.1-13
[71] acepack_1.4.1

 

Thanks!

bumphunter DMR doparallel multicore • 605 views
ADD COMMENT
0
Entering edit mode

Hi,

I also encountered the same problem. Have your problem been solved?

Thank you so much.

Best wishes,

Yu

ADD REPLY

Login before adding your answer.

Traffic: 214 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6