Question: Cannot Update Biostrings to Latest Version
0
gravatar for gradypierroz
14 months ago by
gradypierroz0 wrote:

I am trying to run DADA2 on my local machine, and for install I need Biostrings >=2.42.1. However, whenever I try to update Biostrings it automatically tries URL 'http://bioconductor.org/packages/3.0/bioc/src/contrib/Biostrings_2.34.1.tar.gz'. I've tried upgrading Bioconductor and RStudio, but neither helped. I have also tried downloading the tar.gz files for Biostrings 2.46.0 and installing it with both the the GUI and 

install.packages("~/path/to/Biostrings/",
                 repos = NULL,
                 type = "source")

But doing either led to Biostrings failing to be compiled. Any ideas on how I can successfully upgrade Biostrings, or get around this dependency somehow and install DADA2 regardless? Thanks!

p.s. Sorry, I'm still very new to R....

Here is my session info:

R version 3.4.2 (2017-09-28)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 14.04.5 LTS

Matrix products: default
BLAS: /usr/lib/openblas-base/libblas.so.3
LAPACK: /usr/lib/lapack/liblapack.so.3.0

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C               LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8    LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C             LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] BiocInstaller_1.16.5

loaded via a namespace (and not attached):
[1] compiler_3.4.2 tools_3.4.2    yaml_2.2.0  
biostrings dada2 • 281 views
ADD COMMENTlink modified 14 months ago by James W. MacDonald51k • written 14 months ago by gradypierroz0
Answer: Cannot Update Biostrings to Latest Version
0
gravatar for James W. MacDonald
14 months ago by
United States
James W. MacDonald51k wrote:

Bioconductor package versions are tightly associated with the R version, so you can't get new versions of packages to install on old versions of R. You should upgrade to R-3.5.x (whatever is the current minor version) and then use biocLite to install the packages you need.

ADD COMMENTlink written 14 months ago by James W. MacDonald51k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 392 users visited in the last hour