pathview: object 'bods' not found
1
0
Entering edit mode
@shi-xiang-wang-14673
Last seen 2.0 years ago
China/Shanghai/ShanghaiTech. University

I use pathfindR package and find a problem related to pathview package.

Error in pathview::pathview(gene.data = genedata, gene.idtype = "SYMBOL",  : 
  object 'bods' not found
In addition: Warning messages:
1: In runpathfindR(RAinput, outputdir = "testdir") :
  There already is a directoy named "testdir". Changing to "testdir(1)" not to overwrite the previous results.
2: In inputprocessing(input, pvalthreshold, pin_path) :
  The gene column was turned into character from factor.
3: In data(bods) : data set ‘bods’ not found

I followed the suggestion by Author of package pathfindR and still cannot fix problem. I think the developer of pathview should fix source code of data() part in all functions.

pathview • 941 views
ADD COMMENT
0
Entering edit mode

It would be also helpful for the pathview maintainers if you included your sessionInfo() so they are aware what os system, version of R, and version of the package you are using.

ADD REPLY
0
Entering edit mode
anamaria ▴ 10
@anamaria-15331
Last seen 21 months ago
Barcelona, Spain

As per here, this is a common issue and usually can be solved by unloading and loading the package:

detach("package:pathfindR", unload=TRUE)
detach("package:pathview", unload=TRUE)
library(pathfindR) 
ADD COMMENT

Login before adding your answer.

Traffic: 302 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6