Question: Rgraphviz installation problem on " chmod: cannot access '~/library/Rgraphviz/libs/*': No such file or directory"
0
gravatar for Amin Moghaddasi
12.1 years ago by
Amin Moghaddasi130 wrote:
Dear Li, Dear All, Many thanks for all your suggestions, I have upgraded the R to 2.6 and tried to install the latest version of Rgraphviz but the problem still exist and I don't know if it is actually related to bioconductor or grphviz?? So any advise is appreciated. I have installed : R version 2.6.0, Bioconductor version 2.1, Graphviz version 2.12-4ubuntu3. The environment variable are configured as below : $export PKG_CONFIG_PATH="/usr/lib/pkgconfig" $whereis graphviz graphviz: /usr/lib/graphviz /usr/include/graphviz /usr/share/graphviz /usr/share/man/man7/graphviz.7.gz $export LD_LIBRARY_PATH=/usr/lib/graphviz $ R CMD INSTALL --configure-args='--with-graphviz=/usr/lib/graphviz' Rgraphviz_1.16.0.tar.gz * Installing to library '/home/moghadda/R/library26' * Installing *source* package 'Rgraphviz' ... configure: Using user specified graphviz root directory /usr/lib/graphviz ./configure: line 1459: test: 1453:: integer expression expected configure: Found graphviz 1453: ./configure: line 1481: test: 1453:: integer expression expected ./configure: line 1481: test: 1453:: integer expression expected configure: We have inferred the following flags for graphviz configure: ..PKG_CPPFLAGS=-I/usr/lib/graphviz/include/graphviz configure: ..PKG_LIBS=-L/usr/lib/graphviz/lib/graphviz -L/usr/lib/graphviz/lib -lgvc checking for whether compiler has bool... checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed checking how to run the C preprocessor... gcc -E checking for egrep... grep -E checking for ANSI C header files... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking for stdbool.h that conforms to C99... yes checking for _Bool... yes yes configure: creating ./config.status config.status: creating src/Makevars ** libs gcc -std=gnu99 -I/usr/share/R/include -I/usr/share/R/include -I/usr/lib/graphviz/include/graphviz -DGRAPHVIZ_MAJOR=1453: -DGRAPHVIZ_MINOR=1453: -DHAVE_STDBOOL_H=1 -DHAVE_BOOL=1 -fpic -g -O2 -c agopen.c -o agopen.o In file included from agopen.c:1: common.h:17:5: error: ':' without preceding '?' In file included from agopen.c:1: common.h:52: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?*? token common.h:55:5: error: ':' without preceding '?' common.h:60: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?*? token In file included from agopen.c:2: util.h:18: error: expected ?)? before ?*? token agopen.c:4: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?*? token agopen.c: In function ?Rgraphviz_agopen?: agopen.c:54: error: ?Agraph_t? undeclared (first use in this function) agopen.c:54: error: (Each undeclared identifier is reported only once agopen.c:54: error: for each function it appears in.) agopen.c:54: error: ?g? undeclared (first use in this function) agopen.c:54: error: ?tmpGraph? undeclared (first use in this function) agopen.c:55: error: ?sgs? undeclared (first use in this function) agopen.c:56: error: ?Agnode_t? undeclared (first use in this function) agopen.c:56: error: ?head? undeclared (first use in this function) agopen.c:56: error: ?tail? undeclared (first use in this function) agopen.c:56: error: ?tmp? undeclared (first use in this function) agopen.c:57: error: ?Agedge_t? undeclared (first use in this function) agopen.c:57: error: ?curEdge? undeclared (first use in this function) agopen.c:80: warning: implicit declaration of function ?aginit? agopen.c:82: warning: implicit declaration of function ?agopen? agopen.c:86: warning: implicit declaration of function ?setDefaultAttrs? agopen.c:89: error: expected expression before ?)? token agopen.c:107: warning: implicit declaration of function ?agsubg? agopen.c:109: warning: implicit declaration of function ?free? agopen.c:118: warning: implicit declaration of function ?agset? agopen.c:142: warning: implicit declaration of function ?agnode? agopen.c:170: warning: implicit declaration of function ?agfindnode? agopen.c:180: warning: implicit declaration of function ?agedge? agopen.c:194: warning: implicit declaration of function ?buildRagraph? agopen.c:194: warning: return makes pointer from integer without a cast make: *** [agopen.o] Error 1 chmod: cannot access `/home/moghadda/R/library26/Rgraphviz/libs/*': No such file or directory ERROR: compilation failed for package 'Rgraphviz' ** Removing '/home/moghadda/R/library26/Rgraphviz' ** Restoring previous '/home/moghadda/R/library26/Rgraphviz' =================== > sessionInfo() R version 2.6.0 (2007-10-03) i486-pc-linux-gnu locale: LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_US .UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US. UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF-8 ;LC_IDENTIFICATION=C attached base packages: [1] stats graphics grDevices utils datasets methods base loaded via a namespace (and not attached): [1] rcompgen_0.1-17 Regards, Amin. On Fri, 2007-10-19 at 15:40 +0200, Li.Long at isb-sib.ch wrote: > It's the combination of different version of R/Rgraphviz and graphviz > that's causing the problem. > > graphviz 2.14.1 was released AFTER R 2.4.1 (and its matching bioconductor > release), therefore, the old Rgraphviz doesn't know what to do with the > newer graphviz. > > You could upgrade your R to 2.6.0, along with bioconductor 2.1, its > matching Rgraphviz handles graphviz 2.14.1. > > Or if you have to stick with older version of R/bioconductor, you have to > back port the necessary changes in Rgraphviz to your older version. This > is reported and accomplished already (you could find info in the mail > archive) > > We don't have resource to make all older version of bioconductor > compatible with newer software releases. > > Thanks, > > Li > > > > > Dear Tony, > > Thanks for your quick reply, here is my sessioninfo : > > > >> sessionInfo() > > R version 2.4.1 (2006-12-18) > > i686-pc-linux-gnu > > > > locale: > > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=e n_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en _US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.U TF-8;LC_IDENTIFICATION=C > > > > attached base packages: > > [1] "stats" "graphics" "grDevices" "utils" "datasets" > > "methods" > > [7] "base" > >> > > > > > > Cheers, > > Amin. > > > > > > On Fri, 2007-10-19 at 13:46 +0100, Tony Chiang wrote: > >> Hi Amin, > >> > >> Can you please send the list the output of your sessionInfo(). It will > >> help us to try and reproduce the error you get. > >> > >> Best, > >> --Tony > >> > >> On 10/19/07, Amin Moghaddasi <a.moghaddasi at="" gmail.com=""> wrote: > >> Dear All, > >> > >> I have some problem installing Rgraphgviz on my system with > >> the > >> following specification. > >> > >> My system is Suse 9.2 , i386 GNU/Linux > >> I have installed graphviz-2.14.1 from source > >> I have gcc version 3.3.4 (pre 3.3.5 20040809) > >> I also set the LD_LIBRARY_PATH= > >> $LD_LIBRARY_PATH:/usr/local/lib/graphviz > >> R version 2.4.1 (2006-12-18) > >> > >> 1 - When I try to install from bash command, I'll get the > >> following > >> error: > >> > R CMD INSTALL Rgraphviz_1.5.0.tar.gz > >> * Installing *source* package 'Rgraphviz' ... > >> checking for graphviz... checking for dotneato-config... not > >> found > >> failed > >> configure: error: please specify a valid path to > >> 'dotneato-config' > >> version >= 1.12 using --with-graphviz=DIR > >> ERROR: configuration failed for package 'Rgraphviz' > >> ** Removing '/home/bkp-moghadda/lib/R/library/Rgraphviz' > >> > >> 2 - using biocLite in R gives another error: > >> > source("http://bioconductor.org/biocLite.R") > >> Warning messages: > >> 1: Redefining 'biocinstall' in: safeSource() > >> 2: Redefining 'biocinstall.affyPkgs' in: safeSource() > >> 3: Redefining 'biocinstall.allPkgs' in: safeSource() > >> 4: Redefining 'biocinstall.defaultPkgs' in: safeSource() > >> 5: Redefining 'biocinstall.graphPkgs' in: safeSource() > >> 6: Redefining 'biocinstall.litePkgs' in: safeSource() > >> 7: Redefining 'biocinstall.monographPkgs' in: safeSource() > >> > biocLite("Rgraphviz") > >> Running biocinstall version 1.9.9 with R version 2.4.1 > >> Your version of R requires version 1.9 of Bioconductor. > >> Warning in install.packages(pkgs = pkgs, repos = repos, > >> dependencies = > >> dependencies, : > >> argument 'lib' is missing: > >> using /home/bkp-moghadda/lib/R/library > >> trying URL > >> 'http://bioconductor.org/packages/1.9/bioc/src/contrib/Rg raphviz_1.12.3.tar.gz' > >> Content type 'application/x-gzip' length 1504829 bytes > >> opened URL > >> ================================================== > >> downloaded 1469Kb > >> > >> * Installing *source* package 'Rgraphviz' ... > >> checking for pkg-config... /usr/local/bin/pkg-config > >> configure: Found graphviz 2.14.1 > >> configure: creating ./config.status > >> config.status : creating src/Makevars > >> ** libs > >> gcc -std=gnu99 -I/usr/lib/R/include -I/usr/lib/R/include > >> -I/usr/local/include/graphviz -DGRAPHVIZ_MAJOR=2 > >> -DGRAPHVIZ_MINOR=14 > >> -I/usr/local/include -fpic -c Rgraphviz.c -o Rgraphviz.o > >> In file included from /usr/local/include/graphviz/gvc.h:20, > >> from common.h:38, > >> from Rgraphviz.c:1: > >> /usr/local/include/graphviz/types.h:27:1: warning: "TRUE" > >> redefined > >> In file included from common.h:8, > >> from Rgraphviz.c:1: > >> /usr/lib/R/include/Rdefines.h:148:1: warning: this is the > >> location of > >> the previous definition > >> In file included from Rgraphviz.c:1: > >> common.h:42:20: gvcint.h: No such file or directory > >> common.h:43:21: globals.h: No such file or directory > >> Rgraphviz.c: In function `getListElement': > >> Rgraphviz.c:51: warning: implicit declaration of function > >> `Rf_type2char' > >> Rgraphviz.c: In function `Rgraphviz_graphvizVersion': > >> Rgraphviz.c:1042: error: dereferencing pointer to incomplete > >> type > >> make: *** [Rgraphviz.o] Error 1 > >> chmod: cannot access > >> `/home/bkp-moghadda/lib/R/library/Rgraphviz/libs/*': No such > >> file or > >> directory > >> ERROR: compilation failed for package 'Rgraphviz' > >> ** Removing '/home/bkp-moghadda/lib/R/library/Rgraphviz' > >> > >> The downloaded packages are in > >> /tmp/Rtmpmnucc7/downloaded_packages > >> Warning messages: > >> 1: installation of package 'Rgraphviz' had non-zero exit > >> status in: > >> install.packages(pkgs = pkgs, repos = repos, dependencies = > >> dependencies, > >> 2: cannot create HTML package index in: > >> tools:::unix.packages.html(.Library) > >> > >> I would be much appreciated if someone can help me to figure > >> out where > >> the problem is. > >> > >> Regards, > >> Amin. > >> > >> _______________________________________________ > >> Bioconductor mailing list > >> Bioconductor at stat.math.ethz.ch > >> https://stat.ethz.ch/mailman/listinfo/bioconductor > >> Search the archives: > >> http://news.gmane.org/gmane.science.biology.informatics.conductor > >> > > > > _______________________________________________ > > Bioconductor mailing list > > Bioconductor at stat.math.ethz.ch > > https://stat.ethz.ch/mailman/listinfo/bioconductor > > Search the archives: > > http://news.gmane.org/gmane.science.biology.informatics.conductor > > >
rgraphviz • 730 views
ADD COMMENTlink modified 12.1 years ago by Li.Long@isb-sib.ch510 • written 12.1 years ago by Amin Moghaddasi130
Answer: Rgraphviz installation problem on " chmod: cannot access '~/library/Rgraphviz/li
0
gravatar for Li.Long@isb-sib.ch
12.1 years ago by
Li.Long@isb-sib.ch510 wrote:
What the codes didn't get right is: GRAPHVIZ_MAJOR and GRAPHVIZ_MINOR in the following line: -------------------------------------------------------------------- gcc -std=gnu99 -I/usr/share/R/include -I/usr/share/R/include -I/usr/lib/graphviz/include/graphviz -DGRAPHVIZ_MAJOR=1453: -DGRAPHVIZ_MINOR=1453: -DHAVE_STDBOOL_H=1 -DHAVE_BOOL=1 -fpic -g -O2 -c agopen.c -o agopen.o -------------------------------------------------------------------- If you installed 2.12, they should be: GRAPHVIZ_MAJOR=2, GRAPHVIZ_MINOR=12. They are derived from running "dot -V" that gives something like: -------------------------------------------------------------------- dot - Graphviz version 2.12 (Fri Dec 15 14:34:55 UTC 2006) -------------------------------------------------------------------- You could try to see if you could run "dot -V" from your graphviz-2.12 installation. I suspect that your installation is incomplete for some reason: you only reference /usr/lib/graphviz, where are the executables? I don't think PKG_CONFIG_PATH is used any more (it doesn't hurt anything for you). I'll update the doc. Li > Dear Li, > Dear All, > > Many thanks for all your suggestions, I have upgraded the R to 2.6 and > tried to install the latest version of Rgraphviz but the problem still > exist and I don't know if it is actually related to bioconductor or > grphviz?? So any advise is appreciated. > > > I have installed : R version 2.6.0, Bioconductor version 2.1, Graphviz > version 2.12-4ubuntu3. > > The environment variable are configured as below : > > $export PKG_CONFIG_PATH="/usr/lib/pkgconfig" > > $whereis graphviz > graphviz: /usr/lib/graphviz /usr/include/graphviz /usr/share/graphviz > /usr/share/man/man7/graphviz.7.gz > > $export LD_LIBRARY_PATH=/usr/lib/graphviz > > $ R CMD INSTALL --configure-args='--with-graphviz=/usr/lib/graphviz' > Rgraphviz_1.16.0.tar.gz > * Installing to library '/home/moghadda/R/library26' > * Installing *source* package 'Rgraphviz' ... > configure: Using user specified graphviz root > directory /usr/lib/graphviz > ./configure: line 1459: test: 1453:: integer expression expected > configure: Found graphviz 1453: > ./configure: line 1481: test: 1453:: integer expression expected > ./configure: line 1481: test: 1453:: integer expression expected > configure: We have inferred the following flags for graphviz > configure: ..PKG_CPPFLAGS=-I/usr/lib/graphviz/include/graphviz > configure: ..PKG_LIBS=-L/usr/lib/graphviz/lib/graphviz > -L/usr/lib/graphviz/lib -lgvc > checking for whether compiler has bool... checking for gcc... gcc > checking for C compiler default output file name... a.out > checking whether the C compiler works... yes > checking whether we are cross compiling... no > checking for suffix of executables... > checking for suffix of object files... o > checking whether we are using the GNU C compiler... yes > checking whether gcc accepts -g... yes > checking for gcc option to accept ANSI C... none needed > checking how to run the C preprocessor... gcc -E > checking for egrep... grep -E > checking for ANSI C header files... yes > checking for sys/types.h... yes > checking for sys/stat.h... yes > checking for stdlib.h... yes > checking for string.h... yes > checking for memory.h... yes > checking for strings.h... yes > checking for inttypes.h... yes > checking for stdint.h... yes > checking for unistd.h... yes > checking for stdbool.h that conforms to C99... yes > checking for _Bool... yes > yes > configure: creating ./config.status > config.status: creating src/Makevars > ** libs > gcc -std=gnu99 -I/usr/share/R/include -I/usr/share/R/include > -I/usr/lib/graphviz/include/graphviz -DGRAPHVIZ_MAJOR=1453: > -DGRAPHVIZ_MINOR=1453: -DHAVE_STDBOOL_H=1 -DHAVE_BOOL=1 -fpic -g > -O2 -c agopen.c -o agopen.o > In file included from agopen.c:1: > common.h:17:5: error: ':' without preceding '?' > In file included from agopen.c:1: > common.h:52: error: expected ???=???, ???,???, ???;???, ???asm??? or > ???__attribute__??? > before ???*??? token > common.h:55:5: error: ':' without preceding '?' > common.h:60: error: expected ???=???, ???,???, ???;???, ???asm??? or > ???__attribute__??? > before ???*??? token > In file included from agopen.c:2: > util.h:18: error: expected ???)??? before ???*??? token > agopen.c:4: error: expected ???=???, ???,???, ???;???, ???asm??? or > ???__attribute__??? > before ???*??? token > agopen.c: In function ???Rgraphviz_agopen???: > agopen.c:54: error: ???Agraph_t??? undeclared (first use in this function) > agopen.c:54: error: (Each undeclared identifier is reported only once > agopen.c:54: error: for each function it appears in.) > agopen.c:54: error: ???g??? undeclared (first use in this function) > agopen.c:54: error: ???tmpGraph??? undeclared (first use in this function) > agopen.c:55: error: ???sgs??? undeclared (first use in this function) > agopen.c:56: error: ???Agnode_t??? undeclared (first use in this function) > agopen.c:56: error: ???head??? undeclared (first use in this function) > agopen.c:56: error: ???tail??? undeclared (first use in this function) > agopen.c:56: error: ???tmp??? undeclared (first use in this function) > agopen.c:57: error: ???Agedge_t??? undeclared (first use in this function) > agopen.c:57: error: ???curEdge??? undeclared (first use in this function) > agopen.c:80: warning: implicit declaration of function ???aginit??? > agopen.c:82: warning: implicit declaration of function ???agopen??? > agopen.c:86: warning: implicit declaration of function > ???setDefaultAttrs??? > agopen.c:89: error: expected expression before ???)??? token > agopen.c:107: warning: implicit declaration of function ???agsubg??? > agopen.c:109: warning: implicit declaration of function ???free??? > agopen.c:118: warning: implicit declaration of function ???agset??? > agopen.c:142: warning: implicit declaration of function ???agnode??? > agopen.c:170: warning: implicit declaration of function ???agfindnode??? > agopen.c:180: warning: implicit declaration of function ???agedge??? > agopen.c:194: warning: implicit declaration of function ???buildRagraph??? > agopen.c:194: warning: return makes pointer from integer without a cast > make: *** [agopen.o] Error 1 > chmod: cannot access `/home/moghadda/R/library26/Rgraphviz/libs/*': No > such file or directory > ERROR: compilation failed for package 'Rgraphviz' > ** Removing '/home/moghadda/R/library26/Rgraphviz' > ** Restoring previous '/home/moghadda/R/library26/Rgraphviz' > > > =================== > >> sessionInfo() > R version 2.6.0 (2007-10-03) > i486-pc-linux-gnu > > locale: > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_ US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_U S.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF -8;LC_IDENTIFICATION=C > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > loaded via a namespace (and not attached): > [1] rcompgen_0.1-17 > > > > Regards, > Amin. > > > > > > > > > > On Fri, 2007-10-19 at 15:40 +0200, Li.Long at isb-sib.ch wrote: >> It's the combination of different version of R/Rgraphviz and graphviz >> that's causing the problem. >> >> graphviz 2.14.1 was released AFTER R 2.4.1 (and its matching >> bioconductor >> release), therefore, the old Rgraphviz doesn't know what to do with the >> newer graphviz. >> >> You could upgrade your R to 2.6.0, along with bioconductor 2.1, its >> matching Rgraphviz handles graphviz 2.14.1. >> >> Or if you have to stick with older version of R/bioconductor, you have >> to >> back port the necessary changes in Rgraphviz to your older version. >> This >> is reported and accomplished already (you could find info in the mail >> archive) >> >> We don't have resource to make all older version of bioconductor >> compatible with newer software releases. >> >> Thanks, >> >> Li >> >> > >> > Dear Tony, >> > Thanks for your quick reply, here is my sessioninfo : >> > >> >> sessionInfo() >> > R version 2.4.1 (2006-12-18) >> > i686-pc-linux-gnu >> > >> > locale: >> > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE= en_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=e n_US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US. UTF-8;LC_IDENTIFICATION=C >> > >> > attached base packages: >> > [1] "stats" "graphics" "grDevices" "utils" "datasets" >> > "methods" >> > [7] "base" >> >> >> > >> > >> > Cheers, >> > Amin. >> > >> > >> > On Fri, 2007-10-19 at 13:46 +0100, Tony Chiang wrote: >> >> Hi Amin, >> >> >> >> Can you please send the list the output of your sessionInfo(). It >> will >> >> help us to try and reproduce the error you get. >> >> >> >> Best, >> >> --Tony >> >> >> >> On 10/19/07, Amin Moghaddasi <a.moghaddasi at="" gmail.com=""> wrote: >> >> Dear All, >> >> >> >> I have some problem installing Rgraphgviz on my system with >> >> the >> >> following specification. >> >> >> >> My system is Suse 9.2 , i386 GNU/Linux >> >> I have installed graphviz-2.14.1 from source >> >> I have gcc version 3.3.4 (pre 3.3.5 20040809) >> >> I also set the LD_LIBRARY_PATH= >> >> $LD_LIBRARY_PATH:/usr/local/lib/graphviz >> >> R version 2.4.1 (2006-12-18) >> >> >> >> 1 - When I try to install from bash command, I'll get the >> >> following >> >> error: >> >> > R CMD INSTALL Rgraphviz_1.5.0.tar.gz >> >> * Installing *source* package 'Rgraphviz' ... >> >> checking for graphviz... checking for dotneato-config... not >> >> found >> >> failed >> >> configure: error: please specify a valid path to >> >> 'dotneato-config' >> >> version >= 1.12 using --with-graphviz=DIR >> >> ERROR: configuration failed for package 'Rgraphviz' >> >> ** Removing '/home/bkp-moghadda/lib/R/library/Rgraphviz' >> >> >> >> 2 - using biocLite in R gives another error: >> >> > source("http://bioconductor.org/biocLite.R") >> >> Warning messages: >> >> 1: Redefining 'biocinstall' in: safeSource() >> >> 2: Redefining 'biocinstall.affyPkgs' in: safeSource() >> >> 3: Redefining 'biocinstall.allPkgs' in: safeSource() >> >> 4: Redefining 'biocinstall.defaultPkgs' in: safeSource() >> >> 5: Redefining 'biocinstall.graphPkgs' in: safeSource() >> >> 6: Redefining 'biocinstall.litePkgs' in: safeSource() >> >> 7: Redefining 'biocinstall.monographPkgs' in: safeSource() >> >> > biocLite("Rgraphviz") >> >> Running biocinstall version 1.9.9 with R version 2.4.1 >> >> Your version of R requires version 1.9 of Bioconductor. >> >> Warning in install.packages(pkgs = pkgs, repos = repos, >> >> dependencies = >> >> dependencies, : >> >> argument 'lib' is missing: >> >> using /home/bkp-moghadda/lib/R/library >> >> trying URL >> >> 'http://bioconductor.org/packages/1.9/bioc/src/contrib/R graphviz_1.12.3.tar.gz' >> >> Content type 'application/x-gzip' length 1504829 bytes >> >> opened URL >> >> ================================================== >> >> downloaded 1469Kb >> >> >> >> * Installing *source* package 'Rgraphviz' ... >> >> checking for pkg-config... /usr/local/bin/pkg-config >> >> configure: Found graphviz 2.14.1 >> >> configure: creating ./config.status >> >> config.status : creating src/Makevars >> >> ** libs >> >> gcc -std=gnu99 -I/usr/lib/R/include -I/usr/lib/R/include >> >> -I/usr/local/include/graphviz -DGRAPHVIZ_MAJOR=2 >> >> -DGRAPHVIZ_MINOR=14 >> >> -I/usr/local/include -fpic -c Rgraphviz.c -o Rgraphviz.o >> >> In file included from /usr/local/include/graphviz/gvc.h:20, >> >> from common.h:38, >> >> from Rgraphviz.c:1: >> >> /usr/local/include/graphviz/types.h:27:1: warning: "TRUE" >> >> redefined >> >> In file included from common.h:8, >> >> from Rgraphviz.c:1: >> >> /usr/lib/R/include/Rdefines.h:148:1: warning: this is the >> >> location of >> >> the previous definition >> >> In file included from Rgraphviz.c:1: >> >> common.h:42:20: gvcint.h: No such file or directory >> >> common.h:43:21: globals.h: No such file or directory >> >> Rgraphviz.c: In function `getListElement': >> >> Rgraphviz.c:51: warning: implicit declaration of function >> >> `Rf_type2char' >> >> Rgraphviz.c: In function `Rgraphviz_graphvizVersion': >> >> Rgraphviz.c:1042: error: dereferencing pointer to incomplete >> >> type >> >> make: *** [Rgraphviz.o] Error 1 >> >> chmod: cannot access >> >> `/home/bkp-moghadda/lib/R/library/Rgraphviz/libs/*': No such >> >> file or >> >> directory >> >> ERROR: compilation failed for package 'Rgraphviz' >> >> ** Removing '/home/bkp-moghadda/lib/R/library/Rgraphviz' >> >> >> >> The downloaded packages are in >> >> /tmp/Rtmpmnucc7/downloaded_packages >> >> Warning messages: >> >> 1: installation of package 'Rgraphviz' had non-zero exit >> >> status in: >> >> install.packages(pkgs = pkgs, repos = repos, dependencies = >> >> dependencies, >> >> 2: cannot create HTML package index in: >> >> tools:::unix.packages.html(.Library) >> >> >> >> I would be much appreciated if someone can help me to figure >> >> out where >> >> the problem is. >> >> >> >> Regards, >> >> Amin. >> >> >> >> _______________________________________________ >> >> Bioconductor mailing list >> >> Bioconductor at stat.math.ethz.ch >> >> https://stat.ethz.ch/mailman/listinfo/bioconductor >> >> Search the archives: >> >> http://news.gmane.org/gmane.science.biology.informatics.conductor >> >> >> > >> > _______________________________________________ >> > Bioconductor mailing list >> > Bioconductor at stat.math.ethz.ch >> > https://stat.ethz.ch/mailman/listinfo/bioconductor >> > Search the archives: >> > http://news.gmane.org/gmane.science.biology.informatics.conductor >> > >> >
ADD COMMENTlink written 12.1 years ago by Li.Long@isb-sib.ch510
Hi Li, The "dot -V" gives the following response for me as well. $ dot -V dot - Graphviz version 2.12 (Tue Sep 4 16:56:48 UTC 2007) $ which dot /usr/bin/dot $ which dotty /usr/bin/dotty $ which neato /usr/bin/neato $ which twopi /usr/bin/twopi I have also took the pkg_conf_path out of the env variables, however the error still there. Best Regards, Amin. On Fri, 2007-11-02 at 17:29 +0100, Li.Long at isb-sib.ch wrote: > What the codes didn't get right is: GRAPHVIZ_MAJOR and GRAPHVIZ_MINOR in > the following line: > > -------------------------------------------------------------------- > gcc -std=gnu99 -I/usr/share/R/include -I/usr/share/R/include > -I/usr/lib/graphviz/include/graphviz -DGRAPHVIZ_MAJOR=1453: > -DGRAPHVIZ_MINOR=1453: -DHAVE_STDBOOL_H=1 -DHAVE_BOOL=1 -fpic -g > -O2 -c agopen.c -o agopen.o > -------------------------------------------------------------------- > > If you installed 2.12, they should be: GRAPHVIZ_MAJOR=2, GRAPHVIZ_MINOR=12. > They are derived from running "dot -V" that gives something like: > > -------------------------------------------------------------------- > dot - Graphviz version 2.12 (Fri Dec 15 14:34:55 UTC 2006) > -------------------------------------------------------------------- > > You could try to see if you could run "dot -V" from your graphviz-2.12 > installation. I suspect that your installation is incomplete for some > reason: you only reference /usr/lib/graphviz, where are the executables? > > I don't think PKG_CONFIG_PATH is used any more (it doesn't hurt anything > for you). I'll update the doc. > > Li > > > Dear Li, > > Dear All, > > > > Many thanks for all your suggestions, I have upgraded the R to 2.6 and > > tried to install the latest version of Rgraphviz but the problem still > > exist and I don't know if it is actually related to bioconductor or > > grphviz?? So any advise is appreciated. > > > > > > I have installed : R version 2.6.0, Bioconductor version 2.1, Graphviz > > version 2.12-4ubuntu3. > > > > The environment variable are configured as below : > > > > $export PKG_CONFIG_PATH="/usr/lib/pkgconfig" > > > > $whereis graphviz > > graphviz: /usr/lib/graphviz /usr/include/graphviz /usr/share/graphviz > > /usr/share/man/man7/graphviz.7.gz > > > > $export LD_LIBRARY_PATH=/usr/lib/graphviz > > > > $ R CMD INSTALL --configure-args='--with- graphviz=/usr/lib/graphviz' > > Rgraphviz_1.16.0.tar.gz > > * Installing to library '/home/moghadda/R/library26' > > * Installing *source* package 'Rgraphviz' ... > > configure: Using user specified graphviz root > > directory /usr/lib/graphviz > > ./configure: line 1459: test: 1453:: integer expression expected > > configure: Found graphviz 1453: > > ./configure: line 1481: test: 1453:: integer expression expected > > ./configure: line 1481: test: 1453:: integer expression expected > > configure: We have inferred the following flags for graphviz > > configure: ..PKG_CPPFLAGS=-I/usr/lib/graphviz/include/graphviz > > configure: ..PKG_LIBS=-L/usr/lib/graphviz/lib/graphviz > > -L/usr/lib/graphviz/lib -lgvc > > checking for whether compiler has bool... checking for gcc... gcc > > checking for C compiler default output file name... a.out > > checking whether the C compiler works... yes > > checking whether we are cross compiling... no > > checking for suffix of executables... > > checking for suffix of object files... o > > checking whether we are using the GNU C compiler... yes > > checking whether gcc accepts -g... yes > > checking for gcc option to accept ANSI C... none needed > > checking how to run the C preprocessor... gcc -E > > checking for egrep... grep -E > > checking for ANSI C header files... yes > > checking for sys/types.h... yes > > checking for sys/stat.h... yes > > checking for stdlib.h... yes > > checking for string.h... yes > > checking for memory.h... yes > > checking for strings.h... yes > > checking for inttypes.h... yes > > checking for stdint.h... yes > > checking for unistd.h... yes > > checking for stdbool.h that conforms to C99... yes > > checking for _Bool... yes > > yes > > configure: creating ./config.status > > config.status: creating src/Makevars > > ** libs > > gcc -std=gnu99 -I/usr/share/R/include -I/usr/share/R/include > > -I/usr/lib/graphviz/include/graphviz -DGRAPHVIZ_MAJOR=1453: > > -DGRAPHVIZ_MINOR=1453: -DHAVE_STDBOOL_H=1 -DHAVE_BOOL=1 -fpic -g > > -O2 -c agopen.c -o agopen.o > > In file included from agopen.c:1: > > common.h:17:5: error: ':' without preceding '?' > > In file included from agopen.c:1: > > common.h:52: error: expected ???=???, ???,???, ???;???, ???asm??? or > > ???__attribute__??? > > before ???*??? token > > common.h:55:5: error: ':' without preceding '?' > > common.h:60: error: expected ???=???, ???,???, ???;???, ???asm??? or > > ???__attribute__??? > > before ???*??? token > > In file included from agopen.c:2: > > util.h:18: error: expected ???)??? before ???*??? token > > agopen.c:4: error: expected ???=???, ???,???, ???;???, ???asm??? or > > ???__attribute__??? > > before ???*??? token > > agopen.c: In function ???Rgraphviz_agopen???: > > agopen.c:54: error: ???Agraph_t??? undeclared (first use in this function) > > agopen.c:54: error: (Each undeclared identifier is reported only once > > agopen.c:54: error: for each function it appears in.) > > agopen.c:54: error: ???g??? undeclared (first use in this function) > > agopen.c:54: error: ???tmpGraph??? undeclared (first use in this function) > > agopen.c:55: error: ???sgs??? undeclared (first use in this function) > > agopen.c:56: error: ???Agnode_t??? undeclared (first use in this function) > > agopen.c:56: error: ???head??? undeclared (first use in this function) > > agopen.c:56: error: ???tail??? undeclared (first use in this function) > > agopen.c:56: error: ???tmp??? undeclared (first use in this function) > > agopen.c:57: error: ???Agedge_t??? undeclared (first use in this function) > > agopen.c:57: error: ???curEdge??? undeclared (first use in this function) > > agopen.c:80: warning: implicit declaration of function ???aginit??? > > agopen.c:82: warning: implicit declaration of function ???agopen??? > > agopen.c:86: warning: implicit declaration of function > > ???setDefaultAttrs??? > > agopen.c:89: error: expected expression before ???)??? token > > agopen.c:107: warning: implicit declaration of function ???agsubg??? > > agopen.c:109: warning: implicit declaration of function ???free??? > > agopen.c:118: warning: implicit declaration of function ???agset??? > > agopen.c:142: warning: implicit declaration of function ???agnode??? > > agopen.c:170: warning: implicit declaration of function ???agfindnode??? > > agopen.c:180: warning: implicit declaration of function ???agedge??? > > agopen.c:194: warning: implicit declaration of function ???buildRagraph??? > > agopen.c:194: warning: return makes pointer from integer without a cast > > make: *** [agopen.o] Error 1 > > chmod: cannot access `/home/moghadda/R/library26/Rgraphviz/libs/*': No > > such file or directory > > ERROR: compilation failed for package 'Rgraphviz' > > ** Removing '/home/moghadda/R/library26/Rgraphviz' > > ** Restoring previous '/home/moghadda/R/library26/Rgraphviz' > > > > > > =================== > > > >> sessionInfo() > > R version 2.6.0 (2007-10-03) > > i486-pc-linux-gnu > > > > locale: > > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=e n_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en _US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.U TF-8;LC_IDENTIFICATION=C > > > > attached base packages: > > [1] stats graphics grDevices utils datasets methods base > > > > loaded via a namespace (and not attached): > > [1] rcompgen_0.1-17 > > > > > > > > Regards, > > Amin. > > > > > > > > > > > > > > > > > > > > On Fri, 2007-10-19 at 15:40 +0200, Li.Long at isb-sib.ch wrote: > >> It's the combination of different version of R/Rgraphviz and graphviz > >> that's causing the problem. > >> > >> graphviz 2.14.1 was released AFTER R 2.4.1 (and its matching > >> bioconductor > >> release), therefore, the old Rgraphviz doesn't know what to do with the > >> newer graphviz. > >> > >> You could upgrade your R to 2.6.0, along with bioconductor 2.1, its > >> matching Rgraphviz handles graphviz 2.14.1. > >> > >> Or if you have to stick with older version of R/bioconductor, you have > >> to > >> back port the necessary changes in Rgraphviz to your older version. > >> This > >> is reported and accomplished already (you could find info in the mail > >> archive) > >> > >> We don't have resource to make all older version of bioconductor > >> compatible with newer software releases. > >> > >> Thanks, > >> > >> Li > >> > >> > > >> > Dear Tony, > >> > Thanks for your quick reply, here is my sessioninfo : > >> > > >> >> sessionInfo() > >> > R version 2.4.1 (2006-12-18) > >> > i686-pc-linux-gnu > >> > > >> > locale: > >> > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLAT E=en_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER =en_US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_U S.UTF-8;LC_IDENTIFICATION=C > >> > > >> > attached base packages: > >> > [1] "stats" "graphics" "grDevices" "utils" "datasets" > >> > "methods" > >> > [7] "base" > >> >> > >> > > >> > > >> > Cheers, > >> > Amin. > >> > > >> > > >> > On Fri, 2007-10-19 at 13:46 +0100, Tony Chiang wrote: > >> >> Hi Amin, > >> >> > >> >> Can you please send the list the output of your sessionInfo(). It > >> will > >> >> help us to try and reproduce the error you get. > >> >> > >> >> Best, > >> >> --Tony > >> >> > >> >> On 10/19/07, Amin Moghaddasi <a.moghaddasi at="" gmail.com=""> wrote: > >> >> Dear All, > >> >> > >> >> I have some problem installing Rgraphgviz on my system with > >> >> the > >> >> following specification. > >> >> > >> >> My system is Suse 9.2 , i386 GNU/Linux > >> >> I have installed graphviz-2.14.1 from source > >> >> I have gcc version 3.3.4 (pre 3.3.5 20040809) > >> >> I also set the LD_LIBRARY_PATH= > >> >> $LD_LIBRARY_PATH:/usr/local/lib/graphviz > >> >> R version 2.4.1 (2006-12-18) > >> >> > >> >> 1 - When I try to install from bash command, I'll get the > >> >> following > >> >> error: > >> >> > R CMD INSTALL Rgraphviz_1.5.0.tar.gz > >> >> * Installing *source* package 'Rgraphviz' ... > >> >> checking for graphviz... checking for dotneato- config... not > >> >> found > >> >> failed > >> >> configure: error: please specify a valid path to > >> >> 'dotneato-config' > >> >> version >= 1.12 using --with-graphviz=DIR > >> >> ERROR: configuration failed for package 'Rgraphviz' > >> >> ** Removing '/home/bkp- moghadda/lib/R/library/Rgraphviz' > >> >> > >> >> 2 - using biocLite in R gives another error: > >> >> > source("http://bioconductor.org/biocLite.R") > >> >> Warning messages: > >> >> 1: Redefining 'biocinstall' in: safeSource() > >> >> 2: Redefining 'biocinstall.affyPkgs' in: safeSource() > >> >> 3: Redefining 'biocinstall.allPkgs' in: safeSource() > >> >> 4: Redefining 'biocinstall.defaultPkgs' in: safeSource() > >> >> 5: Redefining 'biocinstall.graphPkgs' in: safeSource() > >> >> 6: Redefining 'biocinstall.litePkgs' in: safeSource() > >> >> 7: Redefining 'biocinstall.monographPkgs' in: safeSource() > >> >> > biocLite("Rgraphviz") > >> >> Running biocinstall version 1.9.9 with R version 2.4.1 > >> >> Your version of R requires version 1.9 of Bioconductor. > >> >> Warning in install.packages(pkgs = pkgs, repos = repos, > >> >> dependencies = > >> >> dependencies, : > >> >> argument 'lib' is missing: > >> >> using /home/bkp-moghadda/lib/R/library > >> >> trying URL > >> >> 'http://bioconductor.org/packages/1.9/bioc/src/contrib /Rgraphviz_1.12.3.tar.gz' > >> >> Content type 'application/x-gzip' length 1504829 bytes > >> >> opened URL > >> >> ================================================== > >> >> downloaded 1469Kb > >> >> > >> >> * Installing *source* package 'Rgraphviz' ... > >> >> checking for pkg-config... /usr/local/bin/pkg-config > >> >> configure: Found graphviz 2.14.1 > >> >> configure: creating ./config.status > >> >> config.status : creating src/Makevars > >> >> ** libs > >> >> gcc -std=gnu99 -I/usr/lib/R/include -I/usr/lib/R/include > >> >> -I/usr/local/include/graphviz -DGRAPHVIZ_MAJOR=2 > >> >> -DGRAPHVIZ_MINOR=14 > >> >> -I/usr/local/include -fpic -c Rgraphviz.c -o Rgraphviz.o > >> >> In file included from /usr/local/include/graphviz/gvc.h:20, > >> >> from common.h:38, > >> >> from Rgraphviz.c:1: > >> >> /usr/local/include/graphviz/types.h:27:1: warning: "TRUE" > >> >> redefined > >> >> In file included from common.h:8, > >> >> from Rgraphviz.c:1: > >> >> /usr/lib/R/include/Rdefines.h:148:1: warning: this is the > >> >> location of > >> >> the previous definition > >> >> In file included from Rgraphviz.c:1: > >> >> common.h:42:20: gvcint.h: No such file or directory > >> >> common.h:43:21: globals.h: No such file or directory > >> >> Rgraphviz.c: In function `getListElement': > >> >> Rgraphviz.c:51: warning: implicit declaration of function > >> >> `Rf_type2char' > >> >> Rgraphviz.c: In function `Rgraphviz_graphvizVersion': > >> >> Rgraphviz.c:1042: error: dereferencing pointer to incomplete > >> >> type > >> >> make: *** [Rgraphviz.o] Error 1 > >> >> chmod: cannot access > >> >> `/home/bkp-moghadda/lib/R/library/Rgraphviz/libs/*': No such > >> >> file or > >> >> directory > >> >> ERROR: compilation failed for package 'Rgraphviz' > >> >> ** Removing '/home/bkp- moghadda/lib/R/library/Rgraphviz' > >> >> > >> >> The downloaded packages are in > >> >> /tmp/Rtmpmnucc7/downloaded_packages > >> >> Warning messages: > >> >> 1: installation of package 'Rgraphviz' had non-zero exit > >> >> status in: > >> >> install.packages(pkgs = pkgs, repos = repos, dependencies = > >> >> dependencies, > >> >> 2: cannot create HTML package index in: > >> >> tools:::unix.packages.html(.Library) > >> >> > >> >> I would be much appreciated if someone can help me to figure > >> >> out where > >> >> the problem is. > >> >> > >> >> Regards, > >> >> Amin. > >> >> > >> >> _______________________________________________ > >> >> Bioconductor mailing list > >> >> Bioconductor at stat.math.ethz.ch > >> >> https://stat.ethz.ch/mailman/listinfo/bioconductor > >> >> Search the archives: > >> >> http://news.gmane.org/gmane.science.biology.informatics.conductor > >> >> > >> > > >> > _______________________________________________ > >> > Bioconductor mailing list > >> > Bioconductor at stat.math.ethz.ch > >> > https://stat.ethz.ch/mailman/listinfo/bioconductor > >> > Search the archives: > >> > http://news.gmane.org/gmane.science.biology.informatics.conductor > >> > > >> > > >
ADD REPLYlink written 12.1 years ago by Amin Moghaddasi130
Hi Li, Many thanks for your advises. According to your suggestions, I have modified the --configure-args='--with-graphviz=/usr/lib/graphviz' to look into executables in "/usr" instead, and it did the job. $ R CMD INSTALL Rgraphviz_1.16.0.tar.gz --configure-args='--with-graphviz=/usr' Thanks again, Amin. > On Fri, 2007-11-02 at 17:29 +0100, Li.Long at isb-sib.ch wrote: > > What the codes didn't get right is: GRAPHVIZ_MAJOR and GRAPHVIZ_MINOR in > > the following line: > > > > -------------------------------------------------------------------- > > gcc -std=gnu99 -I/usr/share/R/include -I/usr/share/R/include > > -I/usr/lib/graphviz/include/graphviz -DGRAPHVIZ_MAJOR=1453: > > -DGRAPHVIZ_MINOR=1453: -DHAVE_STDBOOL_H=1 -DHAVE_BOOL=1 -fpic -g > > -O2 -c agopen.c -o agopen.o > > -------------------------------------------------------------------- > > > > If you installed 2.12, they should be: GRAPHVIZ_MAJOR=2, GRAPHVIZ_MINOR=12. > > They are derived from running "dot -V" that gives something like: > > > > -------------------------------------------------------------------- > > dot - Graphviz version 2.12 (Fri Dec 15 14:34:55 UTC 2006) > > -------------------------------------------------------------------- > > > > You could try to see if you could run "dot -V" from your graphviz-2.12 > > installation. I suspect that your installation is incomplete for some > > reason: you only reference /usr/lib/graphviz, where are the executables? > > > > I don't think PKG_CONFIG_PATH is used any more (it doesn't hurt anything > > for you). I'll update the doc. > > > > Li > > > > > Dear Li, > > > Dear All, > > > > > > Many thanks for all your suggestions, I have upgraded the R to 2.6 and > > > tried to install the latest version of Rgraphviz but the problem still > > > exist and I don't know if it is actually related to bioconductor or > > > grphviz?? So any advise is appreciated. > > > > > > > > > I have installed : R version 2.6.0, Bioconductor version 2.1, Graphviz > > > version 2.12-4ubuntu3. > > > > > > The environment variable are configured as below : > > > > > > $export PKG_CONFIG_PATH="/usr/lib/pkgconfig" > > > > > > $whereis graphviz > > > graphviz: /usr/lib/graphviz /usr/include/graphviz /usr/share/graphviz > > > /usr/share/man/man7/graphviz.7.gz > > > > > > $export LD_LIBRARY_PATH=/usr/lib/graphviz > > > > > > $ R CMD INSTALL --configure-args='--with- graphviz=/usr/lib/graphviz' > > > Rgraphviz_1.16.0.tar.gz > > > * Installing to library '/home/moghadda/R/library26' > > > * Installing *source* package 'Rgraphviz' ... > > > configure: Using user specified graphviz root > > > directory /usr/lib/graphviz > > > ./configure: line 1459: test: 1453:: integer expression expected > > > configure: Found graphviz 1453: > > > ./configure: line 1481: test: 1453:: integer expression expected > > > ./configure: line 1481: test: 1453:: integer expression expected > > > configure: We have inferred the following flags for graphviz > > > configure: ..PKG_CPPFLAGS=-I/usr/lib/graphviz/include/graphviz > > > configure: ..PKG_LIBS=-L/usr/lib/graphviz/lib/graphviz > > > -L/usr/lib/graphviz/lib -lgvc > > > checking for whether compiler has bool... checking for gcc... gcc > > > checking for C compiler default output file name... a.out > > > checking whether the C compiler works... yes > > > checking whether we are cross compiling... no > > > checking for suffix of executables... > > > checking for suffix of object files... o > > > checking whether we are using the GNU C compiler... yes > > > checking whether gcc accepts -g... yes > > > checking for gcc option to accept ANSI C... none needed > > > checking how to run the C preprocessor... gcc -E > > > checking for egrep... grep -E > > > checking for ANSI C header files... yes > > > checking for sys/types.h... yes > > > checking for sys/stat.h... yes > > > checking for stdlib.h... yes > > > checking for string.h... yes > > > checking for memory.h... yes > > > checking for strings.h... yes > > > checking for inttypes.h... yes > > > checking for stdint.h... yes > > > checking for unistd.h... yes > > > checking for stdbool.h that conforms to C99... yes > > > checking for _Bool... yes > > > yes > > > configure: creating ./config.status > > > config.status: creating src/Makevars > > > ** libs > > > gcc -std=gnu99 -I/usr/share/R/include -I/usr/share/R/include > > > -I/usr/lib/graphviz/include/graphviz -DGRAPHVIZ_MAJOR=1453: > > > -DGRAPHVIZ_MINOR=1453: -DHAVE_STDBOOL_H=1 -DHAVE_BOOL=1 -fpic -g > > > -O2 -c agopen.c -o agopen.o > > > In file included from agopen.c:1: > > > common.h:17:5: error: ':' without preceding '?' > > > In file included from agopen.c:1: > > > common.h:52: error: expected ???=???, ???,???, ???;???, ???asm??? or > > > ???__attribute__??? > > > before ???*??? token > > > common.h:55:5: error: ':' without preceding '?' > > > common.h:60: error: expected ???=???, ???,???, ???;???, ???asm??? or > > > ???__attribute__??? > > > before ???*??? token > > > In file included from agopen.c:2: > > > util.h:18: error: expected ???)??? before ???*??? token > > > agopen.c:4: error: expected ???=???, ???,???, ???;???, ???asm??? or > > > ???__attribute__??? > > > before ???*??? token > > > agopen.c: In function ???Rgraphviz_agopen???: > > > agopen.c:54: error: ???Agraph_t??? undeclared (first use in this function) > > > agopen.c:54: error: (Each undeclared identifier is reported only once > > > agopen.c:54: error: for each function it appears in.) > > > agopen.c:54: error: ???g??? undeclared (first use in this function) > > > agopen.c:54: error: ???tmpGraph??? undeclared (first use in this function) > > > agopen.c:55: error: ???sgs??? undeclared (first use in this function) > > > agopen.c:56: error: ???Agnode_t??? undeclared (first use in this function) > > > agopen.c:56: error: ???head??? undeclared (first use in this function) > > > agopen.c:56: error: ???tail??? undeclared (first use in this function) > > > agopen.c:56: error: ???tmp??? undeclared (first use in this function) > > > agopen.c:57: error: ???Agedge_t??? undeclared (first use in this function) > > > agopen.c:57: error: ???curEdge??? undeclared (first use in this function) > > > agopen.c:80: warning: implicit declaration of function ???aginit??? > > > agopen.c:82: warning: implicit declaration of function ???agopen??? > > > agopen.c:86: warning: implicit declaration of function > > > ???setDefaultAttrs??? > > > agopen.c:89: error: expected expression before ???)??? token > > > agopen.c:107: warning: implicit declaration of function ???agsubg??? > > > agopen.c:109: warning: implicit declaration of function ???free??? > > > agopen.c:118: warning: implicit declaration of function ???agset??? > > > agopen.c:142: warning: implicit declaration of function ???agnode??? > > > agopen.c:170: warning: implicit declaration of function ???agfindnode??? > > > agopen.c:180: warning: implicit declaration of function ???agedge??? > > > agopen.c:194: warning: implicit declaration of function ???buildRagraph??? > > > agopen.c:194: warning: return makes pointer from integer without a cast > > > make: *** [agopen.o] Error 1 > > > chmod: cannot access `/home/moghadda/R/library26/Rgraphviz/libs/*': No > > > such file or directory > > > ERROR: compilation failed for package 'Rgraphviz' > > > ** Removing '/home/moghadda/R/library26/Rgraphviz' > > > ** Restoring previous '/home/moghadda/R/library26/Rgraphviz' > > > > > > > > > =================== > > > > > >> sessionInfo() > > > R version 2.6.0 (2007-10-03) > > > i486-pc-linux-gnu > > > > > > locale: > > > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE =en_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER= en_US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US .UTF-8;LC_IDENTIFICATION=C > > > > > > attached base packages: > > > [1] stats graphics grDevices utils datasets methods base > > > > > > loaded via a namespace (and not attached): > > > [1] rcompgen_0.1-17 > > > > > > > > > > > > Regards, > > > Amin. > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > On Fri, 2007-10-19 at 15:40 +0200, Li.Long at isb-sib.ch wrote: > > >> It's the combination of different version of R/Rgraphviz and graphviz > > >> that's causing the problem. > > >> > > >> graphviz 2.14.1 was released AFTER R 2.4.1 (and its matching > > >> bioconductor > > >> release), therefore, the old Rgraphviz doesn't know what to do with the > > >> newer graphviz. > > >> > > >> You could upgrade your R to 2.6.0, along with bioconductor 2.1, its > > >> matching Rgraphviz handles graphviz 2.14.1. > > >> > > >> Or if you have to stick with older version of R/bioconductor, you have > > >> to > > >> back port the necessary changes in Rgraphviz to your older version. > > >> This > > >> is reported and accomplished already (you could find info in the mail > > >> archive) > > >> > > >> We don't have resource to make all older version of bioconductor > > >> compatible with newer software releases. > > >> > > >> Thanks, > > >> > > >> Li > > >> > > >> > > > >> > Dear Tony, > > >> > Thanks for your quick reply, here is my sessioninfo : > > >> > > > >> >> sessionInfo() > > >> > R version 2.4.1 (2006-12-18) > > >> > i686-pc-linux-gnu > > >> > > > >> > locale: > > >> > LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLL ATE=en_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAP ER=en_US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en _US.UTF-8;LC_IDENTIFICATION=C > > >> > > > >> > attached base packages: > > >> > [1] "stats" "graphics" "grDevices" "utils" "datasets" > > >> > "methods" > > >> > [7] "base" > > >> >> > > >> > > > >> > > > >> > Cheers, > > >> > Amin. > > >> > > > >> > > > >> > On Fri, 2007-10-19 at 13:46 +0100, Tony Chiang wrote: > > >> >> Hi Amin, > > >> >> > > >> >> Can you please send the list the output of your sessionInfo(). It > > >> will > > >> >> help us to try and reproduce the error you get. > > >> >> > > >> >> Best, > > >> >> --Tony > > >> >> > > >> >> On 10/19/07, Amin Moghaddasi <a.moghaddasi at="" gmail.com=""> wrote: > > >> >> Dear All, > > >> >> > > >> >> I have some problem installing Rgraphgviz on my system with > > >> >> the > > >> >> following specification. > > >> >> > > >> >> My system is Suse 9.2 , i386 GNU/Linux > > >> >> I have installed graphviz-2.14.1 from source > > >> >> I have gcc version 3.3.4 (pre 3.3.5 20040809) > > >> >> I also set the LD_LIBRARY_PATH= > > >> >> $LD_LIBRARY_PATH:/usr/local/lib/graphviz > > >> >> R version 2.4.1 (2006-12-18) > > >> >> > > >> >> 1 - When I try to install from bash command, I'll get the > > >> >> following > > >> >> error: > > >> >> > R CMD INSTALL Rgraphviz_1.5.0.tar.gz > > >> >> * Installing *source* package 'Rgraphviz' ... > > >> >> checking for graphviz... checking for dotneato- config... not > > >> >> found > > >> >> failed > > >> >> configure: error: please specify a valid path to > > >> >> 'dotneato-config' > > >> >> version >= 1.12 using --with-graphviz=DIR > > >> >> ERROR: configuration failed for package 'Rgraphviz' > > >> >> ** Removing '/home/bkp- moghadda/lib/R/library/Rgraphviz' > > >> >> > > >> >> 2 - using biocLite in R gives another error: > > >> >> > source("http://bioconductor.org/biocLite.R") > > >> >> Warning messages: > > >> >> 1: Redefining 'biocinstall' in: safeSource() > > >> >> 2: Redefining 'biocinstall.affyPkgs' in: safeSource() > > >> >> 3: Redefining 'biocinstall.allPkgs' in: safeSource() > > >> >> 4: Redefining 'biocinstall.defaultPkgs' in: safeSource() > > >> >> 5: Redefining 'biocinstall.graphPkgs' in: safeSource() > > >> >> 6: Redefining 'biocinstall.litePkgs' in: safeSource() > > >> >> 7: Redefining 'biocinstall.monographPkgs' in: safeSource() > > >> >> > biocLite("Rgraphviz") > > >> >> Running biocinstall version 1.9.9 with R version 2.4.1 > > >> >> Your version of R requires version 1.9 of Bioconductor. > > >> >> Warning in install.packages(pkgs = pkgs, repos = repos, > > >> >> dependencies = > > >> >> dependencies, : > > >> >> argument 'lib' is missing: > > >> >> using /home/bkp-moghadda/lib/R/library > > >> >> trying URL > > >> >> 'http://bioconductor.org/packages/1.9/bioc/src/contr ib/Rgraphviz_1.12.3.tar.gz' > > >> >> Content type 'application/x-gzip' length 1504829 bytes > > >> >> opened URL > > >> >> ================================================== > > >> >> downloaded 1469Kb > > >> >> > > >> >> * Installing *source* package 'Rgraphviz' ... > > >> >> checking for pkg-config... /usr/local/bin/pkg-config > > >> >> configure: Found graphviz 2.14.1 > > >> >> configure: creating ./config.status > > >> >> config.status : creating src/Makevars > > >> >> ** libs > > >> >> gcc -std=gnu99 -I/usr/lib/R/include -I/usr/lib/R/include > > >> >> -I/usr/local/include/graphviz -DGRAPHVIZ_MAJOR=2 > > >> >> -DGRAPHVIZ_MINOR=14 > > >> >> -I/usr/local/include -fpic -c Rgraphviz.c -o Rgraphviz.o > > >> >> In file included from /usr/local/include/graphviz/gvc.h:20, > > >> >> from common.h:38, > > >> >> from Rgraphviz.c:1: > > >> >> /usr/local/include/graphviz/types.h:27:1: warning: "TRUE" > > >> >> redefined > > >> >> In file included from common.h:8, > > >> >> from Rgraphviz.c:1: > > >> >> /usr/lib/R/include/Rdefines.h:148:1: warning: this is the > > >> >> location of > > >> >> the previous definition > > >> >> In file included from Rgraphviz.c:1: > > >> >> common.h:42:20: gvcint.h: No such file or directory > > >> >> common.h:43:21: globals.h: No such file or directory > > >> >> Rgraphviz.c: In function `getListElement': > > >> >> Rgraphviz.c:51: warning: implicit declaration of function > > >> >> `Rf_type2char' > > >> >> Rgraphviz.c: In function `Rgraphviz_graphvizVersion': > > >> >> Rgraphviz.c:1042: error: dereferencing pointer to incomplete > > >> >> type > > >> >> make: *** [Rgraphviz.o] Error 1 > > >> >> chmod: cannot access > > >> >> `/home/bkp-moghadda/lib/R/library/Rgraphviz/libs/*': No such > > >> >> file or > > >> >> directory > > >> >> ERROR: compilation failed for package 'Rgraphviz' > > >> >> ** Removing '/home/bkp- moghadda/lib/R/library/Rgraphviz' > > >> >> > > >> >> The downloaded packages are in > > >> >> /tmp/Rtmpmnucc7/downloaded_packages > > >> >> Warning messages: > > >> >> 1: installation of package 'Rgraphviz' had non-zero exit > > >> >> status in: > > >> >> install.packages(pkgs = pkgs, repos = repos, dependencies = > > >> >> dependencies, > > >> >> 2: cannot create HTML package index in: > > >> >> tools:::unix.packages.html(.Library) > > >> >> > > >> >> I would be much appreciated if someone can help me to figure > > >> >> out where > > >> >> the problem is. > > >> >> > > >> >> Regards, > > >> >> Amin. > > >> >> > > >> >> _______________________________________________ > > >> >> Bioconductor mailing list > > >> >> Bioconductor at stat.math.ethz.ch > > >> >> https://stat.ethz.ch/mailman/listinfo/bioconductor > > >> >> Search the archives: > > >> >> http://news.gmane.org/gmane.science.biology.informatics.conductor > > >> >> > > >> > > > >> > _______________________________________________ > > >> > Bioconductor mailing list > > >> > Bioconductor at stat.math.ethz.ch > > >> > https://stat.ethz.ch/mailman/listinfo/bioconductor > > >> > Search the archives: > > >> > http://news.gmane.org/gmane.science.biology.informatics.conductor > > >> > > > >> > > > > > > >
ADD REPLYlink written 12.1 years ago by Amin Moghaddasi130
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 415 users visited in the last hour