Question: Continued problems with pdInfoBuilder
0
gravatar for Harry Mangalam
10.9 years ago by
Harry Mangalam70 wrote:
Like Rob Dunne previously, I'm trying to use pdInfoBuilder to generate a pkg for the RaGene-1_0-st-v1 series, but am getting the same error that he was finally able to resolve. Unlike him, I am not. R version 2.6.2 (2008-02-08) (from Ubuntu 8.04.1 deb) pdInfoBuilder 1.6.0 > library(pdInfoBuilder) > pgfFile <- "RaGene-1_0-st-v1.r3.pgf" > clfFile <- "RaGene-1_0-st-v1.r3.clf" > transFile <- " RaGene-1_0-st-v1.na26.rn4.transcript.csv" > probeFile <- "RaGene-1_0-st-v1.probe.tab" > pkg <- new("AffyGenePDInfoPkgSeed", author = "hjm", email = "harry.mangalam at uci.edu", version = "0.0.1", genomebuild = "Mon Nov 17 14:23:44 PST 2008",biocViews = "Rat Gene 1.0 ST Array", pgfFile = pgfFile, clfFile = clfFile, transFile = transFile, probeFile = probeFile) Error in getClass(Class, where = topenv(parent.frame())) : "AffyGenePDInfoPkgSeed" is not a defined class Is this a version mismatch or am I missing something more obvious? -- Harry Mangalam - Research Computing, NACS, E2148, Engineering Gateway, UC Irvine 92697 949 824-0084(o), 949 285-4487(c) --- Good judgment comes from experience; Experience comes from bad judgment. [F. Brooks.]
pdinfobuilder • 520 views
ADD COMMENTlink modified 10.9 years ago by Sean Davis21k • written 10.9 years ago by Harry Mangalam70
Answer: Continued problems with pdInfoBuilder
0
gravatar for Sean Davis
10.9 years ago by
Sean Davis21k
United States
Sean Davis21k wrote:
On Mon, Nov 17, 2008 at 7:00 PM, Harry Mangalam <harry.mangalam@uci.edu>wrote: > Like Rob Dunne previously, I'm trying to use pdInfoBuilder to generate > a pkg for the RaGene-1_0-st-v1 series, but am getting the same error > that he was finally able to resolve. Unlike him, I am not. > > R version 2.6.2 (2008-02-08) (from Ubuntu 8.04.1 deb) > pdInfoBuilder 1.6.0 > > library(pdInfoBuilder) > > pgfFile <- "RaGene-1_0-st-v1.r3.pgf" > > clfFile <- "RaGene-1_0-st-v1.r3.clf" > > transFile <- " RaGene-1_0-st-v1.na26.rn4.transcript.csv" > > probeFile <- "RaGene-1_0-st-v1.probe.tab" > > pkg <- new("AffyGenePDInfoPkgSeed", author = "hjm", email > = "harry.mangalam@uci.edu", version = "0.0.1", genomebuild = "Mon Nov > 17 14:23:44 PST 2008",biocViews = "Rat Gene 1.0 ST Array", pgfFile = > pgfFile, clfFile = clfFile, transFile = transFile, probeFile = > probeFile) > Error in getClass(Class, where = topenv(parent.frame())) : > "AffyGenePDInfoPkgSeed" is not a defined class > > Is this a version mismatch or am I missing something more obvious? > Hi, Harry. The oligo package and associates has changed very significantly since R-2.6.2. I would suggest upgrading to the current version of R and re-installing bioconductor. As for the direct question as to whether or not this is a version mismatch, it is not possible to say without the output of sessionInfo(), but I would guess that it is. Hope that helps, Sean [[alternative HTML version deleted]]
ADD COMMENTlink written 10.9 years ago by Sean Davis21k
Sean Davis wrote: > > > On Mon, Nov 17, 2008 at 7:00 PM, Harry Mangalam > <harry.mangalam at="" uci.edu="" <mailto:harry.mangalam="" at="" uci.edu="">> wrote: > > Like Rob Dunne previously, I'm trying to use pdInfoBuilder to generate > a pkg for the RaGene-1_0-st-v1 series, but am getting the same error > that he was finally able to resolve. Unlike him, I am not. > > R version 2.6.2 (2008-02-08) (from Ubuntu 8.04.1 deb) > pdInfoBuilder 1.6.0 > > library(pdInfoBuilder) > > pgfFile <- "RaGene-1_0-st-v1.r3.pgf" > > clfFile <- "RaGene-1_0-st-v1.r3.clf" > > transFile <- " RaGene-1_0-st-v1.na26.rn4.transcript.csv" > > probeFile <- "RaGene-1_0-st-v1.probe.tab" > > pkg <- new("AffyGenePDInfoPkgSeed", author = "hjm", email > = "harry.mangalam at uci.edu <mailto:harry.mangalam at="" uci.edu="">", > version = "0.0.1", genomebuild = "Mon Nov > 17 14:23:44 PST 2008",biocViews = "Rat Gene 1.0 ST Array", pgfFile = > pgfFile, clfFile = clfFile, transFile = transFile, probeFile = > probeFile) > Error in getClass(Class, where = topenv(parent.frame())) : > "AffyGenePDInfoPkgSeed" is not a defined class > > Is this a version mismatch or am I missing something more obvious? > > > Hi, Harry. The oligo package and associates has changed very > significantly since R-2.6.2. I would suggest upgrading to the current > version of R and re-installing bioconductor. As for the direct > question as to whether or not this is a version mismatch, it is not > possible to say without the output of sessionInfo(), but I would guess > that it is. > > Hope that helps, > Sean > > Hi Harry, I got this to work my upgrading to the development version of R (2.9.0) and the devel version of pdInfoBuilder. Bye Rob -- Rob Dunne Fax: +61 2 9325 3200 Tel: +61 2 9325 3263 CSIRO Mathematical and Information Sciences +61 2 9325 3100 Locked Bag 17, North Ryde, New South Wales, Australia, 1670 http://www.bioinformatics.csiro.au Email: Rob.Dunne at csiro.au Java has certainly revolutionized marketing and litigation.
ADD REPLYlink written 10.9 years ago by Rob Dunne230
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 217 users visited in the last hour