The support.bioconductor.org editor has been updated to markdown! Please see more info at: Tutorial: Updated Support Site Editor

Question: GenomicRanges requires a IRanges version not available in the repository
0
gravatar for Juan L. Mateo
7.0 years ago by
Juan L. Mateo80 wrote:
Hi all, I need to install the package htSeqTools from the BioConductor version 2.10. This package, among others, requires GenomicRanges, but the installation of this last fails because it requires a higher version of IRanges than the one in the repository. The error that I get is below: =================================================================== ... Error : package 'IRanges' 1.13.22 was found, but >= 1.13.23 is required by 'GenomicRanges' ERROR: lazy loading failed for package 'GenomicRanges' * removing '/bwfs/home/grid/mhbw0366/R/x86_64-unknown-linux-gnu- library/2.15/GenomicRanges' The downloaded source packages are in '/tmp/RtmplUtRs3/downloaded_packages' Warning message: In install.packages(pkgs = pkgs, repos = repos, ...) : installation of package 'GenomicRanges' had non-zero exit status =================================================================== sessionInfo() R Under development (unstable) (2012-02-09 r58309) Platform: x86_64-unknown-linux-gnu (64-bit) locale: [1] LC_CTYPE=en_GB LC_NUMERIC=C LC_TIME=en_GB [4] LC_COLLATE=en_GB LC_MONETARY=en_GB LC_MESSAGES=en_GB [7] LC_PAPER=C LC_NAME=C LC_ADDRESS=C [10] LC_TELEPHONE=C LC_MEASUREMENT=en_GB LC_IDENTIFICATION=C attached base packages: [1] stats graphics grDevices utils datasets methods base other attached packages: [1] BiocInstaller_1.3.7 loaded via a namespace (and not attached): [1] tools_2.15.0 -- ============================= Juan L. Mateo PhD. Centre for Organismal Studies (COS) - University of Heidelberg Im Neuenheimer Feld 230 69120 Heidelberg, Germany Tel: 0049 (0)6221 54 6493 Fax: 0049 (0)6221 54 5639 -- ============================= Juan L. Mateo PhD. Centre for Organismal Studies (COS) - University of Heidelberg Im Neuenheimer Feld 230 69120 Heidelberg, Germany Tel: 0049 (0)6221 54 6493 Fax: 0049 (0)6221 54 5639
genomicranges htseqtools • 844 views
ADD COMMENTlink modified 7.0 years ago by Vincent J. Carey, Jr.6.3k • written 7.0 years ago by Juan L. Mateo80
Answer: GenomicRanges requires a IRanges version not available in the repository
0
gravatar for Vincent J. Carey, Jr.
7.0 years ago by
United States
Vincent J. Carey, Jr.6.3k wrote:
This can happen from time to time in the devel branch. One solution is to obtain the source via svn and install manually. See http://wiki.fhcrc.org/bioc/SvnHowTo I have verified that the 1.13.24 will install from source on a linux platform. On Mon, Feb 13, 2012 at 6:24 AM, Juan L. Mateo < juan.mateo@cos.uni-heidelberg.de> wrote: > Hi all, > > I need to install the package htSeqTools from the BioConductor version > 2.10. This package, among others, requires GenomicRanges, but the > installation of this last fails because it requires a higher version of > IRanges than the one in the repository. > > The error that I get is below: > > ==============================**==============================**==== === > ... > Error : package 'IRanges' 1.13.22 was found, but >= 1.13.23 is required by > 'GenomicRanges' > ERROR: lazy loading failed for package 'GenomicRanges' > * removing '/bwfs/home/grid/mhbw0366/R/**x86_64-unknown-linux-gnu-** > library/2.15/GenomicRanges' > > The downloaded source packages are in > '/tmp/RtmplUtRs3/downloaded_**packages' > Warning message: > In install.packages(pkgs = pkgs, repos = repos, ...) : > installation of package 'GenomicRanges' had non-zero exit status > ==============================**==============================**==== === > > > sessionInfo() > > > R Under development (unstable) (2012-02-09 r58309) > Platform: x86_64-unknown-linux-gnu (64-bit) > > locale: > [1] LC_CTYPE=en_GB LC_NUMERIC=C LC_TIME=en_GB > [4] LC_COLLATE=en_GB LC_MONETARY=en_GB LC_MESSAGES=en_GB > [7] LC_PAPER=C LC_NAME=C LC_ADDRESS=C > [10] LC_TELEPHONE=C LC_MEASUREMENT=en_GB LC_IDENTIFICATION=C > > attached base packages: > [1] stats graphics grDevices utils datasets methods base > > other attached packages: > [1] BiocInstaller_1.3.7 > > loaded via a namespace (and not attached): > [1] tools_2.15.0 > > > > -- > ============================= > Juan L. Mateo PhD. > Centre for Organismal Studies (COS) - University of Heidelberg > Im Neuenheimer Feld 230 > 69120 Heidelberg, Germany > Tel: 0049 (0)6221 54 6493 > Fax: 0049 (0)6221 54 5639 > > -- > ============================= > Juan L. Mateo PhD. > Centre for Organismal Studies (COS) - University of Heidelberg > Im Neuenheimer Feld 230 > 69120 Heidelberg, Germany > Tel: 0049 (0)6221 54 6493 > Fax: 0049 (0)6221 54 5639 > > ______________________________**_________________ > Bioconductor mailing list > Bioconductor@r-project.org > https://stat.ethz.ch/mailman/**listinfo/bioconductor<https: stat.et="" hz.ch="" mailman="" listinfo="" bioconductor=""> > Search the archives: http://news.gmane.org/gmane.** > science.biology.informatics.**conductor<http: news.gmane.org="" gmane.="" science.biology.informatics.conductor=""> > [[alternative HTML version deleted]]
ADD COMMENTlink written 7.0 years ago by Vincent J. Carey, Jr.6.3k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 236 users visited in the last hour