Search
Question: Combat in gene pattern error annotation
0
gravatar for radhikaraheja
3.4 years ago by
United States
radhikaraheja0 wrote:

I am using the Combat module on the Gene Pattern platform to analyse qPCR data and correct for batch variations. I keep getting the following error that I cannot interpret :

Error in matrix(0, length(vec), nlevels(vec) - start + 1) : 
  invalid 'ncol' value (< 0)
Calls: parseCmdLine ... gp.combat.R -> ComBat -> design.mat -> build.design -> matrix
Execution halted

I would appreciate any help in figuring out what this means and how to avoid the error. 

 

ADD COMMENTlink modified 12 months ago by shaymaa_s_elgaafary0 • written 3.4 years ago by radhikaraheja0

It'd help if you included the command you ran. Also, at a long shot, how many columns are in your input matrix? Also, what's the scale of your input matrix? log2?

ADD REPLYlink written 3.4 years ago by andrew.j.skelton73310

I didn't run any command. I am using Combat on Gene Pattern and I don't have to write any code. All I did was upload my data file in a .gct format and the sample info file in a .txt format. I have 47 columns , It has just Ct values. 

ADD REPLYlink written 3.4 years ago by radhikaraheja0

It might be better to email gp-help@broadinstitute.org, as the bioconductor implementation of ComBat in the SVA package may well be slightly different. From the error you've shown, there seems to be a problem with the number of columns, but without more detail, I can't determine what matrix that error stems from. 

ADD REPLYlink written 3.4 years ago by andrew.j.skelton73310

Will it help if I sent the .gct file with the columns and details ? 

ADD REPLYlink written 3.4 years ago by radhikaraheja0

Sorry but I'm not familiar with Gene Pattern, I'd strongly recommend you use the above email address to contact the Broad, as it's their software. This forum is designed for Bioconductor support, and while the ComBat method is in a Bioconductor package, the Gene Pattern implementation is not. The error message you've provided doesn't really give any clues to the problem, other than checking the number of columns in your inputs, but a Gene Pattern maintainer may be able to give you more support. 

ADD REPLYlink written 3.4 years ago by andrew.j.skelton73310

Thanks for providing the email address . I already contacted them . Hopefully they can help me figure it out. 

ADD REPLYlink written 3.4 years ago by radhikaraheja0
0
gravatar for bhill
3.4 years ago by
bhill0
United States
bhill0 wrote:

The GenePattern team was able to resolve this in our mailing list.

The issue was extra spaces in the sample info file, and was resolved by reformatting the file.

 

ADD COMMENTlink written 3.4 years ago by bhill0
0
gravatar for shaymaa_s_elgaafary
12 months ago by
shaymaa_s_elgaafary0 wrote:

I have the same problem...how could you fix it?

Many thanks

Shaymaa

ADD COMMENTlink written 12 months ago by shaymaa_s_elgaafary0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 364 users visited in the last hour